USB 2.0, 3.0 or 3.1? Which is best?

I’ve found posts stating that the Pimax is compatible with USB 2.0 or 3.0, but has anyone noticed any differences?
Has anyone compared USB 3.1?
Any opinions, yet, on which is better for the Pimax? I would imagine that the answer would be the same for the 5k+ and the 8k, but maybe not…?

1 Like

I would stick with 3.0 or 3.1 if available for power & data stability.


The one advantage to not having the time to play with my Pimax is that I can get my “ducks in a row” for when I do!
This is getting ridiculous! Last night it was family car problems, today it’s a family car accident! (no one was hurt)! What the heck is next?

1 Like

USB operates at the lowest standard between the connected components for both power and bandwidth. The PiMax is likely only a USB 3.0 device, so plugging it into the 3.0 or 3.1 (revisioned as 3.1 Gen 1 and 3.1 Gen 2 respectively) should yield the same result. Only difference might be the USB controller performance where it may like one and not the other.

Usb-C suggests likely a 3.1 (but in the end it’s a connector) :laughing:

Where did you see Type C? But yes, you are correct in that it’s only a connector. I have been quite upset at previous phone manufacturers of mine that had Type C, but only operated at 2.0 speeds.

1 Like

Family car trip? (20 char)

1 Like

Bite your tongue! :scream:

The headset ports for accessories are Usb-C connections.

1 Like

FWIW, I have just experimented with different USB ports as I was having some difficulties with my Vive (and losing tracking and power management on some) and thought I might give Pimax a try too.

Originally I plugged my 5k+ to USB 3.1 (gen2) port on my motherboard (marked as USB 3.1 port in the motherboard manual). By originally, I mean it was the first port I used after I installed PiTool. My motherboard has x470 chipset, but this USB 3.1 (gen2) port is controlled by standalone ASMedia chip. I had no problem on this port which I could directly attribute to USB. I observed some stuttering, but it could have some other cause, even though the reported performance for CPU and GPU were nowhere near to full load.

Today I tried to plug Pimax to:

  1. other USB 3.1 (gen1) port (marked as USB 3.0 port in the motherboard manual). This port is connected to one of two “USB 3.0 Root Hubs”, but did not get it working. I tried restarting PiTool, restarting PiServiceLauncher, disconnecting HMD power and USB cables to no avail. What was strange, when I opened Device Manager (Win10 Pro 64bit), I saw that the USB devices related to Pimax were detected, then the drivers were correctly installed, and then disappeared, and then again. It also led to having mouse cursor stuck for short periods of time, basically making the whole OS unresponsive.

  2. my keyboard USB 2.0 hub. The reason was simply to try, because this is confusingly the only port where my Vive works without any problem (does not lose tracking, basestation power management over BT works). I however encountered the same problems as described above.

To be honest, I cannot say if the non-working over the other ports is simply caused by the fact that they were not the first ones used, or that they are inherently not working.

After debugging the problems with Vive, I have the feeling that either the USB support on my motherboard (ASUS ROG Strix x470-F Gaming) is a mess, or SteamVR USB support is a mess. Still cannot decide :slight_smile:


Ah, yeah, forgot about those. Biggest thing is what goes back to the computer, as that is the bottleneck, and iirc, is 3.0.

1 Like

I’ve had similar problems with the rift base stations where one would just ‘die’ 10 minutes into use unless I had it plugged into the ASMedia 3.1 Gen 2 port.

Also, have you downloaded all the latest utilities from ASUS’s website?

Not sure though my MB is Asus 450b rog strix board itx version.

Well that would be the question are these just usb 3.0 or Usb-A 3.1 cables. :beers::wink::+1::sparkles:

@anon74848233 can you check with the tech team if the headset USB is 3.1 or 3.0?

I find with my Samsung Odyssey + that it has problems on the USB 3.1 (ASMedia Chipset) port but not (at least with a powered hub between my 3m extension and my HMD) on the USB 3.0 port (Intel Z270 Chipset). Overall I’ve heard of more issues with WMR, specifically the O+ on ASMedia chipset USB ports.

1 Like

Pimax is compatible with USB 2.0 or 3.0

but 3.0 will be better than 2.0


My usb3.0 & 3.1 both caused problems with sound and also tracking since going usb 2 ive had no problem detecting l/houses in pitool and no random loss of sound


It could be the drivers or poor usb port design. In particular, MSI motherboards appear to have USB port issues. It might make sense to install a USB adapter card and ignore the motherboard ports, in that case.

1 Like

Just to add a fresh anecdotal experience. Just today I resolved a problem with Vive, I was looking into for several days (with Valve support). When I connected the linkbox into my keyboard hub (which exposes two USB 2.0 ports), the headset was working perfectly fine (no tracking problems, power management over bluetooth ok, etc.). When I connected it to the USB 3.0 port on my motherboard, I lost tracking after several minutes.

It seemed crazy - you added another USB hub between the Vive linkbox and the motherboard and it worked, you removed that hub and connected it to the same port directly and it stopped working.

Today I realized that it has been the USB extension cable I used to reach my keyboard and never removed when connecting the linkbox to the PC directly. When I removed the extension cable, the problems disappeared. Now, why it worked over the extension cable and the keyboard hub is another question, but I am not going to debug this further.

Just for the fun, I tried yet another extension cable (slightly longer and much older, also branded as “USB hi-speed”) and was not even able to reliably start SteamVR as the Vive HMD was not recognized in half the attempts and in the other half crashed shortly after.

So beware of those (cheap) extension cables folks!

1 Like

One possibility is that the keyboard hub has better power regulation (than the motherboard usb port) and that the Pimax headset has tight power tolerances. That is, the keyboard hub had a little more power, which helped compensate for a crappy cable.