Updated Pi tool today and bricked headset

So im pretty sad about this, but all i did was update pitool and it automatically tried to update the firmware resulting in a fail and bricked headset.
Cant do much of anything now.
Anyone know if any solutions for this?

Also just a suggestion would be to not ever automatically update firmware, that just seems like bad business practice.


They’ve ignored people telling them to turn that off.
as yes, it can cause issues if all of a sudden it forced a firmware update without you being ready and sure to do one… dangerous… but nothing has been done for over a year.


Luckily, it’s nearly impossible to actually “brick” a Pimax headset. You just need to manually install a firmware “dfu” file. This video is a bit old, but it walks you through the process. The video is set to start at the pertinent spot. For more info, just search the forum, for “dfu firmware download”.

. PIMAX FOR DUMMIES #1: Getting Started with Pimax 8K & 5K+, Tweaks, Hints & Firmware Update Tutorial - YouTube


This user created guy by @rygar1976 may help.


It is quite baffling pimax has not fixed this failed flashing that has iirc been an issue since was it 272?

The same with not using crc checksum verification that the file downloaded properly. This has existed iirc since DOS.

@PimaxQuorra please tell the team to fix the broken firmware download and release a patched 274 that doesn’t force a firmware update that maybe downloads the firmware in a Hmd model directory that also backs up the current hmd firmware in that Model’s directory.

You may want to file a ticket in case you need tech support. Link below.

PimaxVR Support

Main Site
  • Self Help Database
  • Submit a Ticket
PimaxVR Forum Support

This group consists of PimaxVR Staff Specialists for assisting PimaxVR Consumers with resolving Ticket.

Please follow this Procedure before Requesting help.

  1. File a Support :tickets: At
  • PimaxVR
    You should receive a response within x Business days.
  1. If you have not received a response after x Business days or Support personnel is having difficulty understanding your request. Please Direct Message(PM) this @PiSupport requesting assistance.
  • Please provide the following Information:
    Support Ticket # & Details of issue.

if your support issue is Tech related please explore:

  1. Use Docs in Left menu to explore 2 & 3.
  2. Pi-Guides & Troubleshooting. (#guides )
  3. Community Support - review Solved and post question if needed. (#vrcentral:helpme )

I’ve had the same issue for weeks. I finally got Pitool 274 to properly update firmware etc. First, I cleared out everything in my PC that was Pitool related. and rebooted. Next, I ran CCleaner reg cleaner to remove Pitool crap in the reg. I rebooted., and then I loaded Pitool 274…but I didn’t star it. I closed the window. Without Pitool running, I connected my 8kx and again, rebooted. Next, I started Pitool, it automaticly started to download the firmware very slowly. I kept thinking at any moment, the FAILED box would pop up, but it didn’t. Finally,…Pitool works without issue. I believe that rebooting between each step of hardware and software installing is what solved my problems. Try it. You might be pleasantly surprised. I was. Take care all…Eddie.


I forgot to mention, that when I first install Pitool and don’t open, I reboot again. THEN, I connect my HMD etc. etc. Lots of rebboting, but worth it for me.


I was able to get it fixed.
I heard somewhere that the hotas services caused issues, so i shut that service down,
then i downloaded the beta version of pitool, reinstalled and it auto started the update and worked this time.

Thank you guys for your help :slight_smile:


Specifically what hotas service?


I’m interested too. I have a HOTAS and I’ve also had update issues.

1 Like

@dogbite @neal_white_iii
This is the service i had to shut down:
Thrustmaster Hotas Service

Hope that helps :slight_smile:


Not having an issue myself. Just though the info might be of value to others. Thx for posting :smiley:


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.