Unity engine game problem with Parallel projection off

I love to turn off Parrallel Projetion off because the image is much clear and requires less resource.

Unity engine game normally works great BUT
objects are poping up on edge of the screen when I turn around.
I wish Pitool allow cover it with increase black edge or solve pop up problem. it really get annoying.

Unreal Engine game is just perfect. You don’t need to fix it anything.


Is the Unity emgine in game newer version?

yeah, blade and sorcery and onward , dungeon Knight… every famous Unity games.


Maybe reduce the FOV?

Curiously, I find this occurs with Doom VFR (awesome game for first person shooter lovers!) but only on the right screen. Left screen is perfect. Weird.


Doom I believe uses a custom engine as non vr doom uses one. But worth trying.

1 Like

the funny thing when I reduce FOV, then the poping up point is also reduce same as FOV, LOL


Well depending on how game dev programmed objects. It might thinking the object is being drawn off screen causing pop in.

Ah, that sucks. Gaffer tape over the lens? :rofl:


Do you have hidden mask enabled?

1 Like

yeah, no help, Is this happen only for me??

Cyube (nice UE4 game) is an example of a game with severe stereo disparity in normal fov, but fully functional in small fov

Dev confirms that’s a UE4 bug

Odd enough, with PP ON things get worse instead of improving

@SweViver I don’t know if you own the game, but you could pass this info to the PiTool devs.

1 Like

I believe that Dev has been visible on this forum as I recall trying to implement early fixes. After seeing Voodoode review after NDA release.

Hm… If it cannot be solved perfectly, then I wish devs add some option for covering more edge than usual in next built. In .180, it’s not fixed yet. Adding something like addition coverage option.