Unbrick procedure?

Well, “5) Improve the stability of the firmware upgrade.” is a bust.
Upgraded to 270, upgraded the firmware and now I’m bricked. Power indicator is flashing and Pitools won’t see it. Last message was “Restore failed, please contact customer support”.
Any ideas? Besides going thru customer support? I do not allow remote login’s so I suspect that customer support isn’t going to be much help.



Thanks for the info! Working on it…

After the step of uninstalling the Guillemot STM DFU Device from Device Manager, my headset became recognized and now seems to work fine. Attempting the DfuSeCommand.exe with the ‘0’ and ‘d2.fu’ arguments, leads to device not found:

Using PiTool to attempt firmware upgrade leads to the same message of ‘download failed, retry?’. This time I said ‘no’.

Am I supposed to enter some kind of ‘dfu mode’ before attempting this manual update? If so, what is the procedure?

Thank you for your help!

Trying to update the firmware from Pitool always fails me. I always do it manually. I have the DfuSeCommand.exe file package in a controlled folder, I put the firmware to update there and I launch it from CMD. The procedure to put the Pimax in DFU mode is the one that is usually known:

(minute 11:55) PIMAX FOR DUMMIES #1: Getting Started with Pimax 8K & 5K+, Tweaks, Hints & Firmware Update Tutorial - YouTube

I think you download it from: DFU Upgrade : Pimax Support.


Trust the customer support and open a ticket. In this case they will probably send you a firmware that will bring the system back to its initial state, and after that you can load the firmware you wish

1 Like

Got it working, but thanks for the input. I’ve only heard of customer support logging into the user’s computer to fix it so I was a bit ‘gunshy’. Next time I’ll give them a shot.

K I solved this by doing the following…

  1. I killed all Pimax related processes with [Process Hacker 2]

  2. I manually started the pimax service in powershell
    ““C:\Program Files\Pimax\Runtime\PiService.exe””

When you do this, it references the file its trying to load. something.dfu or… something.
(this seemed to be the issue)

  1. I found that directory, put the latest firmware DFU file in the folder – Then renamed it to the file it was looking for.

  2. killed all relevant processes. and then opened pitool
    (or you can just reboot… up to you)

  3. it then worked normal.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.