Trouble setting up Pimax & SteamVR for MSFS

Does anyone know how to set up Pimax, starting PiTool and which of the SteamVR’s to select after starting MSFS so VR will appear in the Pimax HMD?

I have tried starting SteamVR from the Steam program, SteamVR from the desktop and from inside PiTool in both places but I cannot get MSFS to start in VR mode (CTRL+TAB).

Also, which USB from the headset needs to be plugged into a USB 3.1 connection, the blue or white USB plug?

Pimax support suggested that I unplug my monitor and use the Pimax exclusively.

An explanation or link to a vid would be most appreciated.

Thank you in advance.

Let SteamVR off !! Start only Pitool. SteamVR goes automatic up, if you switch to VR in FS.

The Blue USB is for 3.x

@dstar Thank you very much for your reply, I will give your suggestion a try.

@dstar I followed your instructions. First off, I started PiTool and SteamVr and performed the room setup in each program.

I then started MSFS and waited for it to load into the flight planning screen and I started PiTool and SteamVR started automatically. Then there was a SteamVR error, after a restart SteamVR was stable. I then pressed CTRL+ALT and waited, after a few moments the OpenXR error appeared below. I got the same error when I pressed “Switch to VR” in the MSFS VR section.

I verified SteamVR and the “Current OpenXR Runtime” was SteamVR so that appears to be okay. When I reboot Windows 10 it will not load until I unplug the DisplayPort cable.

I will try to uninstall PiTool and SteamVR and try again.


It is important that SteamVR is always off before pressing Alt+Tab.

i always run pitool, power up hmd, then run msfs. then after clicking ‘fly’ on the world map, i launch steamvr using the pitool button and let it load, and then switch back to msfs and ctrl-tab.

if i dont run steamvr i get the same openxr message lately. in the past it has loaded automatically but was less stable that way.

also i have the same ‘must unplug to reboot’ issue, some pi firmwares in the past allowed it, most dont.


Start SteamVR, then on your desktop-
SteamVR Settings → Developer → SET STEAMVR AS OPENXR RUNTIME


A quick update, SteamVR error as above appeared each time I tried CTRL+ALT to start VR in MSFS.

I restarted the PC with the Pimax HMD turned off and only started it once Windows 10 settled. I changed USB ports (tried many USB variations) then I started Pitool and SteamVR once MSFS was in the main flight creation screen.

Sure enough SteamVR connected and I was able to launch MSFS in VR mode using the key combination. I started OpenXR so I could change some settings as per some vids I have seen but the UI in the VR headset was fixed to my head movements making any adjustment changes impossible.

I shut everything down and looked into a way to mirror OpenXR on my PC display so I wouldn’t have to do it while wearing the VR headset. Once I was satisfied that I had found something (reg edit) I repeated the whole process but kept getting the SteamVR connection error. No matter what I tried it would not connect. From one instance to another things changed completely. Once SteamVR appeared to stat connecting the Steam client failed and required a restart but by then SteamVR failed.

I have spent over 130 hours trying to get this all working and it is really getting frustrating. I opened a ticket with Steam and have sent a few logs that they asked for, I hope that the issue is resolved once and for all. The Pimax unit cost me a lot of money and it has only been a bookend since last September.


I see there is a Steam runtime in the registry, does anyone know if there is a registry key for pimax openxr runtime? If there is one could you provide it?


1 Like

I don’t understand some things… OpenXR Settings? is it possible that you still have an old WMR software with OpenXR on the computer?

It has to get off the computer because it overrides the SteamVR OpenXR environment.

WMR has been uninstalled but there are lots of entries in Windows Registry. I will see if I can remove the registry entries.

Yes, in addition to SteamVR users can install the OpenXR Toolkit and make setting changes with it to improve graphics in VR. Below is an example showing someone using it to change settings:

The Toolkit makes not problems. This is only a PostProcess.
Has nothing to do with OpenXR himself.

That’s pretty much the way I start up for a VR session except for changing USB ports. My Pimax is plug into it’s own USB 3.1 which has a separate controller than all my other USB stuff. I only start Pitool if I need to change configuration such as parallel projection as SVR remembers last setting.

MSFS is beta and VR is an after-thought and there was a point when it would likely crash if you tried to enter VR anywhere but in the game (in the cockpit).It is mostly solved now i think.

Not sure why you took 130 hours to get it working but it isn’t a Pimax issue. Can’t speak to the Toolkit being an issue but since you weren’t getting VR to work as suggested by your first post, I kind of wonder why you were messing with a 3rd party tool before getting the basic sim up in VR. Or did I misread?

Glad you got it working.

Yes exactly. I checked the registry and found that none of the WMR modules were initialized. The Steam Client froze leaving SteamVR hanging then eventually it crashed. I uninstalled SteamVR and PiTool, rebooted then installed again - PiTool v277 and the latest SteamVR Beta.

@dogbite - So you do not run PiTool? Once in the cockpit you just press Ctrl+Tab? Interesting. No, you did not misread, I tried OpenXR Toolkit the 2 times that I got VR to work in the last week or so.

I think the issue is more Steam related as the client would crash as SteamVR was initializing.

I’m expecting Adonis from Pimax to dial in to my computer this week and I have a ticket logged with Steam Support. I posted a thread at the MSFS forums expressing my disappointment with the lack of support for Pimax.

Correct. You might leave it on if for example you were adjusting the Pimax for brightness and contrast and such but PT doesn’t need to run if your last setting (Steam games) are the same as for the game you are about to play. For that matter, once you launch SVR you can close PT if you want until you wish to make changes.

As far as crashes go, the sim would crash “if you looked at it side ways” in earlier builds but except for 1 lock up. this build has been fine so far for me. ymmv

That said. We all have different hardware, different cpu, (clocks and ocs) bios, ram (speed and amount) power supplies, gpus and their drivers, different OS configs and different software installed, etc. We are running a very beta Sim on VR hardware, many using different hmds and PT drivers/firmware (can’t remember the last Pitool that wasn’t beta) on the Steam platform which is always upgrading SVR on differing gpus always updating their drivers. Changes in SVR drivers or Pimax drivers or the gpu drivers an alone may upset the VR task they share in creating.
Given that and so much more, I suspect you shouldn’t blame Steam either. It’s a group effort.
I have computer gamed since before pong and from there to what we can do at home today…I am surprised it works as well as it does, given all the complexity and variation now. :joy:

You’re right, Steam has not locked up and SteamVR started without a hitch. I did not know that PiTool wasn’t required. I will try it using your startup method. I don’t know why I keep getting the OpenXR error in MSFS, I made sure that nothing from WMR was active in the registry.

I don’t look at MSFS as being a beta but it makes sense given all the work that was done and is still needed to bring it up to snuff. After having a few glimpses of what it looks like in VR I can’t give up on it.

Hopefully I will get it resolved in the next week or so.

Thanks for your feedback so far, as with everyone else who has responded; I really do appreciate it.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.