Tried to upgrade firmware on crystal from 1.3.0 au0915 to v1.3.0 au1103 but it says my battery is to low

my batteri is fully charged … anny tip_+

Restart the computer,
That was the case for me too, after a reboot it worked…

restart pc , dosent work . thnx for tip

the strange thing is the battery % is not showing in software.-

is it possible to use duf? manual install the firmware like 8kx?

Connect the crystal directly to the PC without a USB hub. then reboot then it works, I mean that’s how I did it…

Stil not working, hmm
trying to swap batteries again

USB C on the side of the crystal is also connected?

that’s really weird…

ye usb-c on the side is connected

maybe full re install the software . i gonna try it

not working with re-install the software. i give up . used to much time in my life to get this pimaxian to work .

open a ticket and please let me know if there is a solution

I have it now:

  1. reinstall old Play software (PimaxPlay V1.16.01 )
    2.Firmware update the Crystal
    3.Update PimaxPlay

Have fun

1 Like

thank you…