Tracking stabilization issue?

After a while of using pimax artisan, i noticed the vision is “jumping” back and forwards as if it’s always trying to correct it’s tracking position when headset is clearly visible for both base stations and is stable on the table, (no reflective surfaces in the room). Imgur: The magic of the Internet

Is this normal?

I didn’t experience anything like this with valve index.

1 Like

No, that does not sound normal.

You say they are “stable on the table”. Are they just sitting on the table or are they mounted (screwed down or attached with clamps or something similar)? The base station contain a motorized mirror which, is subject to vibrations. They need to be affixed in some way.


Sorry, I meant that the base stations are firmly mounted on the walls and headset is just placed on the table.

1 Like

OK. It definitely sounds like a real issue, but (unfortunately) I don’t have any suggestions, other than to contact Pimax Support: Support : Pimax Support

Good luck! I hope there’s some simple fix that I am not aware of.

1 Like

I suggest trying the same test with each base station alone in the same positions. Turn one off at a time then test. This way if the issue is an issue with one of the base stations you can isolate it. If the issue appears with each base station alone then it’s possible it’s a headset defect.

Next test would be to move the base stations around. Keep in mind that the sensor locations on the headset are different than an index or vive so moving the base stations can have an effect.


Thank you for your reply. Just finished all of your suggested tests and I gotta say, nothing’s changed. Is sending it back for RMA really the only option here?

1 Like

Next step is to create a ticket with the team, mention the tests you have performed to speed the process along.

1 Like

Make sure You don’t have any RGB lightning software (like ASUS Aura) running in the background… :wink:


I would retest with the index if you still have it. If no problems, retry the pimax. Disconnect the Pimax completely and rebooting before restarting each. Try the pimax on and be sure it is effecting game play.

1 Like

Quote from another post that cured a loss of tracking issue. May help you

1 Like

If none of that works you have to try reinstalling steamvr and or pitool. Then … IDK

Feeling found this issue, but other pc has auto movement although using 9axis.

Try to change the power source, may electric power make the headset to not stable.

It look the base station 1.0 is stable than 2.0

-Few days ago I retested index with my lighthouses. No shake at all.
-I tried all electrical sockets in the house, no change, pimax artisan still shakes.
-I did try reinstalling PiTool different versions and SteamVR, no change, still shakes.
-I checked 6-7 times now for reflective surfaces. They are not present within the room.
-Moments ago, pimax employee (with teamviewer) tried to up date tracking on headset (2018version) and check for tracking statistics. He said all seems to be good and that’s it’s unlikely that I’ll get a replacement.
-I tried putting lighthouses in different places, even different surfaces, no change, still shakes.
-SteamVR is unable to sleep. Whenever steamvr goes to sleep, it will wake up within 10seconds due to shakyness of pimax artisan. As I write this update, I have steamvr running and I saw ~10times “vr view” screen go black (to sleep) and almost instantly wakeup afterwards

That’s my update. A great headset with a major… MAJOR flaw.

@Heliosurge @PimaxQuorra @PimaxUSA

1 Like

It sounds like something is effecting the timing of the flow of usb data. Do you have another pc to test with (for purposes of this test you don’t need a good video card, just something with DP 1.4). I know it’s a hassle but the ultimate test is a clean install of windows, then pitool and steamvr then test.

1 Like

Do you see any log messages in the web console when this happens?

It could be caused by the optical sensors on the headset, which are:

  • faulty
  • not calibrated
  • miscalibrated

and the poser cannot pinpoint the fixed position.


What is this web console you speak of?

When you run SteamVR, navigate in the main menu to Developer, there is a Web Console. It is basically a web page connected to local server (some process from SteamVR family), which provides online log messages from all subsystems. You can use filter to filter only some, or look for particular word, etc. You can also use to change SteamVR settings in a consistent way.

It is quite handy tool to debug SteamVR problems.


Thanks, very useful, i’ll take a look.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.