Tracking issues

It was working fine until yesterday. My lighthouses track my controllers just fine so I doubt they are the problem. In the pimax play UI the lighthouses flash green sometimes and I dont know what that means. ive tried flashing new firmware but that doesnt seem to change anything.


That last one is really confusing to me. there doesnt seem to be a “helmet interface” section in the settings and I have no idea what this lighthouse locator function is. It stopped working while I was using it, was very strange. Ive tried reinstalling pimax play, reseating all cables including the one in the headset itself, rebooting my PC, flashing new firmware, nothing seems to work. Diagnostics shows no issues whatsoever and I really dont know what to do. Ive tried contacting support but I cant seem to get through to anybody.

1 Like

its gotten worse. I tried using an older version of the firmware (m296 to be specific) and im pretty sure Ive bricked the damn thing. its stuck on a white light and trying to manually push new firmware with DFUupgrade doesnt work and plugging in the USB3 cable windows says it cant recognize the device. I think this headset has officially become a paperweight.

okay ive managed to flash the firmware after who knows how many hours of fiddling but it still wont track. in the pimax client UI the base station will occasionally flash green so I know it can see them its just not tracking for some reason?


When the base station is displaying a flashing green light on the Pimax Client UI, it indicates that the headset is not sensing the base station. To address this issue, you can try deleting the lighthouse folders located at:

C:\Users\ your username \AppData\Local\Pimax\runtime\config\lighthouse

After deleting the folders, proceed to pair both base stations again to see if the problem is resolved.

That was one of the first things I tried, but to be sure ive done it again and still nothing. Also this that filepath is incorrect, thats for old pitool installations not the new pimax play client. with the new client lighthouse configs are stored in C:\ProgramData\pimax\runtime\config\lighthouse

Here is the list of things ive tried:
Reinstalling the pimax client
Flashing new firmware
Rebooting through lighthouse console
Reseating all cables
reverting to the old pitool
And some other things im probably forgetting. trying to fix this has been my weekend.

I do also get this error in the lighthouse console which MIGHT be relevant. “Userdata error”

I really dont know what more I could do, Im at a total loss here… I almost want to believe its a hardware fault the lighthouse receiver devices are right there.

ANY help would be really appreciated, and bless you for responding.


What is the current firmware version for your 8KX headset, is it M299?

You may also consider attempting the following:
Disconnect the PC from the power source, then recycled power.

currently flashed to 2003, previous power cycle have done nothing but ill try again. I will report results shortly.

1 Like

no change in behavior from a power cycle.

It appears that the wrong firmware was flashed, resulting in the headset being bricked. Please only flash firmware versions starting with “200*.” Avoid flashing any other firmware that starts with “M2**.”

Our developer has checked the command and found everything to be in order.

If there are any electronic gadgets near the setup, please make sure to keep them away. Additionally, if you have a sim rig, ensure that the cable’s position is not too close to the headset, as it could interfere with the connectivity.

And not forget to mention that, Apple Watch can caused interference.

1 Like

I thought I was pretty clear that I was on 2003?

1 Like

id hope its not incorrect, I got the firmware from you

1 Like

Also no electronic devices near the headset, I use it for roomscale. it sits in the middle of a mostly empty room.

I also didnt flash any new firmware until after it stopped tracking as part of troubleshooting.

This is the correct firmware.

Flashing the M299 firmware will result in bricking the headset.

How about switching the tracking to 9-axis, then toggle back to lighthouse?

1 Like

Ive tried that, headset works fine in 9axis. But I use this headset for roomscale so thats not really a solution. Switching it back and still the same issue.

I apologize if im coming across as a bit snappy. This has been very frustrating and I do appreciate the help.

1 Like

AH, it is worth noting though, pushing the restore button to return all settings to default makes the lighthouse/9 axis section go kinda screwy. It enables 9 axis, then neither are selected, then it goes back to 9 axis.

I have also tried pulling the firmware logs but when I push that button it just seems to hang forever without actually doing anything.

No worries man.

My recommendation would be to submit a ticket and let our technical specialists perform a thorough troubleshooting of your device and system setup. They will be able to provide more effective suggestions once the troubleshooting session is complete.

1 Like

Alright so ive gotten no response from support as of yet but I have SOME new information

the sensorcheck command in lighthouse console shows some activity so… something is happening. its a bit over my head but the sensors on the headset are reporting something so thats… something. I also have this.
again, kinda above my knowledge here only one of the USB devices in the headset seem to be doing anything at all.

Ive also tried resetting the board through the lighthouse watchman update but that seems to have done nothing.

Im kinda at my wits end here. If someone could get me in contact with a support agent or something it would be much appreciated. my support ticket is going on 5 days old now and ive still not got a single response.

maybe go back to the “old” pitool
you might try to temporarily cover any surface that might reflect the IR from LH’s
also try to lift the headset from the desk move it slightly (slow) in a way that both LH’s can be seen

1 Like