Tracking Issues April 2020

Date: April 5th, 2020
Issue Title: Tracking Issues with Index Controllers and Pimax 8K+
Description: Index Controllers will drop out for 0.5 seconds for no reason, even more when moving the controllers. This happens even without playing any games, and happens in Pimax VR Home too. This issue ruins playing games like Beat Saber, Pavlov, Half Life Alyx, and using software like OVR Toolkit. I have tried switching USB ports on the Pimax, even to a dedicated USB PCIE expansion, and the issue is still there. I have even tried restarting my computer and headset, and the problem still happens even after a restart. I would NEVER have this problem on my HTC Vive and Valve Index, plugged into the same ports and everything.

I strongly believe this is a problem with the receivers in the Pimax headset, or the software.

HMD Model: Pimax 8K+
First 3 Numbers Serial: 206
Pitool Version: V2020.3.24
HMD Firmware: V2.1.255.260
Tracking: 4 Lighthouse 2.0’s. I am using the same non-reflective room, with no WiFi or bluetooth, that I used with my HTC Vive and Valve Index. Tracking was never an issue with them.

System Info

  • Windows Version : Windows 10 1909
  • CPU: AMD Ryzen 2600X
  • RAM: G.Skill Aegis 16GB DDR4 2933 MHz
  • Motherboard: MSI B450 Tomahawk
  • GPU Model: EVGA RTX 2070
  • GPU Driver: GeForce Game Ready Driver Version 445.75
  • SteamVR Version: 1.10.32

attached controllers screenshot for firmware/other info

3 Likes

Anybody got any feedback from Pimax on this?

@Alex.liu

1 Like

Should be a pretty big priority imo. Especially since they’re sending out more controllers

2 Likes

Date: Every day since i got the headset. So over a year.
**Issue Title:**Index Controllers glitching in Beat Saber and other games
Description: Controllers will loose tracking on fast pace movements. This behaviour does not happen when i use my Index. Mostly left controller but sometimes right too. Controllers and base stations are up to date.

HMD Model: Pimax 5K XR
First 3 Numbers Serial: 201
**Pitool Version:**Currently 2020.3.24, but had issues on all of them
HMD Firmware: V2.1.255.255
Tracking: 2-4 Lighthouse 2.0’s. Doesn’t matter if i use either 2 or 4.

System Info

  • Windows Version: Windows 10 Build 1909
  • CPU: AMD Ryzen 7 2700X
  • RAM: G.Skill Trident.Z RGB 3200Mhz CL15
  • Motherboard: ASUS Crosshair VI Hero
  • GPU Model: GTX 1080Ti
  • GPU Driver: 445.75
  • SteamVR Version: 1.10.32
  • Oculus Version: Not installed.

Covered anything that is “reflective”. Tested with Index to make sure it’s not related to any of my other hardware. Already narrowed it down to either the hardware or software. My guess is hardware, since using one controller via USB-C on the headset seems to fix most of the issues.

2 Likes

Date: April 9, 2020
Issue Title: Tracking Issue with Index Controllers and Pimax headset
Description: left controller briefly loses tracking and/or connection with the headset, resulting in hand flickering and dropping of item in hand. It happens intermittently, but on average at least once per minute. Waving the left hand quickly will always cause it to happen, but otherwise it appears randomly. The issue does not occur when I use the controllers on my wireless Vive Pro using the same computer system, so it is not an issue with the index controllers.


HMD Model: 5k+
First 3 Numbers Serial: 203
Pitool Version: 1.0.1.255
HMD Firmware: 2.1.255.255
Tracking: 2x LH 1.0, 5 m apart diagonal, 2 m high


System Info

  • Windows Version: 10.0.18362
  • CPU: i7-7700 @4.2 GHz
  • RAM: 16 GB DDR4 3200
  • Motherboard: MSI Z270 Gaming M3
  • GPU Model: MSI RTX 2080Ti
  • GPU Driver: 445.75
  • SteamVR Version: 1586022601
  • Oculus Version: 15.0.0.200.456

Attachments (Pics/Video etc…)

2 Likes

Date: April 9th, 2020
Issue Title: Tracking Issue with Index Controllers and Pimax 5k+ headset
Description:

  • Today i’ve received my Index Controller and got immediately disappointed by using them in combination with my Pimax 5k+.
  • If I am playing Beat Saber (or any other VR Game), the Index Controller ‘disappear’ for < 1 sec and reappear immediately. This happens a couple of times every minute.
  • The Controllers are NOT usable that way with a Pimax Headset!
  • The Controllers DO work without any problems with my HTC Vive!

HMD Model: 5k+
First 3 Numbers Serial: 203
Pitool Version: V2020.3.24
HMD Firmware: V2.1.255.255
Tracking: 2x HTC Vive Lighthouses (v1)

System Info

1 Like

Here is a followup on the issue. You can see a lot of tracking loss.

2 Likes

I got a reply from Alex.liu of Pimax Support.

He’s been doing multiple comparative experiments and is contacting Valve directly. So I guess he managed to replicate the issue. I’ll keep you up to date if anything comes up.

12 Likes

That’s great news. If he needs some more proof. Today i tried to play and it was worse than ever. Here is the video:

This issue can’t go longer like this, We all know it’s clearly something in their hard/software and it just has to stop. I’m giving this one more month or the Pimax is going to be either sold or binned. I’m done with it.

3 Likes

WORKAROUND No. 1 via flashed valve steam controller dongle

I’ve solved the problem for now by flashing my Valve Steam Controller into a Watchman Dongle:

And connected my right index controller to the dongle and the left one to my Headset. Since then i have no problem with the controllers.

In case you want to flash the Dongle back, so you can use it again for your Controllers, here’s the manual to it:

And in case you don’t want to bother yourself flashing your precious valve steam controller dongle, you can buy a substitute here:

Note: I’ve read somewhere else that you need one dongle per controller, but i haven’t tested that yet.

WORKAROUND No. 2 via cable

Some people using a USB-C Cable, connected to the upper or lower USB Port of the Headset and connect the other end to the USB-C Port of one of the Controller. Might not be the best Solution for those who hate cable, but it seems to work too.

3 Likes

This is all fun and stuff. But these wireless dongles are $80 shipping to the EU…
Playing with a cable is not an option on fast pace beat saber. Either Pimax should supply dongles as a temporary fix, or actually fix the headset itself.

You do indeed need 1 controller per dongle since these are made for the body trackers.

1 Like

Don’t get me wrong, i am on your page. I wish no more then Pimax fixing this issue so i don’t have to buy or repurpose existing (and working) hardware on my side. But until then i only wanted to give a summary of all workarounds i’ve found so far :slight_smile: So that others are aware of them and at least have a option (beside throwing their gear into the corner or even leave VR completely which nobody from us wants)

With a cable it is better but for me the problem is not gone. My hands don’t dissapear anymore but they still move away for a second.

Update: I moved one of the lighthouses (1.0) and now the cable solution works! Without the cable my gun still dissapears in Alyx so Pimax still has something to works on and I hope they find a solution soon.

Sad to hear this workaround didn’t work for you. Not sure if this is a problem with the workaround or if its something else, like a deadspot where your lighthouses don’t see the controller, or even if a sensor of the controller is defect. There are manuals out there how to test this…

1 Like

@Arno In case you are worried about the index controllers being faulty, you can test the individual sensor count and view sensor readings. This works for the HMD and the controllers.

3 Likes

Hey Leonardo, it’s one week since the last life sign from you here in this thread. Any news from Pimax you’ve received since then? Or did they went silent?

Silent I’m afraid. I’ll email him. He’ll see the email next week probably.

2 Likes

I got adviced to e-mail @Alex.liu by Pimax Support but haven’t received a response yet. We will see what comes out of it.

Date: April 22nd, 2020
Issue Title: Tracking Issue with Index Controllers and Pimax headset
Description: When playing any game, one or both my Index controllers will lose tracking and seemingly teleport to the center of my playspace and back very quickly. Sometimes it will go out of the map for as long as 5 seconds and come back. I’ve noticed that waving my hands in front of the headset might help snap them out of it but I’m not totally sure of that. I can sometimes play for up to a half hour without it happening, then it’ll just randomly start to happen for 30 seconds or so on and off.

HMD Model: 5K+
First 3 Numbers Serial: 203
Pitool Version: 1.0.1.255
HMD Firmware: 255
Tracking: 2x LH 1.0 / 10 feet apart in diagonal / 7 Feet High

System Info

  • Windows Version : Windows 10
  • CPU: i7-5820k
  • RAM: 16Gb DDR4
  • Motherboard: ASRock Fatal1ty Gaming Fatal1ty X99X Killer
  • GPU Model: EVGA GTX1080Ti SC2
  • GPU Driver: 442.19
  • SteamVR Version: 1.11.11
  • Oculus Version: N/A
1 Like

Latest email update from Alex:

I am sorry for my delay because i was still do a lot of comparative experiment. Include the different headsets( HTC/PIMAX/INDEX) , controllers , base station,

even the different batches of the same model helmet(Pimax 8K Plus)

Preliminary judgment is that it seems has some compatibility issue between the index controllers and dongle of Pimax.

I already told my colleague to get some help from Valve .

Best wishes!

11 Likes