The GPU utilization boost is not only working with DCS World, it works in SteamVR games too!

Hey all! Have you seen my video about DCS World getting more than 20fps more with one click of a button? It seems like its not about DCS World but its either a GPU issue, software issue or Pimax renderer issue. I get very similar performance testing Hellblade VR trying to use medium to high settings and 110 resolution scale.

I have reported this to the Pimax devs already :slight_smile:

It also gives me different results whenever I have vsync on AUTO or OFF in Nvidia control panel.

Once I jump into MENU, the utilization almost always go down again…

ALSO, as you can see. It works using Afterburner as well :slight_smile:

Here Im using Nvidia Vsync at default mode:

Here Im running with Nvidia Vsync OFF in Nvidia control panel:


Nice find ! We have to make Elite start directly from Pitool !


I would say the chances are big this will work in ED as well, directly from SteamVR. Cant test at the moment, but will do later



What are the differences between both VSYNC mode (apart from the obvious >__<) ?
From what I can see, the GPU utilization seemed to be ok at first, but dwindle only after the second time you displayed the menu.

Btw, you just ruined my vacation, now all I think about is to come back and test it on Project CARS 2 n__n


Ok so what is the fix please. Also what is the count down on your YouTube page? Says you are doing a live stream at 12pm est


Yes as soon as you go into main menu it screws up. Probably because the menu uses a different renderer (menu doesnt need PP on).

Haha I will test PC2 now :slight_smile:

Yep announcement coming up! :slight_smile:


Can you help test the effect of IL2?


Hey nice one @SweViver!

If this boosts DCS some - hell yeah !
(Now imagine Eagle Dyn actually pimps the engine like announced!! )

Are there any other options to check? Like the pre-rendert VR Pics? Its default on 1 for me…


Im in the process of testing some other games but been a bit busy today so I couldnt test much.
Tried Project Cars 2 (only with SteamVR) and it gave indeed above 10fps more.
Elite Daagerous had a smaller impact as I remember. Maybe 6fps or so.
It seems to be affecting most games that doesnt utilize the GPU from start.
Also got some reports that it also works to boost on Oculus Rift.
This must be an evil Nvidia glitch lol

1 Like

Do you have a monitor with Gsync connected to the PC by any chance ?


Oh btw. In Project Cars 2 even if the fps increased with 10 or more fps, I got a lot of flicker so it was not usable.
But smart smoothing was really working great on 5K+ after applying that fix! No judder no flicker at all.


Yes but I have disabled Gsync. I still use 144Hz mode though on one of the screens

I never have gsync active as i never play flat games hehe


I always had that “feeling” that Gsync can/could impact in some way with VR.

I will try to test this too. Looking forward to todays announcement.

1 Like

When I run VRMark the program says V-Sync has to be off for optimal performance …


It worked with me (I have a Pimax 5K+) jumped from 37/38 fps to 55 fps. With some little interesting differences:

I couldn’t run DCS without SteamVR, even by importing in PiTool, so I replicated this trcik with SteamVR on.

I have to keep Smart Smoothing ON, otherwise in the HMD only, I see a lot of ghosting…

I have an RTX2080ti blower edition, so high temperatures by default already. I didn’t have it overclocked , but to trigger the trick I used MSI Afterburner by overclockin a little bit and then RESET:
1 - increase a little the Core clock (+30MHz) and Memory Clock (+30MHz)
2- Increase the TempLimit to 89 degrees
3- Click on RESET

Thanks @SweViver !

PS. Any idea on how to block SteamVR when opening DCS from PiTools?

You can uncheck “Start SteamVR automatically with applications” in SteamVR, then you can start DCS by desktop item without SteamVR running in the background.

Does it start the 2.5 Beta of DCS? I tried it but have not gotten the full effect. @SweViver - if you find the time, could you maybe post a screenshot of your settings in DCS, Nvidia and Steam? I have similar hardware but go around 45 FPS - must be missing something (I do have a g sync monitor running…)

Nice find @SweViver. Hard to believe such big bugs go unnoticed and cause us pain. Hopefully this will get addressed by whoever is responsible for this bug, sounds like Nvidia to me.

1 Like

I’m using DCS beta version. I have similar DCS setting as SweViver show in his video but with Water to High.

Thanks @R.M, it worked as you said, only from the desktop icon!

I’m still not sure what the fix is here. Start the game through PiTool and have VSync disabled in NVidea?