Sword Controllers: first impression

Got my Sword Controllers today! They do the job, but are weird - kinda like a halfway between Quest controllers and Index Controllers. Tracking seems perfect, the huge rings mean there’s never any occlusion. When I first set them up, the left controller trigger glitched so it didn’t work right, but after I charged the controller up to full power the problem went away.

I definitely miss analogue sticks, especially in Half Life Alyx - it’s hard for me to press the exact front of the touchpad with my thumb for maximum walking speed, so normally I’m walking super slow with these. I like the hand straps, and the light on the front looks cool (though I rarely see it since I’m using the headset while using the controllers). I haven’t actually run into the issue yet, but some Oculus games use a B button, which the Sword controllers don’t have, and I don’t think you can remap the controls if you aren’t running in Steam. But until I actually run into the problem, it’s not a problem :slight_smile:

So far I’ve played Half Life Alyx, Beat Saber, and Audica (Rhythm light-gun Shooter) with the new controllers; all three worked well (minus the running issue in Alyx).


Ah the old laments about the missing stick and button. Could buy the 12K and get those features IF the renderings of those controllers are to be believed.

1 Like

I dunno about old laments, I only just got the Sword controllers myself, this is my impression based on the experiences with other VR controllers (I’ve used Vive Wands, Index controllers, Oculus Touch and Quest Touch, WMR controllers, and the horrible PSVR Move controllers, which don’t even have a touchpad). I actually don’t mind touchpads except for the specific issue in Half Life Alyx where I can’t move forward at full speed with the Sword Controllers unless I take my other hand and press on the forward-most bit of the touchpad, since I have problems accurately reaching across to that point with my thumb. I might be able to adjust that in Steam’s controller settings or maybe the game settings, but it’s a controller issue that has to be worked around.

What’s not to know? Most of the vids and articles so far mention the stick caveat and quite a few the missing button.
I wasn’t judging your early review. Only acknowledging your not alone.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.