SuperDepth 3D/VR + Virtual Desktop (Tips)

For those looking to add stereoscopic rendering on a large virtual-screen, and don’t care about motion-controller support etc, you can use SuperDepth 3D/VR with any game that supports ReShade. Support has gotten much better with ReShade 5.x, and SuperDepth has matured a LOT over the years and now produces results that nearly rival G3D in some titles; with very low distortion and natural-feeling depth, as long as you don’t push the depth too far.
I’ve played with a number of solutions; the maker of SuperDepth makes a basic VR viewer; Vorpx desktop viewer supports SBS mode, but currently the fastest solution I’ve found is Virtual Desktop (available on Steam). This used to be one of the slower options, but updates have made this much faster and I’ve found I can push many very modern AAA titles to 60fps at 4K. It’s also got a lot of controls I like; screen curvature etc. and it supports a few different 3D modes (SBS, Top and Bottom, etc.)
Instructions/Tips:

  1. Download Virtual Desktop (Steam)
  2. Download ReShade 5.x ( https://reshade.me/ )
  3. Download SuperDepth ( https://reshade.me/forum/shader-presentation/2128-3d-depth-map-based-stereoscopic-shader )
  4. Install them as per instructions ( Install ReShade to correct game directory then manually copy-in the latest SuperDepth3D & VR shaders. You do NOT need the basic “SuperDepth” shader available directly in the ReShade distribution as it’s extremely limited in function. )
  5. Launch Virtual Desktop and assign hot-keys so you can toggle SBS mode easily (you’ll see the option on the main Virtual Desktop screen). Set the other Virtual Desktop options as you desire.
  6. Run your game as usual and you should now see the game on your HMD
  7. Do the initial ReShade setup ( default for overlay is the “HOME” key )
  8. Choose SuperDepthVR unless for some reason a title works better with SuperDepth3D.
  9. Turn on the SBS mode using the hot-key you set in Virtual Desktop
  10. Have fun playing with the SuperDepthVR settings. I suggest using the Saturation and Sharpening built-into the SuperDepthVR settings (towards the bottom). You may also want to try reducing the default depth a bit, as I find the default amount of depth will produce more distortion than I like, and the 3D effect is often still quite acceptable with that setting turned down a bit. You’ll see there are a LOT of settings in SuperDepth3D/VR, and every game is different, so you may need to play around quite a lot to get things perfect; what works great for one game may not work well at all in another. ( Cyberpunk, for example, likes the depth-balance (near <> far) pushed way, way out which is very unusual. Try 250 on that with a depth amount of only 10 or 15. )
    Recent titles I’ve tried that work well with this Virtual Desktop / SuperDepthVR solution are Detroit: Becoming Human, Greedfall, Cyberpunk, RDR2 and LiS3.
9 Likes

Also just tried this tonight with The Witcher 3 and the new 1st person mod (it actually works! Gervant First Person at The Witcher 3 Nexus - Mods and community ) and fantastic results again. Like Cyberpunk this game seems to like very strange SuperDepthVR settings. I’m using a total depth of only 8, but the depth map adjustment set all the way out of 250, and other than more distortion during certain cutscenes (not too many of them so far) than I like, it’s looking and running great. All settings set to max (a few post-processing effects that I don’t like turned off though), 4K game resolution, HMD set to 60hz and so far I’m getting 60fps without issue, with GPU usage in the 60-90% range. You may also try the default SuperDepthVR settings for this title if you want (SuperDepth3D/VR have profiles for many games built-in so you don’t have to manually configure everything.) That produces good results also, if maybe a bit exaggerated 3D in cutscenes.

1 Like

I got it working with Daytona Usa 2 via Supermodel emulator.

I have a 32x9 monitor so the virtual screen curved around me 180 degrees

going into first person with the 3d depth basically felt like a real VR game.

2 Likes

Appreciate for you nice guide!
Please check the PM for a gift card as guide reward

@hammerhead_gal Thank you! That’s really kind of you.

I’ve delved into really tweaking the SuperDepthVR settings for TW3 with the new first-person mod, as first-person was always the way I wished I could play The Witcher games. I’ve come up with the following settings that appear excellent to me on my 8K-X. I’ve left out any settings that are unchanged from defaults, so you should only need to change these specific settings to get the same results. Note that when you switch from 1st person to 3rd person the depth-map changes a lot, but you’ll probably only do that on horseback, so it’s not too big a problem.
Witcher 3 SuperDepthVR settings:
Divergence Slider: 35ish (this setting is very much a ‘personal taste’ setting)
ZPD Balance: 1.000 (this largely fixes the ‘too much depth in some cut-scenes’ I mentioned in an above post)
ZPD Boundary Detection: BD1 Full
View Mode (Occlusion Masking): VM3 Stamped
Depth Map Adjustment: 25
Saturation: 0.200
Other settings: 1st Person Mod FOV setting: I like 90 best
In-Game sharpening: High (I find this provides plenty of sharpness so I don’t have to use the SuperDepthVR “SmartSharp” feature.

1 Like

Would be kind of cool if Luke would tackle this game next.

1 Like

@LukeRoss Do you take suggestions? (I agree that, with this new excellent 1st person mod, that TW3 would be a great title to VRify. It should also run well as it’s a slightly older title.)

A small update: It used to be possible to enable PiTool Smart Smoothing functions in conjunction with this solution (and other similar solutions) and results were acceptable (some warping where the virtual game screen rendering met the ‘frame’ you had chosen, but otherwise worked like you would expect). This is no longer possible due to the 1/3 refresh-rate Smoothing Method. Everything goes completely out-of-sync as soon as the 1/3 rate kicks in, and with no way to disable that it means you’ll be left with no option but to run this solution with Smart Smoothing off. Since you only need to hit 60fps anyway (assuming 60hz mode) in this solution it’s not a huge issue, but it’s one more reason for Pimax to give us the ability to turn off the 1/3 Smoothing option.

Detroit Become Human SuperDepthVR settings: This title isn’t supported by vorpX, but looks and runs well in 3D using this method. Here are the SuperDepthVR settings I’ve altered (all the rest remain at default). I updated this today after playing with the settings a bit more. Looks as close to a G3D solution as I’ve ever seen.

Divergence: 30ish depending on taste
Occlusion Masking: VM3 Stamped looks best to me in this title also
Depth Map: DM1 Reversed
Depth Map Adjustment: 9
Smart Sharp: 5.000 (DBH is a very soft title; it needs a LOT of sharpening. I leave the in-game sharpening on also!)
Saturation: .2 (personal taste, but watch this setting in all titles as too much saturation causes certain colors to ‘pop’ on my 8K-X and appear to shift to a different focal-depth when they do so.)

1 Like

What do you mean I just turn smoothing off altogether.

Man I’ve been on a SuperDepth Binge lately. I’ve never been able to get it working before, but it turns out I was just doing it wrong.

Ive since gotten everspace 2 to look almost like a native VR game.

Grid 2019 looks crazy good.

Chorus, Hunted, KOF15,PCSX 2 and most recently

I got YUZU working with Vulkan and Metroid Dread!

The possibilities are almost endless.

The only game I couldn’t get working was The Crew 2 because of its anti-cheat BS.

Sure, and now I do too of course, since it’s become useless due to the 1/3 option. Maybe Pimax should just do away with it now that it’s totally borked.

But it was sometimes very useful; Cyberpunk is a good example; it’s just impossible to drive that game to an HMD (any method) with RT on and high resolutions to be sharp simultaneously with enough FPS to make a smooth experience. It used to be a good example of where the PiTool Smart Smoothing function helped significantly (way, way easier to maintain 45fps or 37.5fps doubled to 90hz or 75hz, than to actually drive Cyberpunk to even 60fps on an HMD. Smart Smoothing was never great, but it was at least useful as a last-resort on occasion.)

Strange I never knew smoothing of any kind would work on flat content, so I never even tried

I thought the smoothing was based on the 3d vertexes.

So are you saying I could just stream a movie like spiderman and smart smoithing would make it look like the “Soap Opera” effect?

I have other headsets. I will have to see if smoothing works with CPunk on Vive Pro or Quest or RiftS

I never tried it with a movie; those are generally 24fps (ish) anyway, so there would never be any need for Smart Smoothing and the only thing it would do is ruin the experience if you increased that artificially (so, yes, it would produce the dreaded Soap Opera effect, which I find utterly intolerable.)

But yes, the PiTool Smart Smoothing feature did generally work in flat-games forced into VR; I used to use it in vorpX titles occasionally, if it worked better than the default vorpX solutions. It also made Cyberpunk work better, as you could run the game itself as low as 30, doubled to 60 in virtual cinema mode in vorpX and it really made things smoother with very little distortion (mostly around fast moving smaller objects; like pull out a sniper rifle and rotate and you would watch the gun distort; not great, but better than running a game at 30fps. The 37.5 / 75 mode looked quite decent actually.)

In the Virtual Desktop solution you have to set the Smart Smoothing (or, as I now call it, Stupid Smoothing) to ON and then you could set the forced 1/2 mode if you wished. It did work, but now of course you really can’t use it as it will frequently drop to the unusable 1/3 rate for no valid reason.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.