Strange repeated stutters in iRacing

Hey guys, I’m having strange stutters in iRacing. I’m saying strange because even if I downgrade the supersampling to the lowest value ( steam or pitools ) and it looks like a 90’s gameboy game, I’m still having stutters every few seconds.

My config is Win10 64Bits - i9-9900k - RTX2080ti / 441.66 - Pitools 197 - Firmware 244 Pimax 5K+.

As far as I know, this happened recently but I can’t manage to know from where it came.

Anybody has reported problems with latest Nvdia drivers or Pimax firmware / pitools etc ???

Tryed a hundred of things, can’t find any improvement…

( I tried to uninstall MB LEDS management software, didn’t help )

Forgot to mention I’m running the pimax with 2 lighthouses.

1 Like

What track? All or just specific tracks?

What frame rates is iRacing indicating? I currently have an issue in iRacing where my frames are being capped below my headsets refresh rate.

1 Like

All tracks/cars as far as I know. Framerate is 90 solid almost all the time ( sometimes drops half second to 88 and wents up to 90 right after ) :slight_smile:

1 Like

Yeah I asked because new tracks like Lime Rock are often hard to run and result in significant frame drops using the same settings that might work on other tracks.

I’m not currently using tracking and I have not had stuttering that isn’t related to frame drops. Stuttering is often related to tracking IME. So at this point I’d recommend disabling tracking to see if that resolves the stuttering. That might give you a better idea of how to address the issue or give devs a better chance of understanding the cause.

I’ve seen other Nvidia users claim they reverted back to .144 as they have claimed any pitool after .144 caused stuttering in iRacing. I’m an AMD user on .249 because it is the only Pitool I can use.

I’ve seen people mention issues with recent releases of the Nvidia drivers.

Perhaps you should try the latest Pitool and firmware first. .249 was specifically released for AMD compatribility but I’d be surprised if it does not also support Nvidia. If not you could try .245

Pitool is broken beyond .144, you’ll have to revert and downgrade firmware until they make a fix unfortunately. A massive portion of people have this issue but they haven’t addressed it yet. It has to do with them optimizing gpu usage past .144

1 Like

Thanks guys! I’ve tried disabling the lighthouse tracking and it does the same unfortunately.

Tbh, I‘m absolutely not confident in reverting firmwares and other downgrade operations, I always fear of a problem that bricks the headset :’-(

Is pimax aware of that problem and working on a solution yet ?

Thanks guys

@Alex.liu would you check this thread out. Thank you.

1 Like

Try installing pitool 144 over your current pitool (no uninstalling, folder deleting, no firmware downgrade, keep the current firmware)

And fill in info in this thread, please

1 Like

My understanding is you do not need to roll back your firmware, just uninstall Pitool and install Pitool .144.

But if you do need to go back in firmware from everything I have seen the risk of bricking a unit is almost non existent and very easy to do. I have updated or rolled back my firmware many many times already when I was trying to get my headset to work with my 5700XT. I have done it using the SweViver guide and I have done it using the Firmware tool. Personally I prefer the tool because it is so easy to so and has not let me down yet. But at this point there is no need for me to use it.

I should however warn Nvidia users who might think AMD is a good option based on my experience not to get AMD and stick with Nvida. AMD is relatively rubbish for VR compared to Nvidia.

Hello Anthony 63
I had the same problem did you try that?
in rendererDX11.ini:
Open Vr
FullyWaitForSync = 1 that removed the micro lag, sacade,

Hi Kikal73, thanks for the tip. Unfortunately this didn’t worked.

You guys were right, I went from 197 to 144 and it was smooooooooth like butter ( well, like it should be at 90fps ) and no more stutter even at 75-80fps.

Then I tried to go from 144 to 249 and boom, guess who’s back ? Freaking stutters.

I’ll stick with 144 for the moment, as newer version don’t really have options I need absolutely.

Will post on the related topic tonight.

Thanks for the help guys


Sorry Anthony I didn’t understand how you solved the lag problem?
I use Googletrad.
Désole Anthony je n est pas compris comment tu a résolu le problème de lag ?
J utilise Googletrad

I just downloaded the old .144 version of pitools, installed it, done. :slight_smile: