Still disappointed

So I get these e-mails from this forum, and I can see there appears to be a new Pitool and/or VR experience. First off, I used the Pitool that is on the Pimax homepage, V1.0.1.271.
This all worked fine, also tracking two base-stations. Then suddenly (few days ago), it doesn’t track either base station anymore. As far as I can see nothing has changed? I didn’t update pitool, steam VR or anyhting.
The only thing I can think of that changed was that I set “Home” from “close” to “Pimax Home”?
Thus I am puzzled by two things: 1) is just changing some settings in Pitool affecting some config to recognise base stations??
2) all the newer versions of Pitool and VR experience, that Mr. SweViver announces, are they Pimax official updates? If not why are they coming from you mr. Sweviver and are apparently not on the Pimax official homepage?

Anyways, I did try to use VR experience but removed it because everytime it started the system, it explicitly asked whether I wanted to start ‘diagnose.exe’ and I thought that to be quite suspicious, to say the least.

Long post many questions, still confused and hoping to GET THE F***ING BASE STATIONS TO BE RECOGNISED BY MY PIMAX 8X !!! Why does it have to be so complicated…:frowning:

It’s highly likely the missing base stations are unrelated to your configuration or setting selections in the Pimax Experience or Pitool. There is only 1 setting that can affect that and that is the toggle between 9-axis and base station use in pitool.

Based on your post my guess is something is interfering with your usb and potentially holding access to it exclusively at least for periods of time. This could be software or a usb hardware device like a printer that has driver software constantly communicating with it. We even had a person who’s led lighting driver for his CPU caused a usb issue.

My suggestion would be to shut down your pc. Change both USB ports the headset is connected to. Bootup and run pitool and then SteamVR. Pitool and SteamVR will both tell you whether or not they can see your base stations.

Last note - don’t run diagnose directly, you run it from inside pitool’s help menu with the diagnose button. It can be quite useful and is capable of detecting numerous issues.


Thank you for your reply and suggestions.

I’ll try them out. Still, I believe that these are issues that should not exist, never have had these USB related problems with other USB devices, but I guess VR is something completely different?

Anyways, the “diagnose.exe” dialogue was always popping up in connection with Pitool starting up. I never started it for itself.

Otherwise, the VR experience with Pimax 8KX is awesome, apart from these issues with the base stations.


1 Like

It appears it worked by doing this: After I disconnected the Pimax USB connectors and then went to SteamVR developer settings and clicked “remove all steamVR USB devices”. restarted the PC, reconnected the USB and the base stations were recognised again.
This reminds me of the old days, with command lines and batch files to make parallel and serial devices work. Looking forward to the plug&play VR experience.


Nice fix°°°°