Still cannot get 90hz after 2 months

G’Day Doman,

I am still trying to get 90 hz from my PC,it is the latest with a 3090 graphics
card etc.Everything works perfectly using V1.01.271 and V2.1.255.256 but as
soon as I upgrade to M298 Engineer test it comes up with 10500 fault and
This seems crazy as many people are having no problem with the upgrade
would it be possible for you to check my machine for me ??
I have tried everything I can think of.

1 Like

Hello Skellum,

We spoke to Doman just now.
He asked you to file a ticket on the support page.
Title “OpenMR Skellum 90Hz issue”

After you created the ticket, please kindly share to us, so we could ask Doman to have prompt response.



Thanks Quarra ticket no 18730

1 Like

My 90hz no longer works with the latest Nvidia driver either.

I had the same problem. Install PiTool v1.0.1.270. It will keep the newer firmware, which is what enables the 90Hz option. Good luck!

1 Like

G’day Neil,
Tried that awhile ago,no luck at this stage I must have tried everything which has
been written in this forum.
Thanks anyway for your help

1 Like

Flashed successfully F…G Awesome after months of trying this old man is going to have

a fantastic 77th birthday tomorrow. I truly appreciate your help guys and girls.

To all the wonderful support staff a very big thanks from me

:grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes: :grinning_face_with_smiling_eyes:



I have tried to flash to no avail. Maybe I need to try 270 instead of 271?

I did notice the dfu file doesn’t have exe. Next to it when I go into pimax files…not sure if that’s issue.

Unfortunately, that won’t work. To get 90 Hz, you need to install the firmware which is included with 271.

1 Like

G’Day Brogs.
If you put in a support claim ,ask Adonis to send the ammended files,he will
also send the various Irl’s to explain the sequence to flash your dfu.
All the best


I thought the firmware was no longer bundled with PiTool (i.e. it’s just downloaded)?


I have 271 but firmware still shows m296. I flashed M298 yet it didn’t work. Still shows old firmware…I suck!:confused:

1 Like

I guess that’s possible. I think I got my most recent firmware with PiTool 271, but it’s been a while and I could be mistaken.

If that’s the case, where do you get the v2.1.255.298 firmware?

1 Like

It’s a beta firmware that You download and flash manually (as far as I know?).

It was on Pimax PiTool download page at some point.

There’s also a lot of revisions of it out there which have been given to people who had issues with 90Hz.

If/when it’s ready it’ll be available for download via PiTool but I’m pretty sure it was also available here in the forum earlier.


Thanks! I ll give that a try later today


I finally got it to 90hz…! Very happy!


Yay! VR is definitely better with a higher framerate.


There were some bumps though. After flashing got the dreaded green…blue …red blinking light. I looked up fix for that. Some dfu file in device manager conflict. Had to restart computer few times.:+1:

As most here know I’m avid iracer. Since I updated firmware I haven’t been able to race. I try to even to test track but iracing doesn’t load…just stuck in buffer. Weird