SteamVR in extended mode

Ok this is quite weird. A few days ago I was messing around with the headset, flipping between pimax mode and extended mode, turning the headset on/off and all of a sudden when I started SteamVR it said “are you sure, you are in extended mode” and it started and I THINK that the resolution was higher. However I never managed to reproduce this.

Maybe anyone else has seen this ? Would be great if we could run it in extended mode, stream VR seems to support it !

OK. I saw it too.
There is a fact that we must know about the process of connecting SteamVR.

  1. To run SteamVR we must always change Pimax4K to Pimax mode (usually called Direct mode).
    If you change Pimax to Extend mode, SteamVR will not run. This is because SteamVR does not notice Pimax.
  2. After SteamVR is executed, SteamVR (OpenVR) will have control of Pimax4K.
    At this point, we can change to Extend mode and Direct mode via SteamVR, which is a change made by SteamVR, not Piplay.
    I linked the video to show this.
    In SteamVR, Extend mode warns you that performance is degrading, and if you want to experience it, it will be fine.

I responded with a little knowledge gained from using OSVR.

Yes, that’s exactly what happened to me ! It warned about extended mode and that performance would degrade. Which made no sense to me since everybody says SteamVR only works in Pimax/direct mode.

Your video is a bit hard to follow in Chinese. But you’re saying we should change it to extended mode through SteamVR ? I’m not at home at the moment but I’ll try some more.

Anyway so through this you think we can run at 1440p resolution ? I THINK I saw a higher resolution but I’m not 100% sure. Would be awesome to use 1440p in steam

If you want to enjoy SteamVR at high resolution, you can even set the DSR in the Nvidia control panel to a higher resolution.
Since my monitor resolution is 2560 * 1440, I can choose up to 5K using the Nvdia DSR setting, of course SteamVR is running.
The screen looks crisper and certainly looks better.
Do you want this? If so, you will have to prepare a monster class PC.
There is too much lag.
I’ll be ready for the video shortly, but it probably will not be possible.
Instead, I prepared the picture first.

[Pimax 4K] Playing Game In SteamVR Extend mode for up to 5K

There is a extended mode in steamvr, it is not the same as extended mode in piplay. I’ve had it on but usually in vertical layout. Not actually been able to use it.

You can go into one of the settings in steamvr and activate it there.

Hope that helps.

AFAIK, extend mode is not different from pimax because steamvr only has control of Pimax.
When you put the Pimax in steamvr extended mode you must also rotate the display in your display settings, since the display in the Pimax is a portrait display and not landscape like a normal desktop monitor.