SteamVR & games huge performance drop (Pimax 8KX, PiTool


SteamVR became unusable after recent updates. I updated PiTool ( and installed Pimax Experience from official installer.
After this I am unable to use SteamVR home. It lags incredibly. I tired to change render quality to lowest (0.5) in PiTool but nothing changes.
Pimax Experience runs fine though.

I noticed my GPU consumption goes to 100% right after I run SteamVR

I have RTX 2060, i5-9700, 64 GB RAM. I had no issues running it until now.
Did you have similar issues? Maybe the recent update adding 90Hz support somehow broke it for users of less powerful GPU’s?

EDIT: It’s not only SteamVR, I see big framerate drops almost in each game.

1 Like

It sounds like You have set SteamVR supersampling too high.

Leave it at auto or 100% for simplicity’s sake.

As I said I did not change anything except version of PiTools and Pimax Experience.
If by supersampling you mean render resolution in Steam VR than it is the same as it has always been.

Up until recently I did not have any problems.

1 Like

I wonder if they changed their gpuspeed calculation again.

Well to me this also looks like they changed something more when implementing 90Hz for Native mode.
Another thing is everything runs ok in Upscaled mode.
And I know Native is higher res and so on, but couple of days ago everything was fine for me in Native.
That is of course until I installed recent update.
I’ll try to get hold onto previous version of firmware and PiTools for my HMD (though I have to consult it with Pimax, cause I once had a complete HMD failure when downgrading).

Maybe use something like malwarebyte to scan your pc. I was getting intermittent lags with Gpu 100% turns out I was infected with bitcoin miners which secretly use my gpu to mine, and cause lag.

Once removed no more lag, I’m on latest pitool and firmware.

1 Like

You can still run the headset at 75hz if you don’t have enough GPU horsepower. No need to downgrade the software. The option is in Pitool and PE.