Steam VR does not find Pimax HMD anymore

So today i started SteamVR as usual, but my Steam VR says it can not find the Display Connection. (Error 208)

This ist strange, because Pimax Home is fine. Also starting Oculus Games works just fine.

I updated the PiTool to Version 260 and Firmware too. I also tried SteamVR Beta 13.3.3

I updated my Nvidia driver and I have a Pimax 5k+

i think there was a tread around about steamvr going into safe mode and refusing to see the headset until a manual edit was made to some file. i think it was provoked by the piservice shutting down unexpected or some thing.
if that is what happend you may be able to find the old thread somewhere.

oops, this thead. take a look it may be able to help you.


Thanks this was the issue, the forum search did not find this thread. Thank you!

1 Like



did this really work for you?

Yes… Apparently:


strange thing is I can’t even find those edits in my files…

I’m having the same issue, editing the .vrsettings as shown in the linked thread did not work.

steamvr.vrsettings may be in a different path depending on your specific installation.

1 Like

running the program vrpathreg.exe in your steam installation folder which per default looks something like this:
C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64
will tell you where the current active config files are placed

C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64>vrpathreg.exe
Config path = C:\Users\bnp\AppData\Local\openvr


Running vrpathreg opens and quickly closes a window. I have tried modifying the .vrsettings file that exist in both the Steam/config folder and the appdata folder. When I change the file in config folder it overwrites the file. If I set it to read only it creates a .tmp file.

Ran the file from cmd prompt, pointed me to Steamvr/config folder

run it from the comand prompt
(click start -> type “cmd” -> right click and chose run as administrator)
cd “C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64”
and then


and you’re editing steamvr.vrsettings, not default.vrsettings, right?


Yep, it just overwrites the file.

weird, steamvr.vrsettings should be the permanent file that will keep your changes and default.vrsettings the one that gets overridden on every steam start. I don’t know what else to suggest.

1 Like

Removing the section:

"driver_aapvr” : {
"blocked_by_safe_mode” : false
Steam doesn’t overwrite the file if this isn’t present.

I am still unable to use steamvr, however I should have noticed the typo in the file edit:

This contains 2(') instead of (") which is why steam was overwriting the file.


Unfortunately, those wrong double-quote characters can be hard to notice and many editing systems like to substitute the “pretty” ones (like what just happened on this line). Most programs and computer languages require the use of the ASCII double-quote char.

I noticed in the config file that the quotes looked different, as I said this didn’t solve the problem, just kept Steam from rejecting/overwriting the file.

I have however fixed the problem. I uninstalled/installed SteamVR/PiTool, and updated my graphics driver. I’m not sure which of these fixed it, but I’m not going to question results.