Started recently: 8KX Ghosting and hitching constantly, but gpu and cpu graphs flat

So I’ve had this 8KX for a few years now and have been very happy with it. I have a good PC with a 13600k and 4090, and in the steamvr void I get smooth gpu and cpu graphs confirmed by the windows task manager performance graphs.

However since a few weeks ago in the headset I’m seeing constant and significant hitching and ghosting when I turn my head. It’s harder to tell but I think I also see the chunkiness in the steamvr headset view.

Some notes about what I’ve checked which all resulted in no improvement:

  • Different fov’s
  • Different refresh rates
  • Native vs Upscaled
  • Same hitching/ghosting in pimax home (havent tried pimax experience) with steamvr closed
  • same with and without parallel projection
  • smart smoothing always disabled (and when tested enabled it’s always inactive)
  • FFR always disabled
  • HAGS enabled and disabled
  • Kill all unnecessary background and foreground apps and services after hard reboot including performance monitors, and I have no RGB controller software running (opaque metal case gang)
  • different usb ports
  • different display ports

I’m on windows 10 and per the screenshot below I’m on pitool and headset firmware 299, I’ve so far not tried downgrading or upgrading this. Is it worth trying pimax play? Can someone recommend and link to an older pitool I can try maybe? The pimax website makes it look like that software is for crystal and the pitool 284 is the latest for 8K (it doesnt show 8KX at:

I haven’t reached out to pimax support yet, mainly because I know it’s out of warranty… could be worth trying to get them to connect on a remote desktop session to check deeper settings. I’ve not tried another cable, we just moved so I’d have to dig a bit to find and compare an older cable I had to replace because of the snow artifacts.

Let me know if anyone has any ideas or experience, otherwise I’ll have to buy a new wifi 6e/7 router and take over my partners quest 3 as my primary until the 12kx or something better from bigscreen comes out. :frowning:

1 Like

Hello Seth,
my experience:
I have practically the same configuration as you but with Windows 11 and Firmware in 2003 (ver.2076) also with Pitool Version 281 was the most stable version in my case!
You modified a lot of parameters without success, it’s surprising that you didn’t have any improvement!
I tested Pimax play but from version 1.11, big graphics bug and drop in performance (do a big cleanup if you want to uninstall it after testing it), I came back to Pitool!
Let’s be clear, the latest versions of Pimax play seem to be dedicated to crystal.
HAGS enabled does not work for me (stutters) -
Did your problems appear after updating the Nvidia drivers because I noticed a small loss of fluidity after installing the Geforce driver?
I use pimaxxr 0.3.4 at most for certain games and I have better results than under steam.

1 Like

Thanks for your notes, the timing could definitely align with nvidia driver updates I’ll try grabbing an old gpu driver and i do have pimaxxr set up already so i’ll try testing with that as well today and see if there’s any differences

1 Like

Well there you go, I installed the December 12th nvida driver from GeForce Game Ready Driver | 546.33 | Windows 10 64-bit, Windows 11 | NVIDIA and it’s working smooth without the hitching and ghosting! So thanks for that suggestion!

Am I really the only one experiencing this on the latest driver? I’m not seeing any known issues about vr or pimax specifically anywhere I search


Has anyone figured the root of this problem out? The hitching is pretty bad, per above I was able to fix it with a downgraded nvidia driver but since then I’ve been playing Horizon Forbidden West which requires the latest driver… then went to also use VR and the hitching is as bad as it ever was.

Is there really no other 8KX users seeing the same thing?

One more reply to myself for this one, in my recent testing I’ve found that the hitching looks very similar to what it looks like with HAGS enabled, but when HAGS is disabled it’s less severe (but still obviously present). Is that a clue? I’m also on W10, does anyone have a clue if upgrading finally to W11 would be worth while?

@PimaxQuorra is this something that I could get some help from a technician on screenshare maybe? I’m long out of warranty at this point

Hi Seth,
I had no problems with W11 as long as HAGS is disabled even with the latest Nvidia updates!
Just for info, I’ve been using a quest 3 for 2 weeks, no more hassle with pimax! I made compromises with the fov, but in the end I will sell my 8kx while there is time

thanks for your response bram, that does help to know that its working for you without hitching with latest nvidia drivers on W11… I did pull the trigger on the windows upgrade today to see if that would fix the pipeline but no luck – looks exactly the same even in the pitool pimax home moon environment.

But at least I can imagine fixes now that assume it’s a local problem to me, I’m a bit worried theres a hardware fault in the hmd itself, would love to hear back from @PimaxQuorra if theres a way I can do something like diagnostics either myself or led by their tech support.

you should try a complete new installation of Windows 11, I think that could help with your diagnosis

1 Like

Well I saw there was a new bios version for my z790 motherboard and did that… now pitool shows disconnected 10934 error not getting any image at all haha the bios flash re-enabled the onboard graphics which I remember caused this problem, disabled it but still see the same hitching – a fresh reinstall isnt really an option for me any time soon so will hammer on it some more this weekend. It’ll probably end up in a drawer and I’ll start running the quest 3 as daily driver with link which isn’t my favorite with the latency + compression… boo.

1 Like


How is the headset functioning currently? Are you still experiencing the hitching issue after reinstalling Windows?

I recommend filing a support ticket to let our technical support team diagnose the problem.
Also please try to install the PimaxPlay instead of using the Pitool.

It’s still a problem with windows 11, I’m not going to do a full format and new windows install – but I will I’ll try pimaxplay then reach out to support assuming its still a problem after that.

I’ve been trying to use my quest 3 with link, air link, and steam link and I dont know how people play this way. the compression is bad, and still plenty of its own hitching esp with dynamic bitrates that are constantly fluctuating

Got it, if you encounter any issues even with PimaxPlay installed, please don’t hesitate to reach out to our support team!

Ok looks like I’m good again, had to do a full uninstall of pitool manual delete the appdata everything with a few reboots in between, installed the newest pimax play and it’s already working smooth!

just a “clean reinstall” of the old pitool did NOT work.