[Solved] SteamVR issue - can't find headset

This is weird. I’m trying to use my 8KX after a lapse of a few months (long story). Anyway, Pimax sees the headset and base station, but SteamVR can’t find the headset and automatically blocks my Pimax. Note that the SteamVR icons show a headset and base station were found. When I re-enable the headset in SteamVR, SteamVR crashes again. At one point, I was able to enter the SteamVR Home app, but not a game. I turned SteamVR Home off and now I can’t turn Home back on.

I’m stuck in a loop and can’t play games. I am NOT using a SteamVR beta version. I’ve restarted the Pimax service and rebooted the headset multiple times.

Any ideas?

1 Like

Maybe you can switch beta, then non beta again. And try unblocking Add-on Pimax in every version.


Find SteamVR under Library> Tools. Right click on SteamVR and select Properties. Click on the Local Files tab. Click Check Cache Integrity.


I’ve tried all your suggestions. (Thanks!)

I’ve also swapped USB ports and am now using my original Pimax cable (instead of the Pimax fiber optic cable). I’ve rolled back to my previously installed nVidia drivers.

SteamVR is still failing to find the headset. I can sometimes get into SteamVR Home, especially when I’ve just rebooted my system, but I can’t run any games. I had the problem last night; this morning, I downloaded and flashed the brand-new firmware for my 8KX, in the hopes that would fix this problem. No change in behavior, but I can actually run 90 Hz on my RTX 2080 non-Ti, which I wasn’t really expecting. I’ve uninstalled and re-installed SteamVR and now Steam thinks my VR Library is empty, even though my VR games are listed in the main game library.

To recap: PiTool seems fine, but SteamVR cannot find my headset and displays errors, even though I can run SteamVR Home.

Any other suggestions?


I reinstalled PiTool and now SteamVR runs fine.


@neal_white_iii I had similar issue like you, but I was not so lucky; I had to wipe my windows and to install everything from zero. :face_vomiting: :face_vomiting: :face_vomiting:

Everything else was not succesful (remove/add steamvr, pitool, steam and all leftovers from them), my steam was not working with steamvr (same critical error). Well I could play games from pitool directly, without even turning on steam, but that was inconvinient for some games (i.E. I couldn´t choose another vr controller configuration, or use “VR Neck safer” in fly simms).

I write this here in case more people have same issue.

1 Like

I’m away from my VR setup atm but also having this problem. I’ll try to reinstall PT if that solves it, good to know thanks.

I found a strange workaround (eg when trying to get DCS to load in VR mode), which was to turn on a VR controller and load NMS (so mouse in PE causing an issue?). For some reason for me this is one of the few things that will not trigger a SteamVR crash. And after that stuff like DCS will load correctly in VR.

A new related quirk is with PE. Trying to click on any item (game or menu setting, doesn’t matter) will cause the whole UI to disappear for 10 seconds, leaving me just looking at the background skybox and nothing else. Wait for a bit and it comes back.

This happens repeatedly until I run the controller workaround. Mouse quirk? Not sure when it was introduced and whether the trigger was PT / firmware update (I’m on an older one) / Nvidia driver

Wait, so you guys did go into the steamvvr.settings file and edited ‘blocked by safe start’ within the segment related to Pimax drivers from ‘true’ to ‘false’, right?

That is what I always did when I was still using my 8KX and now with Varjo, occasionally the same thing happens.

I feels as though this behaviour is down to the complete mess that SteamVR has devolved into.

1 Like

Funny, I have used SVR with my 5K+ since it’s arrival without any issues in running it or any of my games so “complete mess” is not something I have experienced with it. On the contrary.
Happily playing VR on Steam since 2016

1 Like

Yes, I did that many times before successfully, but this time that was not solution.

Once before I started my steamvr with admin rights, I do not remmember my reason for that. Maybe that was trigger for this problem now?

I have continued to have this problem (SteamVR keeps disabling my headset).

I found a solution which seems to have (finally) fixed it, once and for all. I uninstalled PiTool and reinstalled Everything seems solid. Even better: I had set my 8KX to 90 Hz prior to uninstalling 271 and 90 Hz continues to work with the older PiTool.

@PimaxQuorra, please mention this issue to the developers. They need to find out (and fix) this extremely annoying issue. Thanks!



Thank you for pointing out the problem.
Will forward your feedback to the developers, and urge them figure something on the Pitool version with SteamVR.


1 Like

@PimaxQuorra what’s the latest with this? I’m trying some VR again and everything I launch from Pimax Experience triggers a SteamVR crash followed by the app only loading in desktop mode.

If it persists I guess I’ll go back to .270 and see if that’s better.

1 Like

I have the exactly same issue recently . I had no problem with weeks ago but these days, it suddenly doesn’t work as described by Neal.

The latest SteamVR update? Windows update? Graphic driver update? I am not sure what caused this issue but it gives me a great concern about long term use of Pimax device as the headset is too sensitive to the new drivers or updates of SteamVR/Nvidia . Pitool developers need to find permanent solution to make the headset works regardless of minor updates by Steam VR or Nvidia driver.

BTW, Wasn’t new pitool supposed to be released last week or this week? I have seen the comment from Pimax forks from somewhere in this forum.


Someone just liked an old (and forgotten) post of mine, which offers another possibility: Perhaps reinstalling PiTool (regardless of version) might solve the problem…


…Either way, Pimax needs to investigate what’s going on with PiTool. @PimaxQuorra


Well, reinstalling both programs did not work for me. I tried it several time. The last thing I would want to try is windows initialization. I hate to do that.

1 Like


You may try to install the V270 Pitool before you do the windows initialization.

1 Like

I have uninstalled v271 and re-install v270 It does work. I still wonder why v271 suddenly stop working. ( stop making Steam VR to be exact.)


@PimaxQuorra, just uninstalled 271 but I can’t properly install 270. BitDefender blocks a file as having a Trojan or virus:

I see @Trigen had this too. If most AV software doesn’t consider it a threat I guess I’ll have to take the risk and except it.


1 Like

I had to temporarily except the whole \Pimax\Runtime\ folder to get 270 to install. But now that’s done, things seem to be working normally again.

I did a test with NMS, which I haven’t played for some time but thought I’d check the new Frontiers settlements update. Game loaded without any issues whatsoever.

As a bonus, using 90Hz + Motion Smoothing, I can now hold a steady 45FPS in the new town areas, and even better I can crank up a number of settings from Standard to High and it’s still running fine. So 90Hz mode + presumed game optimisations is a winner!

Also @neal_white_iii thank you very much for confirming that a rollback to 270 solved the problem. I probably would have just given up until a future fix otherwise :+1:t4:

1 Like