SOLVED - Bug/Feature request - NO thumbnails makes choosing a game impossible


First of all, I’m happy with what I already see in this alpha release, very encouraging for the future.

I have noticed something, not really a bug more like the absence of handling some cases in the displaying of games :
Sometimes, you may have VR games outside of Steam (and Oculus, and viveport) and added them to your Steam library by using the “add external game” feature.

In this cases, the game is visible into SteamVr, but does not have any thumbnail. Which does not really matter as the name of the game is written under the missing thumbnail.
But in PE, the name is not written and makes your choice of a particular game impossible, especially if you have multiple external games.

Priority is not high, its just something I noticed, but it also may have an impact of the profile handling
too (not tested yet).

I dont want to create another topic for such a little thing, but is it possible to recenter the Gui ? I often play outside my playspace (at my desk) for some seated games, and the PE Gui is very far behind me :slight_smile:

Thanks !


Good observation, added to my notes. Will let you know once I have it sorted!

You can recenter by pressing Valve Index Thumbstick down or Touchpad down on HTC Vive wands.

Although, it does only recenter the X and Z position, not Y. Im trying to understand why it ignores the Y value (height position of the GUI, which is currently defaulted to eye-to-floor position upon Room setup in Pitool. I will somehow fix that)



  • Seems like PE does not import Oculus external added games.
  • Same like @TheMalkavien ; apart from see shortcut picture, you should see program/game name in letters below shortcut picture.
1 Like

yes thats correct. Currently, the initial SteamVR and Oculus imports are made by PiTool itself upon launch (for its own Game Launcher), while VivePort games are only imported through VR Exp. Soon I will change that so all games are imported by VR Exp, including Revive games (which I already know how to import). And I have to investigate how externally added games in Oculus can be imported, as I cant find them in the manifest files…

Do you mean in the game gallery view? you can always switch the view mode to “Gallery+Title” and you will get the game name upon the thumbnail container. But yes I will fix the request from @TheMalkavien as well :slight_smile:


As there is a workaround by changing the view mode, do not bother to take too much time on this :slight_smile:

My 2cts : An elegant way to handle this, may be to display the title instead of the thumbnail if this is an external game without thumbnail.

Thanks for the good work !

1 Like

Yeah thats how Im doing with the Imported games (which are imported through PiTool), it shows the black thumb with Pimax headset. I will fix this the same way for manual imported games in Steam.

By the way, how do you add a custom game to Steam that gets recognized as a VR game? I have plenty of these imported, but they dont show up in the steamvr manifest (list of VR games installed)?

As you may understand, Im only importing games to library that does exist in the manifest (which means these are VR capable according to Steam). All the others are ignored.

1 Like

Very easily, right click on your external imported game, and check the “add to my VR library” (or something close in english).
Here is a screenshot (in French) :


Ah thats awesome, thanks a lot! Will try to fix this in the next version tomorrow or so. Didnt see your message until now… been totally into Unity today again hehe…


@TheMalkavien It seems like when including custom games into Steam VR library, they do not get added to the steamapps.vrmanifest.
I added a couple of games, but have not been able to see them imported, as they are missing in steamapps.vrmanifest (which is required for the game to be added to PE)

Do you mean that you can see your custom Steam games (included in VR library) inside PE as of now anyway? I wonder how thats possible…

Sorry the confusion :slight_smile:

1 Like

Well, it does show in the manifest for me :slight_smile: :

  	"app_key": "",
  	"strings": {
  		"en_us": {
  			"name": "Tea For God"

  	"launch_type": "binary",
  	"binary_path_windows": "C:\\Jeux\\Tea For God\\tea.exe",
  	"working_directory": "C:\\Jeux\\Tea For God\\",
  	"arguments": ""

It even exist in my steamvr.vrsettings.

All my imported Steam games are visible in Pitool AND PE too. Maybe you have to restart Steam to write the manifest ?

1 Like


Thank you, the issue is now mainly solved. But not fully :slight_smile:
There is one case which does not display the title nor the thumbnail.

For some reason, when the “launch_type” is “binary” into the manifest, SteamVR adds an "“image_path” pointing to the exe file (which may contain an icon) but does not display any thumbnail (not in PE, nor in SteamVR).
For these cases, we have to add the title like the other external games without thumbail.

Easy way : add title for each external game even if the thumbnail is working (never working for me)
Elegant way : add title if no thumbnail (no image_path or invalid/no thumbnail after loading image_path)

Obviously, like said before, this is not a very important issue.


Thanks. Im currently rewriting the import and this time PE will handle the import (instead of PiTool) of SteamVR games, including Revive games once I get it right. Going this path, I can extract the binary path from the manifest so these non-steam games actually works to launch, which they currently doesnt… :slight_smile:

1 Like

Fixed in 0.25 :slight_smile:



Is it possible to add in a new custom thumbnail? even Steam/SteamVR doesnt do that but iw would be nice to be in PE

its definitely possible but will require this:

1 Like