(Solved)8k just bricked when updated the new filmware

of to bed now with pimax led red blue green after updating to new brainwarp version ,tryed lots of stuff as posted by others but nothing,poor experience so far

Have you checked @Davebobman wiki in 5k 8k directory?

3 methodes & @spamenigma posted 4th.

I think last one was reboot reinstall & cinnect headset.

Try plugging around different USB ports too. I went through the whole DFU routine only to find out it comes to live again on a different USB port. On that port it upgraded again with success.

1 Like

i will try again tonight thanks ,have tried lots dont think its usb port it has red green blue light or is this a standard thing untill pc has seen it


I just looked on here and grabbed the tool from this posts link https://community.openmr.ai/t/incorrect-was-in-dfu-mode-now-fixed-beware-the-103-update-i-bricked-my-5k/14722/6?u=spamenigma

Mine was flashing r g b and I just clicked ‘Return from DFU’, it then couldn’t find the headset so I rebooted my pc and PiTool in the background just had another go at updating firmware and all come up fine.

There may be a more refined procedure but that seemed to sort it for me :slight_smile:


Mine is already in a state of cant find headset ,also not sure if relavent ,in the dfu program lists as no filmware present,
Yhis is going to be a painfull prosses as computers are ,well not my choice of ocupation ,i have tryed the fix flaahing light but just comes up with pimax not found not sure if im donig it wrong

Which headset? Dusty

if the hmd is in dfu mode windows should find it as usb device and in the pimax directory comes the driver for dfu mode so it should be “present”

if its not in dfu mode then its possible to do that by pressing the buttons on the hmd in the right way

i found this somewhere in the forum (sorry dont know where it was, its now just a text file in my documentation)

  1. close PiTool, shut down PiserviceLauncher in the task manager.

  2. unplug the power adapter, press the 3 buttons on the headset together

  3. plug the power adapter while the 3 buttons are pressed, the LED turns white. count 8s, release the power button, the LED turns blue another 8s, release the button in the middle, still blue light 1s later, release the last button, the LED should start flashing.

1 Like

8k sde is great ,i tried the button pressing but not while pitools were shut so will try that again thanks

nope thats not worked

1 Like

Pimax needs to get on these things. While most seem to have little trouble with installs. Too many folks do have issues & no release notes is not proffessional.

Linux Distros almost always have good release notes.

that the sum of it so far there is another dfu file in runtime folder that comes up as firmware loader but doesn’t register any pimax device ,so i’ve tried all now and still got hmd in dfu mode ,guess its dead ,wow only tried it for few hours pretty bummed out right now,ok now not so bummed

Go to Management console -> Device Manager
Uninstall the driver for the device “DFU in FS mode”. When asked if you want to remove the driver files say yes
delete the stm_dfu_3040_64.exe from C:\Program Files\Pimax\Runtime\dfudriver

deleted all pimax folders plus the STMicroelectonics folder via remove program ,installed /downloaded https://www.st.com/en/development-tools/stsw-stm32080.html then run apllication ,dpinst_amd64 ,from DfuSe v3.0.6 > Bin > Driver > Win10
Had to reinstall pitool after this before update would complete

im now red light with notice filmware update UPGRADING i hope this go,s well this time

1 Like

up and running now loving the update wasn’t sure about the distortion on the edges ,but i can say wow its pretty damn good now


A friend of mine has a problem. I try to help.

Unfortunately, an update failed.

The Pimax is no longer detected on the USB.

I tried the three heads and waited 8 seconds as described. The LED lamp of the pimax only flashes briefly, red green blue. Then white again.

I also tried the program. But do not continue.

Can someone help?

Did you stop PiServiceLauncher.exe service before putting it into DFU mode?


Problem was solved thank you.