[Solved]5k+ headset won't power on at all anymore after accidentally unplugging when firmware was updating (red green blue at power button)

[Edit: fixed the problem. TLDR: reinstalled the firmware with a flasher tool, updated pitool to latest beta version, let it upgrade the firmware of the headset, restarted the computer, and opted into the beta branch of steamVR. There were a bunch of other little things that might have been the thing to solve it, but I don’t know which specific thing or sequence did the trick. For anyone who’s coming across this thread, I hope all of this info may save you time and frustration.]

Hi. I’ve run into a frustrating problem. My headset won’t turn on at all anymore. I was setting up my computer in a different place than where I normally keep it and updated my pitool software from .91 to the latest. When I plugged in my 5k+ the pitool software started automatically updating the headset’s firmware when I wasn’t looking at the monitor. As I didn’t know that was going on, I unplugged the cable so that I could plug it into a better port that was facing a more suitable spot where it would have most slack and now my headset just isn’t turning on. :worried:

Since my headset has been blinking red, green, blue at the power button, i’ve tried following the steps at this post https://community.openmr.ai/t/solved-led-keeps-flashing-red-green-blue/14441/31 , but so far no luck.

I’ve run @Sjef 's flash tool but I don’t know what to do since it says “Error: Unable to get descriptors… Bad Firmware” when i try to Flash FW ( then it opens the “file open” manager in the flashertool folder. I’m assuming i might be able to load a firmware or something, but i don’t know where to get that . :confused:

What happens, when you run PiTool? Does it start the FW upgrade automatically?
Do you see in Windows Device Manager “ST device in DFU mode”?

1 Like

Q1: pitool just says Disconnected, Diagnose, (10500)
Q2: No, it doesn’t start FW upgrade.

edit: i just now found a firmware link here https://community.openmr.ai/t/where-do-i-find-firmware-downloads/12610/7 .I’m going to try to use it with the flashertool and see if that does anything.

edit 2: :slightly_frowning_face: after using p2.1.225.181.dfu with Flash FW with the flasher tool it just gave me an “Error!” window and when I closed it it now says in the Pimax Status box of the flasher utility “WAIT Going to flash now !” . It’s been around 10 minutes but there’s no way for me to tell if something’s happening with a progress bar or something, so i have no idea if it’s glitched, or if I should just keep waiting until something new happens… I guess I’ll wait unless anyone has some input that could help me understand what’s going on or could say if it’s safe to close the flasher utility.

It really shouldn’t take very long (more than a few minutes).

It sounds like you are taking the correct approach, but unfortunately, I don’t know much else to suggest. You might try powering off your PC and Pimax headset, waiting a couple of minutes, power up your PC, waiting a few minutes until all the start up tasks complete, and then retrying the firmware flash procedure. If that fails, you might want to try connecting the headset to a different USB port and retrying the flash, but I’ll be honest, I’m grasping at straws.

Hopefully, someone might have a suggestion.

1 Like

Try “controlled” powercycle:

  1. Stop PiTool
  2. Stop PiServiceLauncher.exe service (in Task Manager->Services)
  3. Make sure no Pimax background task is running.
  4. Power off the headset
  5. Start PiServiceLauncher.exe service (it will start the other Pimax programs)
  6. Power on the headset
  7. Start PiTool

When you start PiTool, it should detect that the headset is in DFU mode and commence the update. It will however use the FW from PiTool install (I believe it is p2.dfu in Pimax\runtime\dfudriver, if you want to try different FW, you should replace the default one in PiTool install with your version.

EDIT: If you use a standalone flashing tool, I would stop PiServiceLauncher.exe before and make sure no other Pimax software is running as well.


quick update. I restarted my computer and left the room for a while. I’d just come back to my computer, and now my pc is making the “device connected” “device disconnected” sound over and over again. every 7 seconds. When i look in device manager, the “Stm device” appears for a second and then disappears until it reappears again.

@risa2000 i’ll try that.

What is the LED color on the headset when it does that?

1 Like

when you say 4. power off the headset and 5. power on the headset, do you mean hold the power button? When I try that, it doesn’t respond to it. it just flashes red green blue disconnects and reconnects.

it’s flashing red green blue.

Yes. To power off the headset you need to hold it a bit longer, for power on, just press it quickly.

EDIT: I remember there was already someone on the forum long time ago with the same problem (headset USB recognized and then disconnected after a botched FW update), but I cannot find it right now. I believe though that at the end he contacted the Pimax support for help.

1 Like

Something new finally happened! I stopped all the pimax related .exe’s in the task manager, tried the flasher utility and used Flash FW and it did a download and says “upgrade successful ! Rebooting now, WAIT !”, then the led strip at the front of the headset turned on(blue) and the power light stopped flashing red green blue and is just a stable red. whew. I hope this continues to work. Just waiting now. I don’t know how long it’ll take (there’s nothing indicating progress like and increasing percent number when the flasher downloaded something that passed too quickly for me to see what it was.).

edit: still waiting for the flasher to do something… :sweat: I’m gonna wait for around 10 more minutes just in case (I’m very wary about messing something up again.). I’ll go elsewhere for a bit and check back on it then. if nothing’s happened still, I’ll just take the chance and start pitool or something.

edit 2: alright, i’m back after 10 minutes and nothing’s changed. Time to start pitool and see if anything works properly.

edit 3: so i’ve started pitool (still .91 ver just to see) and there’s a new error. it’s the 10600 “Plugin hdmi/dp” now (before it was 10500)


i’ve installed pitool 180 beta and it said it upgraded the headset firmware successfully, but now I still get 10600 error “hdmi unplugged”

edit: i’m updating my nvidia firmware to the latest. just in case.

Is it still detected as “ST device in DFU mode” or is it now recognized?
Is PiService.exe and pi_server.exe running? What is the LED color?

EDIT: You may try to unplug all cables (DP, USB, power) from the headset and after 30 sec. plug them back.

I don’t see any “ST device in DFU mode” anymore.Those .exe’s are running, the front face led strip is blue, the power led is red.

edit 1 reply to your first EDIT: k. I’ll try that.

edit 2: my gpu driver is being installed. I’ll do the unplug replug thing after that.

This means the headset is either not recognized correctly, or due to some error, not initialized correctly by Pimax software (PiService, pi_server). The problem also could be that your FW version you have in the headset is not compatible with the PiTool software (and services). Which version did you flash at the end? Could you downgrade to the corresponding PiTool version which uses this FW version?

EDIT: I read this:

but did you actually see the update happen (i.e. the progress bar), or did you just get the message it was successful?

I unplugged everything for 30 seconds and replugged now I get 10620 error"hdmi/dp disconnected"

I did see a progress bar in the pitool 180 beta version. It filled up some ways and then skipped to 100 before near instantly flipping to the Success! message. It happened really quickly so I may be misremembering a detail but I do feel confident that I saw a progress bar.

i happened to just check device manager and selected “show hidden devices” and now see that there was a hidden “STM device in DFU mode”. it’s grayed out so I don’t know if it’s active and hidden, or hidden because it’s not active, but there’s that.

It is hidden, because it is not connected, i.e. just a remnant from the past.

1 Like

ah i see. good to know.

it was P2.1.255.181 and pitool .91

Do you know where I can download a copy of the 180 beta firmware(link to a download)? I’m thinking I’ll try to use the flashtool to reinstall it in the headset.

Edit: I thought 180 beta was the latest but after searching “firmware” it appears that the latest is 197 beta. I’m going to download it and see if it fixes anything.