So can I install the latest Nvidia driver?

Currently still on 471.11 from 22nd June because this seemed to work without issues with the Pimax Experience, PiTool, and 8KX. I rolled back to this one because a later version stopped games launching in PE. I have no idea if any version since then works OK or not.

I want to install one of the latest ones to access the Nvidia Shader Cache Size setting, which is doing the rounds at the moment online for Star Citizen and plenty of other games - because there seems to be an issue with the default 1Gb setting and having multiple games on your system - this causes the limit to be reached frequently and the cache to be subsequently rebuilt, causing large drops in performance - at least on certain systems, and especially those with 32Gb of RAM.

It is a constant source of frustration to me that Pimax don’t provide any clarity on driver compatibility, especially when Pimax products seem to require specific versions to function properly.

If Pimax want to make customers happy, they should be extensively testing and then communicating their findings regularly. Instead, we get nothing.

The current attitude is “Just cross your fingers and hope it works - but if everything breaks, let us know and we’ll try and do something about it in the next release”. Not exactly an adequate ‘system’…


So far so good. I’m now on 479.9, and tested one VR title, Blade & Sorcery. Launched fine from Pimax Experience and no performance issues, but not really a demanding title either. Especially now that PP is no longer required again.


@Octofox Does the 90 Hz mode work for you? Just upgraded to 472.47 (the latest Studio driver) and I only get black. 72 Hz native and 114 Hz upscale both work. Undecided whether it’s worth to roll back again or forget about the 90 Hz mode until Nvidia/Pimax get it working with a current GPU driver version (and optimally all versions after).

1 Like

I’ve only tried with B&S but yes. I did leave Motion Smoothing on though, but the game rarely needs it (just one of the old pre-U10 maps so far) and so mostly plays at 90Hz.


Just do be sure: So, you were able to enable the 90 Hz refresh rate native mode for the 8kX with current Nvidia GPU drivers? (Not so much concerned about 90+ fps - this depends on PC hardware, game, settings etc. - but more whether you see anything at all in 90 Hz mode)

Yes absolutely. I’ve had 90Hz native mode set for a while since whenever the PiTool and firmware versions allowed for that, and it’s still set and working for me with the latest Nvidia driver (released 1st December) - no black screen.

I’ve not used a driver to date that triggered a black screen when trying 90Hz mode though - other earlier drivers just refused to launch games entirely, I had a spinning wheel within PE or the apps would simply launch in desktop mode. I use the standard DP cable, no extensions.

But as mentioned I’ve only launched B&S since the driver update, I haven’t tried any other game yet not been doing much VR of late. If I get a black screen on any other title I’ll update here :+1:t4:

Values in PE match of course:


And my PT and FW:



Great, thanks! Good to know that it should work. May have to test the latest gaming driver then. (Am on the studio driver because I don’t have to sit on the bleeding edge when it comes to GPU drivers - but if the new one is better in relevant aspects then - sure!)
Hope it’s not the new optical cable. That would be a bummer. Am quite happy with the bigger range that these two additional meters add. Will have to check.


Ok, first I upgraded to PiTool 271 (from 270) which turns out to still work for me (273 doesn’t) which is supposed to allow newer Nvidia drivers with 90 Hz.
Tested with the latest game ready driver 497.09 and went back to the original cable. Still no picture with 90 Hz. It might be the 298 beta firmware that I am still using?
(Tried again to update to firmware 299 again - no chance, just a yellow led, have to return to 298.)

Then I finally reverted to the Nvidia driver to 461.09, now 90 Hz works again. Good news: It also works with the new optical cable.
So I guess I cannot upgrade my Nvidia driver until there is a new version of PiTool+firmware that supports the new drivers and works on my 8kX.

Good news is: With PiTool 271 the Dfu.exe firmware update tool seems to work now for me. Previously only the command line DfuSeCommand tool could sucessfully flash firmwares, Dfu.exe failed for PiTool 270.

So the combination PiTool 271, Firmware 298 and Nvidia driver 461.09 is the best possible combination for me at the moment when it comes to the 8kX.

1 Like

After about 15 minutes happily playing table tennis in 90 Hz native res with the new cable, the screen went blank, the 8kX makes an odd buzzing sound and PiTool doesn’t recognize it anymore.
Went back to the original cable. Tried to reset the firmware again. But the 8kX drops out of transfer mode after a few seconds, the led going red.
I fear my 8kX is gone now :frowning:
Have been playing with 90 Hz before for longer times. But perhaps the experiments with the newer firmware and/or the new cable stressed it and now playing with 90 Hz for some time again did the rest.
So I guess 90 Hz isn’t good for the 8kX. Or I had a suboptimal unit. Will contact support.

Oh no sorry to hear. In which case I hope support can help you out :pray:t4:

I tested earlier with VTOL VR and a Warplanes: WW1 Fighters demo. No black screen for me.

1 Like

Sounds good, fingers crossed that it stays that way!
This is my second 8kX already. The first one was replaced because it refused to work in 114 Hz upscale mode. Perhaps the frequencies Pimax drives the panels with are outside of the comfort zone for some (batches of) parts?

Hmmmm maybe I hoped they sorted out that sort of quality control issue by now, but perhaps not. I guess there may only be so much control they have over third party suppliers.

Still, it should not be the concern of customers. I hope they fix it once and for all and asap for you. @PimaxQuorra I think you should get involved and make sure Support deal with it promptly.


Jepp, think it’s a case for support. Already opened a ticket. Wouldn’t expect them to jump on it on Saturday night :slight_smile:

1 Like

Yay, my 8kX works again! The Pimax support figured out what the problem was: Apparently it pulled more power from the usb port than my computer internal ports could provide for longer time. The solution was to plug in the USB cable to an externally powered USB hub.
No idea why it worked up to now and suddently stopped working. But good to have it working again! The buzzing sound is now also gone. Phew…


Nice great news! :partying_face:

Just tested Star Wars: Squadrons. No problems with 479.9 and 90Hz I’m happy with this :+1:t4:


Just now, i am on windows 11 with 496.76 nvidia drivers without any problem. 8KX here with the last pitool an firmware runs at 90hz

On the other hand, I don’t use pimax expierence


With the 299 driver firmware I got from support and PiTool 273 I can now also use the latest nvidia driver 497.09 with 90 Hz. Finally!

1 Like

Great! 299 driver?


Yes, support sent me a P2_DEBUG_8KX_M299_t20211101115020_r85cdd55_forEnableHDCP.dfu firmware which (in contrast to the 299 release version) works on my 8kX. Debug builds might be slightly slower than release builds, so if release works for you I don’t think there is a reason to switch. Otherwise I think they have noticed that the official 299 release doesn’t work for everybody, so hopefully a new official version is around the corner anyways.


Ah firmware, nice :+1:t4: