Room setup: new 8kX driving me crazy

I’m running latest PiTool and SteamVR… 2x base stations + 2x controllers

SteamVR Home seems to be “locking” the headset at the floor and is not centered on the controllers. I’ve tried repeating the room setup several times in both PiTool and SteamVR. I’m getting confused and frustrated. I assume this is some sort of user error on my part but I can’t figure it out.

Both PiTool and SteamVR seem to be cool with the headset, bases, and controllers all being connected and visible.

Help please.

Turn off your controllers. Are your base stations still blue in PiTool? If not, your headset is stuck in 3DOF mode but isn’t warning you.

This is typical when the LH chip does not initialize properly. To fix this, one solution is to remove the connector from the headset’s end and plugging it back in while keeping PiTool running. Do not unplug anything else.

1 Like

well… this all makes sense and I’ll run the test you describe shortly.

I’m not familiar with the function of the “LH chip” but I’ll do some research to better educated, in general. That said, what is the cause of the headset being stuck in 3DOF mode? This is a brand new device. Is it defective? Is there a specific order of initialization I should be using when bringing up the VR stuff???

Cheers and thanks for the insight.

1 Like

LH chip just means Lighthouse chip. Its what handles all the data that the IR chips receives when a base station sweeps them. When the LH chip isnt working properly, no positional data can be extracted for PiTool or SteamVR to recognise. Hence it defaulting back to gyro aka 3DOF.

I dont think the issue is related to a defective unit. Ive had this problem on all of my 8KXs and just seems to be a weird bug with it. The solution shouldnt be too hard though if it fixes it for you. Keeping the headset USBs plugged in at all times and turning it off from the power button instead removes the need to do this fix every time you want to use VR.

I’ve been having the same problem with room set up. When sizing in sitting mode, there’s no way the setting stays true when in IL 2 cockpit. I fly with no base station. I have one base station, as I fly or drive sims only. When I attempt sizing while standing, I can’t go any further than setting the 8kx. It wants me to use the controllers before I can proceed with the room sizing. I’ve read that if you size the room for sitting, steam room set up is what should be used. Why does steam room set up want me to set up controllers when there are none connected? Am I doing something wrong? hanks for all help…take care…

Not 100% sure I’m helping but I’ve found that, if I leave controllers off and fire up PiTool with only the headset and bases powered, only about 50% of the time will the headset register with the bases…

… as per any earlier post, this leaves the headset in 3DOF mode.

To fix, i unplug and replug the headset. I’ve got an open support question about fixing this… its really annoying and feels ‘bush’

My suggestion is try to leave your controllers off (if you have them) and unplug then replug the headset to see if this registers to the bases. No point in worrying and room set till then.

Just as a reminder:
Sufficient distance between bases and headset (approx. 2 meters), set different channels for two bases.

1 Like

I have my problems with positioning, but only with DCS and neck saver there. For that to work, I have to make pitool calibration, and after that steamvr calibration - in booth cases my middle point (hmd head position for dcs) must be exactly same in booth calibrations. 1cm or degree mismatch is visible in game.

@eddie also steamvr calibration is possible without controlleres;
steamvr, hamburger menu top left, developer, developer options - here choose the biggest space (does not matter how big your room is), put hmd on floor and click fast calibrate.

1 Like

dude at least your headset dectects I’ve had 2 head sets now that work the first time I plug them in then like never work again, well half work as my new headset doesn’t seem to have any working audio.