[ Resolved ] Received 8K today, keeps disconnecting

Setup everything, it keeps disconnecting and reconnecting every 15 seconds, giving alternatively error 20300 and 10600, someone has suggested it could be a defective cable rather than the HMD, how can I proceed to get tech support/replacement now?


Have you tried the following?

  • Reseating the cable (unplugging and replugging the cable on both ends)
  • Restarting the HMD
  • Restarting your computer
  • Updating your graphics card driver
  • Switching to a different DP port

IIRC the HMD and your monitor should both be connected to the same GPU. That may just be a Vive limitation, though.




Can you post system specs?

Both codes you listed are related to detection if headset.

Also check taskmanager for pi_servers (2)

File a support desk ticket (create a support account if you haven’t already) & post Supen number here.

@Doman.Chen is one of the pimax techs.


Pc is a 4790k@4Ghz 16GB.ddr3 with a non OCed rtx2080ti, used for more than 1000 hours with a VIVE pro on 134% supersampling (suggested is 200%) with no issues.

What I’ve tried so far:

different usb and displayports
reseating the connectors
updating and reverting to old video drivers
updating the hmd firmware
rebooting the hmd and the pc entirely many times
tried different combinations of fov, mask and parallelP
booting a game anyway even if the problem is still there

I either get colored lines all across the hmd’s screen or it turns off or a game image for 30 seconds
at best before resetting again, the most “stable” settings seem to be normal fov, pitool quality 1 and only 80% in steamvr supersampling, still stutters for those 30 seconds and cannnot maintain stable tracking.

1 Like

With your usb ports have you tried using the Vive breakout box for the Usb?

One user found his onboard Usb 3.0? Wasn’t putting out enough & had to use an addon card.

1 Like

Unfortunately the VIVE Pro linkbox has a proprietary connector going to the hmd instead of the separated usb and hdmi, also since I have a mini-itx mobo I don’t have slots for expansion cards :frowning:

1 Like

Yeah I’m a fan of mini itx.

A powered usb 3 hub might work. With your mobo ensure bios & drivers upto date from mobo website.

Which mb do you have?

I have an old msi 97 itx that doesn’t recognize an i7 4790 (verified it works on a different mobo)

1 Like

mobo is a Z97 by Msi with bios updated, I’ve tried a usb hub too but it didn’t solve it.

But now something comes to mind :thinking:
When I first got the VIVE pro after a couple hundred hours I had a similar issue (albeit not as severe ),
solved as soon as I received a replacement cable.
Basically this has been confirmed to be a problem with all the cables using displayport
instead of hdmi, they’re at least 10 times more susceptible to torsion and very finicky for
lengths above 3 meters. The problem is the Pimax’s cable comes crammed in a very small box and
so already pre-stressed and bent, so it could be that it gives that unstable link right out of the box instead
of several hundred hours of use…


Agreed might need to modify their packaging method. Perhaps have it in 1 large halo loop around the headset vs the narrow box.


1 Like

Wondering if your msi z97 is the same board I have. Need a cheapy cpu to update bios if so.

Ran into a fellow with i think it was a z97 hero asus board couldn’t get to work with the 4790 even with checking with asus.

1 Like

Just checked the box, my specific version is Z97I AC if that can help.

Yes about the cable, the VIVE pro had it all wrapped around in a spiral taking advantage of the
entire box width, also there are people reporting this problem with 4k monitors too, dropping to
30p if the cable is not good quality and gets bent more than 70°, if more than 100° losing the signal
So the more I think about it the more I’m convinced it’s the cable now :-/

1 Like

Iirc, the MSI mbs have some difficulties with USB ports and the Pimax headset. Try different USB sockets to see if some are better that the others. There have been reports of 3rd party USB adapter boards fixing you problem. It may be a USB power limit issue; if you have a powered USB hub (which plugs into the wall), you might want to try hooking up your headset to that. Good luck!

1 Like

Yeah tried everything, all ports on the mobo plus powered hub and as stated it’s a mini-itx so no pci slots for internal usb cards unfortunately.

1 Like

Looks to be the same board I have. Looks will need a cheap cpu to upgrade bios.

Had an awesome deal on tge i7 4790. Bought if for $150ca & buddy included 16g ddr1600 ram (valueram I think no headsinks)

1 Like

A cable like this might be a good option. As tge power cable could plugged into a wall adapter if needed.

Could be good for others as well.

1 Like

It says 1.4Amps top, the hub I’ve tried is even more at 6Amps…
At this point let’s hope Doman Chen sends a replacement cable (hopefully not bent in the
package like the one included) :crossed_fingers:

1 Like

My bad should have read the specs.

The good news: @Doman.Chen you can close the ticket, I’ve solved myself by straightening
the cable with a blow-dryer, now it doesn’t disconnect anymore.

The bad news: since I don’t think there’s a refund program for the KS backers, I think I’ll sell my unit.
I’ll post a micro impressions topic just to avoid spamming this one.

1 Like

I’ve marked this resolved and closed the topic. If you decide you’d like to reopen it, please PM me.