Problem with the latest firmware 1.3.0_au1103

I have a problem since updating the firmware to version 1.3.0_au1103 and the Pimax Client to version

When I close the VR headset with the button on the Crystal, the VR headset opens again automatically after 2 seconds.

The Crystal no longer stays closed.
In the Client, the Shut Down button no longer works since these 2 updates.
To close it, I have to disconnect the 2 usb cables connected to the power hub. When I reconnect the two cables, the Crystal opens without my pressing the On/Off button

My Crystal worked fine before these two updates.

1 Like


The shutdown bug is a known issue, and our developers are working on a solution. Hopefully, the hotfix can be released shortly along with the smart smoothing bug.

1 Like

While waiting for the bug to be fixed, would it be possible to reinstall the firmware that preceded 1.3.0_au1103 ?
Would it be possible to reset the Crystal and start again with a new installation ?

Thanks you

1 Like

It would be really nice if we could go back to an old firmware that worked properly for the user.
Why doesn’t Pimax allow this ?

I found a page with the old versions of the Pimax Play but I couldn’t find the old firmware. Release Notes - OpenMR | Community