Playing Lone Echo 2 In The Pimax 8KX - Live Replay

Tonight I am finally playing Lone Echo 2 from Ready At Dawn but I decided to do it a bit differently… For tonights stream I will be playing the game in my Pimax 8KX using Revive in order to get a higher resolution image and a much wider field of view. This game is absolutely stunning and while it looked great in both my Rift S and Quest 2 using a link cable, they just can’t compare to a 4K image with a 170 degree FOV!!! [;]-)

I had intended to stream this when the game launched but due to the loss of my Mother I have been away and that unfortunately put things on hold for a while, but I’m back now and I absolutely can’t wait to play this game! Lone Echo 2 has been one of my most anticipated VR games for years now and i’m looking forward to jumping back into Liv and Jack’s story and of course taking all of you along with me for the ride!


Sorry for your loss.

I think I’ll need to check this one out. What’s your thoughts on decent settings for the 8KX on this one? Things like pitool settings and if you noticed any particularly important ones in game?

Loved the first game for sure.

1 Like

indeed,what settings where you at in the pimax pitool and ingame?

1 Like

Im still playing the 1st game … but why Revive rather than PiVive (Pimaxes Version of Revive built into Pitool/PE)?


im playing this one 8kx and revive, my first session of about an hour and a half i had great performance and quality on my 3090 (small fov, 75hz, pp enabled, 1x pitool, 100% steamvr and in game, HIGH preset for game settings) , the next day i loaded my save pressing continue and was stuck at 55-60fps and glitchy textures that either flicker or take up to 30 secodns to load after approaching a surface all at the same settings.

looking online a lot of people are having similar problems, for me i cant continue the game like this. if i put settings to lowest it DOES hold 75fps mostly, but it’s a muddy mess and the textures/lods are still buggy. hoping a patch is incoming, or otherwise someone else here figured out a work around. someone on reddit said flipping between HIGH and MEDIUM back to HIGH texture quality fixed it for them, but that didnt work for me.

by the way: i played the whole of lone echo 1 recently using quest 2 and air link, and i loved it thought it looked great. going into 2 with pimax and revive, and wow it’s so much sharper and better colors better everything. crazy to think so many Q2 users have no idea how bad they have it for pc content.

1 Like

While I don’t disagree with you that the Pimax is a higher fidelity experience.

I will probably opt to play this one on the Q2 Airlink.

I am currently playing LE:1 and I decided to try something. I am sitting on a bar stool turns out is crazy for immersion in this game. When floating in space the fact that my feet are somewhat off the ground really gives me the sensation of hovering freely.

Plus when I need to adjust myself or swing around something while holding on with one hand i just kind of kick iff and send the stool swiveling freely, feet off the ground. It really feels like im weightless.

The visuals we stsrtlingly crisp and hi def with my bitrate set to 200.

I went back to the 8KX and the weight of the headset compared to my suoer comfy BoboVR strap and the facke that I need studio form weights on the back of 8KX makes it really heavy on your neck to look down.

Plus I dont think I can use the stool with a wire unless I put carabeners up into the ceiling. (Not doing that, wireless freedom is seriously a game changer)

This game reminds me that its not just about FOV and specs anymore.


i actually played the same way with my office chair with the arm rests removed and you’re right its crazy immersive when you can lift your legs off the ground and do the spins – and yeah keeping track of the cable with pimax IS worse, but the visual fidelity is just so much more and more immersive… so i think in the balance i’d rather use snap turn and keep track of my spins.

now, who can fix this framerate and the textures for us!?

“CSI WTF?!” episode averted. :wink:

Yeah I’m kind of the opposite. Last night I totally forgot that you could use the right stick to turn. After 1.5 hours I accidentaly hit the right stick and was like “Oh Yeah…”

I just ordered the Fiber Opic for my 8KX because my pc is on the desk and turning in any direction coils me up immediately. Its unplayable.

something like this for adults has crossed my mind…lol


I don’t use them often but I mounted a couple of these to suspend cables for a couple of situations. One over head great for 360 rotation. Screwless mounts have strong adhesive that has kept them in place.

How did you find the Index controller bindings? Did they mimic Touch well?

Heh, kind of resurfaces to mind a pair of brothers who used to demonstrate and promote their idea for a way to move around in VR, which was to tether yourself to something stationary (ideally a swivel on a pole, for 360) by a bungee cord from your waist, which would pull you back whilst you were jogging in place. :7

1 Like

Won’t stick to stucco ceilings I’m afraid

I like the index controls better than native oculus (for the lone echo campaign at least, not so much for echo arena multiplayer)

but ok about the performance breaking, look what they’re trying to push on the discord (which doesnt even address that it worked perfectly my whole first game session with the same hardware settings):

Are You Experiencing Performance Issues? TL;DR: If you’re above minimum spec, performance issues are likely the result of component overclocking or using AirLink with Windows 11 (which isn’t supported by Oculus: You might be overclocking one of your components without realizing it!

Check out the links below on how to verify! A significant portion of users who have reported performance issues on PCs that meet or surpass the minimum recommended spec to run Lone Echo 2 (and have followed up with us after troubleshooting) have found that they were either overclocking (and subsequently bottlenecking) without realizing, or are running on Windows 11 with Airlink (which Oculus currently does not support, resulting in performance problems). Lone Echo 2 is big and performance-hungry, and there’s room for optimization. That being said, the game should be reaching the correct framerate (for the headset/platform you’re on) if your machine is above spec and you’re running on a supported OS version. We have been testing Lone Echo 2 on machines that span the gamut above min spec without the performance issues that some folks are reporting, which is why we strongly suggest re-assessing whether you’re overclocking one of your components: (edited)


3 Ways to Check If Your CPU or GPU Is Overclocked

If your hardware is overclocked, you’ll need better cooling or you could wreck your system.


What are XMP profiles and how do I use them?

XMP profiles automatically set your system RAM to higher frequencies. But should you?

obviously none of this worked or makes sense that it would work, but there you go – still looking for ideas from anyone else that might have stumbled on any good ideas. They wont let me contribute to their discord to directly troubleshoot because it’s confirmed users only and I’ll never give discord my personal details.

1 Like

Definitely going to try the bar stool lol and I got kiwi cable system so never have any cable problems :wink:

I will admit my Stucco ceiling isn’t a bumpy as it was new, but it is certainly not anywhere near smooth. The 3M adhesive pads that come with these are amazingly strong. Had them up for4 years now. never had one come off yet. ymmv


I hear you. I won’t use discord because they want my email to be on the same machine as their software.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.