Pitool v1. has caused SteamVR faiure

Restarts at the time it did not help. After I closed down and returned just now the problem seems to be solved so if it happens to anyone they should do a complete cold restart.

Date: 22/04/2022
Issue Title: Pitool v1. has caused SteamVR faiure.
**Description:**Cannot get SteamVR to run.Critical error. I have uninstalled and re-installed SteamVR. MSFS will switch to VR view but the view is stationary and will not move.

HMD Model: Pimax 8K plus
First 3 Numbers Serial: 206
Pitool Version: v1.
HMD Firmware: v2.1.255.273
Tracking: single station

System Info

  • Windows Version: 10
  • CPU: i7 8086 Spl Edition
  • RAM: 32Gb
  • Motherboard: Asus ROS STRIX F390
  • GPU Model: RTX3090
  • GPU Driver: 511.79
  • SteamVR Version: 1.22.8
  • Oculus Version: N/A

Attachments (Pics/Video etc…)


Nice pitool update if it is true. :frowning:

1 Like

… and once again no official announcement nor release notes until searching on my own on the PiTool download page:confused:

Well - as far as I can judge, there seems to be no major need to update from .275 to .277 for me. So I’ll leave that red notification dot in PiTool untouched :wink:


No Problem here, 8kx on Steamvr Beta.


Please ensure your watching release notes category. #pi-soft:pitool-notes


I have been using V275 for a while and am experiencing the same freeze with MSFS2020.
The probability of this happening is much higher if I use steamVR auto-start when I start VR mode.

My guess is that this is happening when the HMD is not in detection range of the base station when auto-starting.
It seems that the HMD is missing its position and is failing to initialize.

If I start MSFS and then manually start steamVR before putting it into VR mode, it is fine. If this still occurs, please place the HMD in the detection range of the base station.

I have not experienced any freezes with that usage.

1 Like

Okay, I did the trial because the forum’s release notes state some “Additional bug fixes and optimizations.”, too.


  • PiTool seems to recognize the 8k-X now instantly again as it was before .275 when I used .270.


  • SteamVR failure:

I already did a cold boot, no change.

I’ll give a SteamVR reinstall a try now - but at least, this certainly isn’t what is supposed to happen…

Okay, seems to work again:
I did a clean re-install of PiTool .277 including deleting manually the four Pimax/Pitool folders in AppData and reboot.
At first, it did not work yet - it took me a moment to realize that there is a new feature in SteamVR which locks the Pimax PlugIn - so I had to unlock this PlugIn.
Now, I have image again.

Apart from this, as mentioned above already, the headset is recognized at once again :+1:
But the issue with pi_overlay.exe crashing when closing PiTool still persists:


"Additional bug fixes and optimizations.”

I wish @PimaxQuorra would elaborate a little more…


Yeah, no kidding. It’s not just Pimax; companies in general have mostly done away with the detailed update/upgrade notes we all used to rely on to determine whether we really wanted to do the install. It’s almost always now vague language about ‘bug fixes and optimizations’ (even though, ironically, a release may actually be both buggier and slower.)

I would sure love to know a little more about this release. (Please, PLEASE tell me I can use Smart Smoothing again! That 1/3 rate needs to go away. Permanently. Forever. Gone. Bye bye!)


This is unfortunately out of his hands. Quorra, @PimaxUSA and myself have been pressing for quality release notes without much success. I imagine even @SweViver whom has demonstrated with @arminelec have also requested professional release notes.

We last had quality release notes iirc 2 years ago.

I get an error failed download at various MB (changes each time I try) - could the server be busted? I guess I don’t care as I don’t have tundra trackers or leap motion…

Ya. it would be nice to have a list of what is unresolved and being worked on. It would reveal something of what Pimax thinks is still in need or improvement.



I wish I could done more than this.

Will give it a try on the next update to have a detailed patch note, or including the unresolved and new feature that being worked on.


Well after update to V277 my PIMAX 5+ cannot connect failure 20300, although it is connected to DP Port like before. Nothing has changed within my hardware.
Although plugged/unplugged ports and cold-started PC… nothing helped…what should I do ?


roll back



Fall back is something that should work.

Some find uninstalling, delete pimax data directories and clean installing may also work.

1 Like

If nothing else help, then unplug cable from HMD side, and replug it again. PC side will not help.
It solved once same problem to me; also didn´t change anything in my hardware, and that was inctructed by Pimax helpdesk.

20300 usually mean that there are too many USB devices, You may first try to remove some unnecessary USB devicesand tips provided from the community .
If it still 20300, we suggest you to log a ticket at our helpdesk.
Our technician is ready to provide assistance to you.

1 Like

Okay, unfortunately that worked only that one Windows session on 04/22/22 correctly - since then I am still and again having the problem, the headets isn’t recognized directly: First #10600 for 3-5 seconds, then #20300 for 1 second, then, the headset is identified and everything is working properly, just as it was with .275 before, too.

As I had another problem with fholger’s vperfkit not launching since two or three days (.277), I did the try and made a downgrade to .270.

Result - really weird:
During downgrade I did three Windows restarts - two after uninstall and folder deletion, a third after PiTool .270 installation.
=> The HMD was recognized properly and I could play for half an hour.

I then shut down the PC completely during lunch, restarted it 15 minutes ago - and PiTool wasn’t able to recognize the 8K-X any more. Same as I had two months ago when I first went to .275, had the aforementioned problems, wanted to downgrade to .270 - and at that time, too, first launch after having done only “warm” reboots was no problem. But as soon as the PC was completely shut down over night, I wasn’t able to convince PiTool .270 to work with the 8K-X any more. So I upgraded back to .275, got the initial detection and pi_overlay.exe crash problems back - but at least the HMD was working again.

So, as far as I can judge, firmware version isn’t downward compatible properly, for whatever reason.

Besides: Back then in February, even trying a firmware downgrade to the corresponding version of PiTool .270 didn’t work…
=> So really be careful for the moment. If you have no need to upgrade beyond .270, don’t do so - stay with .270 or before and remain happy that everything is working :wink: