Pitool v1.0.1.274 Beta

Motion smoothing does not work when using 90hz. The screen stutter like crazy

1 Like

I’ve got the exact same issue as Vulcan.
is there any solution ?
i updated to 274 as prompted by PiTool, it tried upgrading the firmware of my 8KX headset but kept failing.
The headset lights keep flashing red, blue and green.
PiTool says nothing is connect when the headset clearly is.
Im unable to manually update the firmware as it says nothing is plugged in when it is.
using a 3090. nvidia driver is latest

1 Like

SOLVED .
a Thrustmaster steering wheel driver was conflicting and preventing the 8KX to upgrade its firmware.

i followed this solution: Failure Upgrade (blinking led) : Pimax Support

and applied this firmware (for 8KX): FOR 8KX : Pimax Support

3 Likes

Yeah that issue is in the Table of Content Wiki(see your profile under the star)iirc. Glad you have it working. Glad they added this community solution to there main site.

3 Likes

I am in China, although I am British. I can not access google dive (from here).
I hope Pimax can add a direct link to the driver on their Pimax website.
I have seen request for this before.
I am not updating, because I have no (almost) access!

3 Likes

Well I just did the update to 1.0.1.274. Guess it is not beta any more!
The update went smoothly.
It did force the firmware update (that was worrying). However, firmware update to 2.1.255.299 went smoothly too. A few flashing LEDs. Wait a mo and all good.
Smart Smoothing is different to what it was in 271.
Still not working, but need a different description.

1 Like

Thanks removed my comment above. :beers::sunglasses::+1::sparkles:

Am i the only one who doesn’t have the option for 75hz or upscaling mode? The only option is 90hz and works fine.
I’m on Pitool 274 and firmware V2.1.255.2001.

That Firmware number looks wrong.
At the moment I have:
8Kx
Pitool V1.01.274
Headset Firmware: 2.1.255.299
SteamVR 2.16.10
Pimax Experience 0.85.0.3

For my 8Kx I have 60, 65 and 90 Hz plus upscale.

2 Likes

When i got the 8K-X it was like this. You think i should flash it? When i click on “check firmware” it says: no update available.

I would.
this is the lattes Firmware (according to pimax site)

As you see above, i just updated the firmware, with the latest Pitool.

Pitool 247 has had problems. I have had none.
But I am listing some issues i am having now. Are they because of Pitool 247 or are all my issues to do my AMD 6900XT!

If it ent broke, don’t fix it.

Thanks man, i’m gonna try it.
Maybe it solves the annoying IPD pop-up/adjusting it 1mm the whole time when connecting the hand tracker as well.

Hmm…after flashing it stays on firmware V2.1.255.2001.
I only flashed the firmware.

After installing Pitool 1.0.1.274, I started experiencing intermittent BSODs with the error PFN_LIST_CORRUPT. These were infrequent (like once per day or two) until yesterday when I was trying to play After the Fall I couldn’t make it through a single mission and after multiple BSOD’s I switched back to my Index so that I didn’t have to abandon playing with my friends.

After that gaming session, I reverted to 1.0.1.273 and tried playing After the Fall on the 8KX again and have experienced no more BSODs since reverting.

The BSOD’s were infrequent enough that I can’t verify with certainty that 274 was the cause yet. I’ll have to continue on 273 for a good while longer without seeing any more BSODs to be reasonably sure. Reverting to 273 was the only thing I changed.

I also just got 8KX with firmware V2.1.255.2001 and pitool 274
I only have 90hz available, no upscaling

Response from support is that it’s now 90hz ONLY and no upscaling is supported

4 Likes

Thanks for the clarification! Weird decision from Pimax to take away the upscaling support. :face_with_raised_eyebrow:

1 Like

WHAT??? No 74hz???

2 Likes

@PimaxQuorra can you get some answers? Pimax did a poll and it was deemed to keep Upscale mode(advertised feature) and other refresh rate modes.

4 Likes

Supporting 90Hz native only seems like a good choice for Pimax to me. So long as it works. I have not yet had 90Hz actually working (I’m waiting on more feedback before upgrading firmware).

I’ve done my own testing on the upscaling mode and found that it produced substantially worse clarity in eye chart tests and no performance boost in return for that tradeoff. The only advantage to the mode is the higher max frame rate cap. That maaaybe has utility if the native mode is limited to only 75Hz, but when native mode runs at 90Hz the case for upscale mode at 110Hz becomes very thin. Especially when you consider that reaching >90Hz frame rates is pretty tough with even the fastest modern GPU’s at these resolutions.

I’d rather see this small company concentrate its resources on perfecting 90Hz native rather than trying to support several other much less useful modes. Indeed, I think concentrating on releasing fewer well polished things rather than releasing a larger number of unfinished feeling things is a shift that would benefit Pimax and their customers in general.

My only concern is not having 75Hz native to fall back to if 90Hz isn’t working. But if 90Hz is rock solid, then this isn’t needed.

2 Likes

Well, okay, so for me that means I will stick to my old .270.
I cannot find any benefits in the newer versions, FFR still is broken in Elite:Dangerous and my Truck Sims (probably due to the games having changed their AA technique/mode), and with my high graphic settings I don’t even get beyond stable 60-70 FPS - so why worry about 90 :wink:

Nevertheless keeping an eye on every new version just in case there’s anything worth the upgrade :+1:

2 Likes