Pitool v1.0.1.270 support 90Hz 8kx?

As in topic. Does .270 have 90hz option?

I have beta firmware with native 90Hz for 8kx but only pitool 269 works with it for me.

1 Like

I see the 90Hz option but as I’m on a 2080 Ti it doesn’t work properly here (black screens).

I can switch between 60, 75 and 90Hz in .270 though (as I could in .269).


Yes, it does, I have no problems,
Evga FTW3 3090.


did they give any reason why a 2080Ti is not supported? Is my 2080Ti an outdated POS now?

Also is there any negative side effects / bonuses if I install it anyway ?


Sounds to me like they haven’t gotten it stable (yet). They might at some point, but who knows?

They did pretty well with the 5K+ :wink:

Well, it is… :slight_smile: And so is mine (but You can still sell it for a premium if You buy a crazy premium 3090 - in hindsight I should have ordered one back when we could and have waited - it would have saved me a lot if I end up going for one now) … :smiley:

I don’t think there’s any bonus for installing the firmware, but there are bug fixes in PiTool .270:

I don’t know of any side effects, yet … :wink:


Sounds like the 90hz can work with a 2080Ti but worst case scenario it may flicker, has anyone tried 90hz on a 2080Ti with 8KX yet?

1 Like

Yes (well worst case it’ll turn off the panels like it does for me). Some with success. Check the thread I linked:


I think there is something about the USB power mode guide added in this version that causes my hmd to go black when I cover either the left or right side of the headset? This is bs. I know my lighthouses 2.0 is working fine. I also notice that I run an SRS shaker that uses a USB port as well…but as soon as I disconnect port and not use it, the black out of the hmd is gone…so I KNOW there something wrong with the Pitools.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.