PiTool shutdown memory error


This error occurs when the system shuts down and is a very old bug.

2 Likes

Hello,

Does it happen when you run the most recent Pitool?
Or is this a problem with every version?

Regards.

I am on Win10 Pro with all latest updates and Pitool does this to me if I shutdown while it is still running. Versions 279 and 280 have same bug.

You can exit Pitool before you shutdown Windows and avoid this error.

I’ve seen this problem consistently, too. Trying to shutdown the PC while PiTool is running has always been a recipe for trouble in my experience, and I’ve thought that was the case for everyone and assumed Pimax knows about it and just never fixes it. It’s easy enough to work around by just avoiding shutting down while PiTool is still running, but that does kind of suck. It’s one of the reasons PiTool is perceived as flakey software.

The first problem that PiTool creates for shutting down is that it blocks shutdown in the first place. It gets stuck on its “Are you sure you want to Quit?” dialog. Frankly, it shouldn’t have this confirmation dialog on exit in the first place. But especially, it should be bypassing this dialog and honoring the Windows system shutdown rather than sitting there trying to show a dialog the user can’t even see because Windows is shutting down. All the user gets is the “This app is preventing shutdown” thing. That’s bad behavior for PiTool.

And then on top of that, these error dialogs will come up. There’s a few different ones. I just tried testing this, and I got a different one for cmd. But I’ve seen plenty of crashes from pi_overlay.exe before when trying to shutdown. Typically multiple dialogs in a row for multiple things that crashed.

I tried some variations of steps in reproducing these problems and found that these error dialogs were only happening if SteamVR was also running. If I booted Windows, only started PiTool, and then tried to shutdown windows… well, of course, PiTool will still block shutdown, but it didn’t cause an error dialog on top of that.

I’m running Windows 10 and PiTool 280 (this was also happening on my previous 275 and earlier).

It would be nice if Pimax cleaned all of this up so that Windows can shutdown cleanly when PiTool is running.

4 Likes

It’s a very old bug, so I don’t know exactly when it happened.

Got that.

I have to forward this to the software engineers. They shall take a look at this bug and sort it out.

Nice thanks :+1: … but while it is good news that you forward this info to the programming team, it is both strange and concerning that nobody at Pimax even knew about this annoying bug.

I am only a very new Pimax user since a month or so yet this was noticed after a day or two. I also still get random freezes after changing Pimax settings requiring a hard reboot, turning PC off at power then back on. That is not a good thing so I am hopeful the Pimax software engineers know about that problem as well… my guess, probably not !

1 Like

This is something that you learn to avoid doing as a Pimax user. Just like you don’t try to shutdown Windows while Pitool is running, you don’t try to change settings in Pitool while SteamVR is running. Or especially while a VR game is running, too.

If you always close any game and close SteamVR first and then make settings changes in Pitool, that works consistently without any problems.

Text in Pitool indicates that changing such and such a value will require restarting SteamVR or restarting the game. But you’re playing with fire if you make the settings change first while SteamVR and/or the game is still running and then do that restart.

There’s nothing that says that anywhere. So new users just run into it, and either eventually learn to avoid it or just avoid making settings changes altogether. Either way, it’s another issue that makes Pitool seem flakey.

Some of the problems with this may not even be Pitool’s fault per say. I think Pitool immediately makes the setting change, and maybe that sends something in SteamVR for a loop. But frankly it doesn’t matter to the customer who’s fault it actually is. If SteamVR can’t handle some settings change underneath it, Pitool should delay actually making that change until the next time SteamVR isn’t running. Possibly stop and start SteamVR itself (with a dialog asking the user for permission to do so). Detect if the user stops SteamVR and realize the settings change then.

This is important stuff for Pimax to address in order to expand to a wider audience of customers. Pimax has only had appeal to dedicated VR enthusiasts who are the kind of people who are willing to learn the ins and outs of Pimax like don’t try to shutdown while Pitool is running, don’t try to change settings while SteamVR is running, etc. Pitool needs to be able to gracefully handle the user doing whatever, including the user doing silly things or randomly pushing buttons just to see what they do. None of that should break it. A wider, more general audience is going to do those kinds of things and isn’t going to be willing to put up with it when it falls over.

True, and I already did know those things. I do always close SteamVR before any changes. There still are sometimes random lockups & system freezes requiring a hard reboot. No other app I run is as prone to this.

It’s been almost a year since this bug occurred.
The same problem has already been reported over and over again, but it hasn’t been fixed yet…

1 Like

I am a new user of Pimax PC. I am using it in my Dell system having Windows 10 Pro. I used it for a few days. For better performance of my PC, I decided to upgrade my PC Memory and installed a new Dell AA579531 32 GB Ram. after installing the new RAM it started showing a memory error. I was running fine with 8 GB RAM. Is there any issue with this RAM or this issue is with Pimax PC

How can I fix that issue?

1 Like