PiTool not recognizing 5k Plus headset. Windows unable to find/install Driver

Hello there! I’m backer #5343.

Had my 5k Plus delivered and set it up, but having trouble getting it to work. I installed the [] version of PiTool, but I keep getting random errors (presently 10500, but I’ve had a whole slew of them) and it just says ‘disconnected’. I have so far not been able to get it to be recognized even once.

I read that Windows is supposed to automatically install the driver for the headset, but it seems mine fails to do so. It can’t find any drivers to install, and it’s listed as ‘unknown device’ in the device manager.

I have tried reinstalling PiTool multiple times (including removing all installation folders), turning the headset on and off, connecting to different USB and DP ports, various orders of restarting the computer and plugging in the power/headset after booting up…

Thanks in advance for any help!


ASUS Maximus IX Hero

Intel Core i7-6700K

Gigabyte GeForce GTX 1080 Ti Aorus

Corsair Vengeance LPX DDR4 3200MHz 16GB

Windows 7 64-bit

@anon74848233 @Doman.Chen

Please create a ticket from support: https://pimaxvr.com/pages/feedback

Run into same issues and mine only works o my Inateck pic-e 3.0 usb card.
Managed to have it working on 2.0 but not for long.
Might also be the cable on the headset that is not plugged properly, you can try removing it and put it back in.

For info this is the card i use :

I have made some progress and the drivers have actually been installed. However, now I am presented with:

Disconnected: Diagnose(10932)

If I click “Diagnose” it simply throws a blank and tells me:

“Unknown reasons, you can do:

I have made a ticket for support now. I so far attempted reinstalling PiTool, restarting my computer, unplugging and re-plugging the various cables involved, and even unplugging and re-plugging the HMD cable itself in the headset. I have tried various different orders of this, but nothing has worked so far. It does seem that at least some things are detected by my computer however, as the HMD audio overrides my default audio device when it was initially connected.

Are you sure your USB drivers are up to date? Check your mobo manufacturer site for that, also BIOS. Remember there’s usually two sets of USB drivers.

Maybe try removing the device in device manager and DELETE the existing driver, unplug the headset, reboot, plug it in again, thats what I’d do.

Edit. Didn’t some Asus mobos have usb problems…? @Heliosurge

My USB drivers are up-to-date. Just to be sure I downloaded and installed the latest drivers. I also updated my NVIDIA graphics drivers. I’ve also tried various USB ports; USB 2.0, USB 3.0, and my USB 3.1 port. I even tried my extra 3.0 ports (part of my case rather than being a part of the mobo itself). There’s been no change at all.

I am unsure how to find out which device to delete the driver of, considering the HMD drivers seem to have utterly generic names, and I can’t for the life of me find out which one among the list of ~10 identically-named drivers it is.

Oh, it’s showing as “unknown device”?
Maybe @Doman.Chen can help you

Well, earlier it did that. :slight_smile: As I wrote, I managed to resolve that one and get it to be connected in windows now (so I guess the title is a bit misleading by now…)

I had issues earlier (10500 and 10632 respectively) where the DP wasn’t connected or the DP AND USB connection weren’t recognized, but the current error, 10932, seems to come in after all of that. The PiTool clearly recognizes the cables are connected, because when I diagnose it doesn’t state that they aren’t (which is what it says with the other error messages), but for some reason it’s still listed at ‘Disconnected’ in the PiTool.

Oh yeah
What color is the small led light on the Pimax headset?

It’s steady red. I haven’t gotten the screen to flash on yet.

Does the power adapter work? Can you check that with a multimeter?
There has been a few bad adapters.

I don’t have a multimeter unfortunately, but when I unplug the power adapter I hear the windows notification sound of ‘device disconnected’ and both the vanity light and the power indicator light on the HMD turn off, so I assume it works.

1 Like

Thats all I got, maybe someone else can help you more, or you can email the Pimax support or post the problem here

They seem to solve the problems quite fast in that thread.

Thanks for the effort, man! I’ve also kinda given up trying to find a solution myself, as nothing seems to work. I made a ticket as Doman.Chen requested, and am waiting for a reply from them now.

1 Like