PiTool broke steamvr, other issues

So I updated to PiTool version and got a ton of problems @Pimax-Support @PimaxVR :

  • steamvr not working properly now. Half the time I run steamvr it stays in the white background, others you get into steamvr home, but in both cases, as soon as I click the menu button it crashes and shows the pimax logo, then the pimax space environment.

    Tried resetting the computer, headset, pitool, it keeps happening, at this point i’m yet to get steamvr working properly even once, so steamvr home is only usable as long as i don’t try to open the menus with the wands. I’m on 1.0 pitool render res and steam 80% and normal fov, so nothing too extreme imho on my i5 4690k 1080ti.

  • There some weird stuff happening. In the steamvr home, if you move your head looking at the shadows from the starting point towards the mountains, shadows morph unnaturally as you move your head from left to right, like it’s being rendered incorrectly. It also feels a bit wrong somehow, like the scene is not rendering perfectly fine.

  • I can start Hellblade from the pitool game menu and it now has some weird some issues. When moving your head fast enough the Hellblade logo ?? appears in the middle of the screen for some reason for an instant, then dissapears. There’s also some extreme color modification at the near center edges of the screen, while the straight center of the screen is fine. This color issue doesn’t happen in the steamvr home though.

  • Low brightness mode is cool though, blacks are better, but not worth the price of broken steamvr.

  • Hibernation mode works, if I leave the headset 1 minute idle the screen turns off, really nice and could help improve the fog issue turning it on and leaving it idle for a few minutes for the screens to get warmer.

I’m an idiot and should have stayed away from this update since 1.91 worked fine, but the brightness and hibernation update was too tempting, now i have a ton of new issues.

update: Switched to steamvr beta, issue still happens, actually just turning the wand on crashes steamvr home to the pimax logo and gives a nice “steamvr has encountered a critical error” message on windows.

update 2: Tried to set brightness to normal, pitool to 0.75, still crashing as soon as i turn on the wands.


The biggest issue for me with this version seems to be the introduction of those vertical stripes, that randomly appear at 1/3th and 2/3rd of the FoV

1 Like

I’ve seen something that may be related to that, something like a rectangle in the middle of screen with distorted borders when I move my head too fast, happens just for an instant sometimes.


This waterfall effect is super annoying


What about Pimax gets some beta testers on the forum?

So far I have no issues.
Just love the sleep mode, I was used to turn my hmd off everytimes and it wasnt detected back everytimes, was annoying.


8k or 5k? 20 characters


Yeah that sounds like it

If you’re asking about @Ludiks he’s got a 8k, you can see π8k next to his name.


We are early adopters. Might be an idea to roll back to previous pitool &/or firmware.

@anon74848233 & @Matthew.Xu can the pitool download link in banner to include pitool & firmware links? With roll back instructions on firmware?

Might be an idea for future pitools to incorperate this as a feature.


Ok, so what is the consensus (if there is one) on the best version of pitool to install assuming that we can get hold of older versions?

1 Like

Thank you for your advice, Dan.

I will let the technical support team deal with this.

@Sean.Huang @Doman.Chen @Alan.sun Please help to deal with it.

Thank you very much.


If you are using Vive controllers 1.95 is the most reliable one to use. You still get sometimes problems but far less than 1.91.

1 Like

Sorry if it’s been asked - you are aware of the issue, right? And working on it?

1 Like

where do i get 1.95 - main link seems to be to 1.91?

1 Like

Install 1.91 and then update software in PiTool.

1 Like

I will learn about this issue and report it to the technical department


Here are all versions:


thanks both. now to play Eeny, meeny, miny, moe with the version no…


At least you have a headset to play with :slight_smile: I don’t want to touch my Vive anymore…

1 Like