PiTool (stable) released

Official Version Features

What’s New:
Add Japanese language support.

Issue Fixed

Fix the occasional ghosting problem caused by the high GPU occupancy

EDIT: Seems it should have been The last beta was also even though the download page says

EDIT: As You can see on the screenshot above after install You might have different brightness values for each eye. Press default and/or set the values again after pressing the chain icon.
EDIT2: This seems to happen on every restart.

Direct link: http://piplay-us.pimaxvr.com/PiToolSetup_1.0.1.132_212.exe

There’s no new firmware update with this version (i.e. it’s the same as in beta = v2.1.255.212 as the filename suggests).


  • Brightness slider uneven between left/right after update (on every start of PiTool)
  • Chinese language (text) in language selector seems broken (see screenshot)

Wow, excellent news! Can’t wait to test it.


This is lovely news!

It will most likely fix the flicker when doing the GPU “default” button trick and getting better performance :slight_smile: Great job!


Fantastic, excellent news!


I dont get the Version-Numbers Pimax is using. I have V1.0.1.109 this one reads should it supposed to have a higher Version-Numer then my current Version??

Which one is better, can someone explain?


They most likely forgot the 1… :smiley:

EDIT: I actually think it’s the other way round. .109 should have been

EDIT2: Nope. It’s the new versions that are missing the 1… :wink:

.132 is the latest stable release, .129 is the latest beta.

Hope it fixed controllers not connecting and showing the annoying “not enough dongles” issue…

1 Like

So does .132 include the changes of 129?

1 Like

I would really think so, but someone with an RTX card (who can test FFR) need to verify it as mine is sent in for repair (I’m on a 1080Ti and the FFR options won’t show up if the card doesn’t support it).

EDIT: Seems to me like the rest is there:

BTW - Even the filename says

So I just installed the update. Now the left eye of my pimax is darker than the right eye…

Anyone knows how to fix this? The Brightness level on left eye is -5 but when i move it to 0 it jumps back to -5???

1 Like

Press the little icon which is between left and right to align them?

Okay a press on “default” did the trick :wink:


Just noticed it’s the same on my screenshot… :smiley:

Didn’t try it yet as the kid isn’t asleep yet.

Just did a few reboots and it seems to me that they’ve improved the PiService.

I don’t have to restart PiServiceLauncher to get my Pimax tracked/recognized… :open_mouth:

FYI - The PiServiceLauncher service is set to auto-start, but I start PiTool manually.

1 Like

Hmm, PiTool “Check Version” still thinks it’s the latest version. Why is the button even there, if it doesn’t know there’s been an update?


I noticed the same thing…! :smiley: I don’t think it has ever worked.

I wonder which URL it actually “polls”… Probably a broken link… :smiley:

@Sean.Huang, There’s a text issue. The default was the 1/4 string. It worked fine, once I changed it to English.


Got that too. Guess they built it with a broken Japanese as default language.

1 Like

Added bugs to the OP.

1 Like