Piservice keeps disconnecting and reconnecting the headset

Hi all,

I have installed Piplay 1.2.57. When I connect the headset, Piservice connects it as an additional screen + the Rift sensors (shown in the Device Manager), but then after a few seconds the screen flickers, the device is disconnected and then reconnected again. As a consequence, Piplay cannot see it and I cannot use it.

I have tried uninstalling everything (including Java) and reinstalling, cleaning the registry, rebooting pi_server, Piservice and Piservice_launcher, disconnecting and reconnecting the headset… nothing.

My specs:
Windows 10 Creators Update
MSI Nvidia GTX 970 latest driver
no internal graphics card installed

What could I try next?

If you have a lot of usb devices try reducing to the number of needed usb devices. Ie hmd/headset/keyboard & mouse/controllee

Thanks for the reply. I tried reducing the number of USB devices connected, it did not help. Piservice keeps disconnecting and reconnecting the headset, the screen flickers, the light on the headset becomes red and then blue again until the next disconnection.

I run 2x GTX980 in SLI (knowing SLI does not work as expected with VR) otherwise my build is quite similar to yours around Win version etc. Its been a PITA to get it to work correctly using 1.2.57 and the latest NVidia driver and I cannot get 1.1.92 to work with the latest NV driver at all. So I’m stuck with 1.2.xx unless I revert back to an older NV Driver and I’m to stressed about it not working again to go there as 1.1.92 has documented connection issues to begin with although it has better image quality.
I had to do the following to get it to work after updating Piplay and the NV driver and having the same disconnecting problem all the time.

  • Uninstalled Piplay and removed all references to PiMax and Piplay from the Windows registry and also deleted all the folders I could find. Then unplugged the HMD from my system completely and rebooted.
  • Did a clean NV driver install of the latest driver. Rebooted again.
  • Plugged the unit in after the reboot using a different USB port as for some reason Windows could not “recognize the USB device” on the initial USB port. Then I installed ver 1.2.57 of Pimax and rebooted again.
  • Then I enabled the display on the NV control panel as the HMD started in extended mode by default. If your HMD starts in PiMax mode you are good to go and test via SteamVR. If not then check the NV control panel and enable the display under the configure multiple monitor section. DO NOT FIDDLE with any NVidia display enhancement settings like digital vibrancy. It screws up Direct mode good and proper (at least it did for me) and I had to do it all again.
  • Once that is done and you can see the display in extended mode, flip the switch to PiMax mode and test in SteamVR.

This worked for me. It was a PITA but at least I got it working. Hope you get it sorted soon.

1 Like

Thanks so much, I have followed your instructions and got it working in Pimax mode. But now SteamVR does not detect the headset… the led is blue, Piplay shows the headset and Pimax mode working, but SteamVR just gives me error 108 (headset not detected). And if I try to setup the room, it says “no headset” also in the “standing” configuration.

EDIT: I got it working! I just reinstalled SteamVR while Piplay was running and now everything works. Thanks again!!!

Awesome to hear. Glad you got it working! Thanks @Grey.Nightshade for sharing on how to!

My pleasure guys. The device is a bit of a lemon software wise and seeing we are in this together, I’m just glad I could help :slight_smile:

Now if we could just make that damn ghosting problem better…

With adjusting super sampling down a bit have heard it helps. Try 0.9 or 0.7

I’m running ss at 8 but it doesn’t seem to help much with the ghosting though :frowning:

True, ghosting is pretty bad as well. I have read somewhere that working with the Oculus Rift Runtime environment 0.8 rather than Piplay makes it better, but I still could not find a way to make it work.

Only here all wrote that they could not start in DK2 mode.
I also did not work.