Piplay not working! Need help

Just received the headset today, I followed the instructions including disabling windows defender and nothing is happening, the Piplay logo pops up briefly then disappears.

I tried this a number of times now, so here I am.

What am I missing here?

Shouldn’t be any issues with the system, it’s Windows 10 with a GTX 1080.

Check if pimax mode, Unplug & plug in your pimax4k’s usb and you can see the pimax logo through pimax4k lens.
Try it.

All I can see is the static Pimax logo, that’s it.


Yes, that means you are ready to use it. Now you can enjoy steamvr by following the link’s 8.Other instructions.

Link : http://community.openmr.ai/t/piplay-installation-and-using-instructions/130

No, that’s just the default image.

I’ve installed the software already and it doesn’t load, if it doesn’t load I can’t change mode or configure the headset. so no, it’s NOT ready to use.

When launching piplay. Launch as adminstrator.

With PiMax logo it *should be ready. Try launching steamvr from piplay or download a game from piplay.

Please if you can post your computer configuration.

Win version
Cpu & memory
Graphics card & driver version
Piplay version & firmware version

Yes, I’ve tried running as administrator, when installing and running the software.

I’ve tried steamvr with virtual desktop but it doesn’t seem to be working, I think steamvr is the least of my worries right now, if the Pimax software itself doesn’t work it’s just a waste of time trying anything.

More system specs for what it’s worth,

Windows 10
i7 4790K
GTX 1080 (378.78)
Numerous Samsung SSD drives…

Firmware version? no idea, how do I check that without using Piplay?

PiSetup version is 1.2.57.


I have to head back to work. But check a couple threads there maybe an issue with lastest nvidia driver.

@lukeb has nvidia as well as others.

Also there is a newer version of piplay 4 download

I knew the software for this was going to be a bit dodgy but this is much worse than I expected.

What’s the support for this like ? do the staff help here?

Okay, I figured out what was causing the problem, it was rivatuners statistics monitor. Once closed the piplay now loads…

First problem solved

Now for SteamVR

It keeps saying I’m in the wrong mode and I can’t change it. I tried loading virtual desktop but it’s not loading… driver issue?

I did all the steps you mention but not working for me.
I have nvidia 1060 card.
Uninstall all the nvidia drivers, downgrade, upgrade.
Uninstall piplay, reinstall.
Plug and unplug the cables …

Virtual desktop now working, not sure what I changed but it’s working.

I have to say the headset is not that comfortable, seems difficult to get the best or sharpest image without some discomfort around the nose.

One thing, the IPD… How do you change it? I clicked change but there was no English on that screen.

What is the render option for under device? what does it do?

Virtual desctop is working, try different start methods.

The PiMax staff is actually pretty good. It can take a bit to setup a skype session due timezone differences. During the skype session with teamview they can give hands on support.

@LukeB has used this service a few times.

Well unfortunately it seems that the latest version brings us a whole new bunch of problems.

I made a BIG mistake last night and installed the new Piplay and now SteamVR can’t find the headset any more.

Also my favourite video player, Whirligig doesn’t see the headset and none of the downloaded videos in Piplay work. The video player does not launch.

However the rubbish Kodi player works as normal. Very badly.

Sigh :(. Back to the old uninstall again.

I appreciate your efforts Pimax, but your testing is terrible.

I suspect others with NVIDIA video systems will also have some issues.
At the moment my advice is don’t install this update if your Pimax is working.

I installed the latest beta last night and steamvr was working for me.

Can someone tell me how to change IPD? the option is there but when select it that configuration screen is displayed and there’s no English there, so no idea what to do at that point.

The display has more detail but I’m struggling sometimes, it’s almost blurry sometimes.

Guessing the optics are not that good.

Okay that is a current issue as mentioned in the latest beta. On that page they posted an emglish pic.

Use left cursor & right cursor to move crosshairs. The crosshair will become 1. Press both to reset. Alternative on gamepad A & B

First method sounds overly complicated, will try with gamepad.


Your welcome.

For reference

1 Like

Well again Pimax support has come to my rescue.

It seems that one of the files didn’t get overwritten during installation (even though I ran the installation twice) and that was causing all the fuss.

Well support found the problem and fixed it.
I Can’t thank them enough.

Try and get that level of support from Oculus or HTC Vive. I don’t think so.

Cheers, Luke

1 Like