Pimax Pitool Tundra Incompatibility Issue

I’m already on 274, reinstalled twice in an attempt to rule out a bad install. Pimax customer service confirms it’s a problem. How long does it take to fix something this simple? We are going on a month now.

I am unable to individually assign the trackers in SteamVR > Manage Trackers. I’m on 274 and have tried both the Tundra SW5 and HTC dongles, individually paired, in different USB ports, and no matter what I do I cannot assign them individually.

I’ve tried uninstalling and reinstalling both Pitool and SteamVR and both of my Tundra Trackers insist on showing up as a single unassignable entry in SteamVR > Manage Trackers.

The entries below the single entry at the top there pertain to inactive HTC Vive Trackers.

If I attempt to pair the trackers through SteamVR it never goes beyond “Initializing”.

Pulling my Vive Pro 2 out of the closet and reinstalling the respective software and the Tundra Trackers show up correctly with SW5 dongle and can be individually assigned. Unfortunately, hoping that pairing process would persist over to Pimax, when I removed the VP2 hardware and open Pitool it automatically recognizes the trackers and reassigns them as the former single entry, which looks like it does in SteamVR > Manage Trackers only now there are 4 entries beneath it.

I’ve googled ad nauseum for hours about this problem, I’ve looked into playing around with .json files but don’t even know where to start. I’ve tried removing all USB devices under SteamVR > Developer > Developer Options and the devices don’t actually remove. Worrying still is that settings remain in Pitool after uninstall (contrast and brightness settings), so unless these settings remain at the hardware level locally in the HMD I’ve a feeling that Pitool is not uninstalling completely. The last time I reinstalled 274 I searched for all Pimax files and folders and deleted them all. Problem persists, Pitool insists on assigning them as a single entry that I cannot manage through either Pitool nor SteamVR.

I’m at wits end here, I bought these trackers for Natural Locomotion as this form of movement greatly facilitates immersion in Half Life: Alyx and similar slow paced titles with realistic movement and I found the bulk and weight of the 2018 HTC Trackers uncomfortable.

NaLo cannot work as it needs the trackers individually assigned to feet:

The problem is narrowed down to Pitool. It’s absolute garbage and their customer service is non-existent, I’ve about 5 exchanges trying to explain the above and they lack the technical competence to help with this.

I’m sick of Pitool. I wish there was a way to run the 8KX without it, it’s 100% the problem here.

Pimax, can you tell the janitor who makes the firmware at Pimax about the problem so he can get to it after cleaning the break-room? Thanks.

Still a problem, Pimax has not updated Pitool. I still cannot use the Tundra Trackers I purchased.

Pimax, can you tell the janitor who makes the firmware at Pimax about the problem so he can get to it after cleaning the break-room? Thanks.

“12KX in 2022 with super high resolution film projection technology”, LMFAO.

Maybe the Software Developer who makes the firmware is also the sole engineer working on the 12KX and that’s the reason this simple, already identified issue hasn’t been addressed.

Here’s the solution:

Transfer handling of pairing of all SteamVR peripherals back to SteamVR.

See: Vive Pro 2

1 Like

Eh you do realize you don’t need pitool to run at all? You can just shut it down. Pitool is just a way to configure settings.


You still can’t pair the controllers or trackers with a Pimax headset within SteamVR. I don’t fully understand it but Pitool somehow interferes here, even with Pitool disabled.

1 Like

You will simply need to wait on a fix. Tundra Labs Trackers are new to SteamVR. So yes sometimes it will take sometime to complete a fix.

Index Controllers for example was working prior to there non public developer release. When they were publically released they had a compatibility issue.

Being toxic because you have issues is not helpful. Neither is spamming the forum in multiple threads.

274’s release fixed some of the issues but as identified there are still areas unresolved. Pimax generally releases full versions vs patches(patches of course would be better).

SteamVR tracked devices needs to go through pitool so that these devices/controllers can be used outside of steam.

1 Like


Our Pitool team is aware of the incompatibility issue, as I summarised and transmitted all relevant information to them.

We’ve had a talk about this specific tracker issue, and they’ve assigned this work as a priority.



Is there any update on this Issue? it’s been 2 months since we’ve heard anything and it’s still a problem.


When will this issue be addressed? Many of us enthusiast Pimax owners cannot use Tundra trackers properly, I’m no expert but this doesn’t seem like a difficult fix, just relinquish tracker assignment responsibility from Pitool back to SteamVR, or is this not possible?

Either way, many members of the Pimax enthusiast community are fast losing faith that Pimax will be available to deliver the many promises of the 12K and other slated Pimax products if it takes you 6 months to fix what seems like a relatively simple issue.

Is the sole Pitool engineer at Pimax still busy with custodial duties? Can you ask them to pause cleaning the break-room to come and address this issue?

How much noise do we have to make?

It’s been 4 months now for crying out loud.

They have acknowledged the issue and are working on it. It was a reply on one of your topics on Reddit and here iirc.

Since no new pitool has been released yet. There still working on the next release.

I am a volunteer and not paid. Insults are against rules here and on r/pimax. Your post was flagged by several users and is why it was removed.

However you admitted your a Self Entitled Karen your own words on Reddit. Patience is a virtue especially when dealing with 2 3rdparty products.

Guess you never saw Wearality Sky which created an Aspherical fresnel hybrid lense.

Here is a link from Edmunds Aspheric Fresnel lenses

And a technical read


Reminds me of when you posted on Reddit insulting VR Lens Labs because they didn’t have lenses available for pimax hmds.

Being toxic like you choose will not gain you community support.


I would like this issue fixed as well my guy. nothing good will happen if you berate people. If anything this could fuel pimax to never fix the issue. In reality pimax could just chose to never fix this issue. please calm down vulcan. I feel you dude i really do. Here is to hoping pimax can fix this.

Helio, I dont think he hates you i think he is just spiraling because this has been an issue. I am sorry.


No worries. I don’t really take much offence from him. His post history on Reddit has caused him issues due to his Toxic attitude; he posted his rage letter on r/pimax to VR Lens Labs insulting them for not supporting pimax.

I do hope he can learn how to better conduct himself. As it does seem at times he wants to improve things but goes about it wrong.

I am impressed as of all the headsets he has bought and proclaimed them great only to jump on a new headset shortly afterward. He has been stuck on pimax ever since so far. So for all his rage type posts it seems he is hooked. :wink:

There just not moving fast enough to keep him appeased. Eventually he might join the rest of us with a zen like patience. :grin: