Pimax in-game image skipping/lagging

Before I get blasted I have searched the forums and have tried what is suggested to fix my issue with nothing working so far. I apologize if I missed the answer. I am new to the Pimax family and am loving my 5K+. My issue is that in some games the image “lags/skips” frames. Even when fpsVR says I am getting 90fps I can stand still, turning my head, and the image lags/skips. Moving makes this worse. This is extremely immersion breaking and kills the mood while in the game. Does anyone have a suggestion as to what can fix this?

I have tested turning on and off Parallel Projection, and Hidden Area Mask.
I have turned all settings in the games to low and no change
I have tried Large, Normal, and Small FOV…all do the same
Turned off Display Scaling in NVIDIA Control panel

I do not believe it is my PC as I run almost all my games fine. It is simply a select few that have this issue. Does anyone have a solution to this?

Thank you for your time,

1 Like

Might simply be those games are not pimax friendly. What games are you having troubles with?

1 Like

So far it is only happening in two of my games. There are many others I have not tried yet

  • Doom VFR
  • Gates of Nowhere
1 Like

I had this issue a while ago on my 1070 laptop. Kind of one/two lost frames every 5 seconds or so, even when franerate is 90fps. Try to uninstalling PiTool, install version *.132, and then install latest *.180 again. This solved my problem.


Hi Welcome to pimax forums.

Can you post your system specs please?

Windows Ver
Motherboard model
Gpu/driver version

If nothing above works try to uninstalling all your usb drivers with USBDeview and reinstall Pitool

1 Like

Thank you all for the responses. I went ahead and tried the first suggestion:

  • Unistalled PiTool and reverted back to version 132. After this install I upgraded to version 180(beta). This did not fix the issue
  • I have not tried the USBDeview as it is late here and I am calling it a night. I am not sure why the USB would be making a specific game skip frames though.

PC Specs:
CPU - i7-7700k
GPU - 1080ti
RAM - 16gb
Motherboard - MSI Z270 Gaming M7
Windows 10
NVIDIA driver - 440.97

I attempted to play a few other random games this evening after the PiTool revert/upgrade and they all played just fine. It is only these two games so far that have the issue. It is a shame because I really enjoy playing Doom VFR. I can live without the other.

If anyone has any other input that will be great.

1 Like

There is a bug caused by some HID USB driver that stresses the CPU causing drop frames every 4, 5 seconds on Dirt Rally 2. I fixed it with USBDeview

1 Like

Oh yeah I forgot this one, thanks for the reminder @Mlkconcept. It could be the well known LED software issue.

@Hudnutz try disabling/closing your LED light software if u use any in yiur PC. Especially Corsair/MSI and similar. These causes periodical stutters/missed frames every few seconds as well using Pimax.



@Mlkconcept - I uninstalled/reinstalled/updated all my USB drivers. This did not fix the issue. I also switched between all the USB ports that were on my PC. Also since you stated stressing out the CPU I watched my CPU on fpsVR while playing Doom VFR and it was very calm the entire time. Only spike was when the game first started. (FYI I am using the same USB port my OG Vive was using and it played Doom VFR perfect)

@SweViver - My MSI motherboard does have RGB but I do not use it. The lights are always off and the software is not running. My 1080ti has RGB as well but again neither the lights or the software are ever being used. My NZXT Kraken does have RGB enabled. I turned the RGB off as well as closed CAM completely. This still did not fix the issue.

I took some time tonight and fiddled around in the settings turning on and off everything that I could. No matter what I turned on or off (hertz settings 90…72…64, smooth motion, PP, mask area, changed render quality from .5 up to 2.0) nothing changed the skipping/lagging in the game.

I played 5 or 6 other games tonight as well randomly. None of them had the skipping/lagging issue. I am at a loss.

1 Like

Have you checked Lighthouses? Skipping/lagging when moving you head in my case was always related with distance and angle to LH. Try to turn them , and try to play not to close to one of them. Minimum distance as far as I remember is 1m.
Also make sure they are above your hight.


@Yata_PL- thank you for the response. I believe my lighthouses are fine. I previously went into the SteamVR settings and checked their mapping. They cover my entire play area and are above my height angled down. I have walked around my entire play area before when setting up the Pimax and they tracked as should. As I have said. So far this is the only game this happens in (that I have tested). All other games I tried track as they should.

The lagging/skipping happens when I physically move my head, as well as when I am using free locomotion while “walking” in the game. So even when no physical movement is happening it is there.

1 Like

So I finally fixed the issue after hours of testing. Apparently the “game settings” for the Pimax are not properly working. I had to set the following for the game to run smooth:

  • Small FOV - Normal FOV or higher did not work
  • 90Hz
  • PP on
  • Vive only game on

Turning all these on made the game run as it should at 90Hz without Smart Smoothing ever kicking in.

The problem is that even though I set these settings in the “Game Settings for Doom VFR”, this did not work with the game when started. I would start the game from “My Games” in PiTool and it would look and play like CRAP. The only way to make it play and look decent was to change all the settings of my current “Common Settings”, reboot SteamVR and PiTool, and then it would work…this is a super inconvenience!!!! Why even have Game Settings if they do not work?