Pimax client starts IL2 in Steam VR

Even wth PimaxXR up and running, IL2 launches in Steam VR whether launched from the client ( for my steam version) or from the desktop icon( for my non steam version of the game.)
The game does not look crisp and FPS are slow. In comparison-and strangely- FS2020 now runs very well and looks great with PinaxXR

You can use OpenComposite to make IL2 work without SteamVR and use PimaxXR instead.

It’s fairly simple, just install the OpenComposite Launcher from that link above (see the instructions), run it and do Switch to OpenComposite.

IL2 isn’t written for OpenXR. Read more abour why this is needed:

1 Like

Matt, you are freaking awesome!

I must be doing something incorrectly. I find the GitHub instructions hard to follow. I got opencomposite to work in IL2, but I only get 19-25 fps compared to 39-45 in steam.
Do I need to launch opencomposite switch AND OpenXR toolkit?
What about PimaxXR? Do I need the steam framework?
Pardon my stupidity, but what do I run in addition to the Pimax client?

The most common mistake people make leading to the lowered performance is differences in resolution. SteamVR lets you set the global resolution and also per-app resolution. But these settings are 100% ignored when bypassing SteamVR via OpenComposite and PimaxXR.

You can still use the rendering quality slider in Pitool/Pimax Client to alter the resolution (PimaxXR will read that), or perhaps the Override resolution in OpenXR Toolkit.

Btw here is my write-up instructions for OpenComposite (not specific to Pimax though):

I will add a gotcha for the resolution thing, since it’s not obvious. Hopefully this is your issue.

@mbucchia Hi Matt, here’s another issue for you.

I can’t start my steam version of IL2 in steam mode without getting a headset not connected error.
My IL2 standalone version will start in opencomposite (with only open composite and PimaxXR running) but I get 14 fps.
My DCS version is not a steam version, so it’s not seen by steam. When I try to start it from the desktop with Pitools, opencomposite, and PimaxXR running, I get this message: "failed to write applist json: Permission denied.
How have I screwed this up so badly:?
Now I can’t play DCS in steam OR in opencomposite.
Obviously I’ve done something wrong with the install.
I am using the openxr version of opencomposite, and the latest version of PimaxXR (0.2.8)
Any ideas?

Ok I solved the DCS issue. There was a file left over from the openvr AMD sharpening tool. Openvrfsrconfig something or other. I deleted it and then DCS ran in opencomposite with the .dll file for that.
Still working on getting the steam version of IL2 BOS working though.