Pimax Artisan: PiTool can't detect HMD after it was restarted

PiTool detect HMD only after reboot of whole OS. If I restart HMD (or use power button) it stuck on “Disconnected”, there is also USB-connection sound and unrecognized USB deviced in device manager. Tried all USB ports, of course.

1 Like

Hi, Which pitool Version do you use? BR Henry

1 Like

I’m using PiTool

1 Like

Ok there shouldn’t be any problems with tracking. In this regard, 258 is really good, but not very permormance.

Turn off HMD, then restart PC with "pitool starts at windows startup, dont use Pimax vrroom. Start pitool and then turn on HMD. Have you already performed the room setup?

When it Stucks try restart service or restart hmd from pitool option.

1 Like

Well, fixed by plugging Pimax to USB 2.0 on my motherboard. :slight_smile:


Same issue after changing refresh rate. Reboot and nothing…

Nice :slight_smile: I had it on usb 3.1 port. Are you using DCS? Then I recommend pitool 253…,but the tracking take a little bit longer. (Just for info :slight_smile: )

Ok that’s bad to hear…

Do you happen to have “optimized” your windows? Some people set up all services in windows for performance reasons … and suddenly wonder that nothing can anymore :slight_smile:

Is the green light on or red when you turn on HMD after start pitool? Sometimes it takes a little bit longer to detect.

Have you tried reseating the cable into the headset?

Yeah, it’s the same like if you resetting on the other end.
Seems weird that every time I’m inserting cable to another USB it spawns different “Wrong USB descriptor” device.

Sounds like you might want to open a ticket with support. Could be a funky cable or hmd.

I had a connect/disconnect issue with my M65 Corsair mouse and swapped mice only to have the issue continue. After reboot the replacement mouse was fine but my M65 persisted to cut out on another pc. Too bad as i loved that mouse.

Disconnect the helmet. Clear the data of disconnected USB devices. Connect the helmet.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.