Pimax Artisan disconnected after new Pitool install

i have not used my artisan since one year.

Today i tried to use it on a fresh windows install. I installed the last pitool version.

The headset was connected and all looks fine until i tried VR then i’ve got a steam VR issue.

Then i thought it was possible due to the fact that i had not restarted the PC.

So i restarded the computer and Pitool tried to process a firmware update that failed 2 times.

Since this time the headset is disconnected. Hdmi and USB are not seen and it is flashing green blue red.

What can i do?

1 Like

I have been able to update the firmware on another computer.
It worked after the second try.

Now the Pimax is seen and all looks fine but i start Pitool and my computer freezes after 5 minutes.

1 Like

I tried different USB port without success so far.

I’ve got freeze in the middle of the game.

Is it the latest pitool? Please post version of pitool and firmware.

Red green blue flashing usually indicates an issue with firmware flashing.

Maybe try previous pitool version and ses if it freezes.


Which version of Pitool and firmware you have installed for the Artisan?
After the freeze, does it computer work well? Or you have to force a reboot on it?

1 Like

The computer is frozen, i have to disconnect it from the power in order to stop it.

I’m using the last pitool version in a fresh windows Pro 64 install.

I’ve been able to update the headset firmware on a Xeon server. It failed the first time, i retried and it was ok.

Now the Headset is seen correctly by pitool but after a few minutes the mouse moves slower then it freezes the computer. Ingame or not changes nothing.

I have not this issue with the G2.

That’s the v1.0.1.270 Pitool version.

I will check the headset firmware version.

Have you tried one of the previous pitools?

I don’t know where to find them.

1 Like

Check this link. @playa’s link at the bottom of post has all pitool downloads available.


Link below for playa keybase.



Ok, thanks i will try it.

1 Like

Pitool 266 freezes…

Pitool 253 freezes too and almost as soon as i connect the headset.

It looks like the headset firmware update has not been a great thing.

Back to 270.

If i start Pitool then power the Pimax it freezes immediatly.

If i power the Pimax then start Pitool it freezes after 10 minutes the computer.

It looks like there is a bug with the firmware update.

My artisan is not usable.

I hope that this is not due to an hardware change in Artisans.

I did not have use it since one year probably.

1 Like

I would try reflashing the firmware. If that doesn’t help file a ticket. While waiting for assistance try maybe an earlier firmware.

If you upgraded or changed pc components there might be some kind of conflict.

Have you or can you test the Artisan on another pc?

The Xeon server which is not made for that.

1 Like

Is it missing some of the cpu instruction sets? Or no room to use even a low 970 gpu?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.