Pimax 8KX suddenly disconnecting/reconnecting

And here I was, happy, that everything finally worked!

The problems began when I tried to install the latest HMD-firmware (the one with the adjustable backlight). The update got stuck at 98% and I ended up in DFU-mode limbo. With the help of this great community here, I was able to solve the problem and finally install the latest firmware.

Yesterday, the newest SteamVR Beta even solved the compositor-scale issue where floating windows in Steam VR Home all appear blurry. So it seemed everything was running fine and, well, fine and pretty it was indeed with the cranked-up backlight.

But hey, wouldn’t it all be way too boring with everything running just like it should! Right, so here is the next issue.

Since yesterday, the 8KX disconnects and then reconnects while using it (usually happens after a few minutes of use). Usually, it’s unresponsive after reconnecting but still will show an image. I remember I faced similar issues when using the Oculus CV1 back in 2016. I strongly feel it’s a USB related issue. But then, why does it occur now, when I didn’t change anything system-wise in the meantime. It’s also not the SteamVR Beta. The disconnect/reconnect issue also happens with the most recent non-Beta version.

Any idea?

P.S.: This may be a dumb question but I have no idea which of those 2 USB-cables is the power supply cable. I guess the thicker USB-cable is meant for power-supply but I may be wrong…


Black (USB 2.0) is power only. Blue (USB 3.0) is data/power.


Have you checked device manager to make sure none of your USB ports have a yellow exclamation mark beside them?

1 Like

Make sure the cable is properly inserted at the headset end (even though it might not look like it is actually detachable it is).

Could be a slightly bad connection (if it’s not fully inserted) and with temperature change it’ll cut out.

1 Like

I had that problem with the USB ports on the old Asus Z97 motherboard. I played around with the USB settings and finally got more consistent connection by changing the following bios settings:
Intel xHCI Mode off
EHCI Hand-off [Disabled]


1 Like


We suggest you log a ticket at our helpdesk, and allow our technician to diagnose the problem.

And you may follow the tips provided by the community.


1 Like

I just connected the power supply USB-cable to a 5V 1600mAh Smartphone charger and now (so far) it works like a breeze. Even better than before actually. Previously when switching from Skyrim VR (big FOV) to SteamVR Home, SteamVR Home always acted strangely with parts of the screen being black, tracking issues, etc…

Now with the power supply connected to the USB charger, I could quit Skyrim VR and jump back to SteamVR Home without any issues. I know it’s definitely too early to call the issue fixed but so far it definitely seems so.

Thanks for all the help!


So issue might just be that Your PC (PSU or motherboard issue) isn’t up to the task of providing the needed amount of power on the USB port(s)?

Back in 2016, when I used the Oculus CV1, I remember there were some reports about my Asus ROG STRIX X99 Gaming MB which confirmed USB related problems with this MB-model (like USB ports not working with xHCI or USB ports that suddenly stop to work) . So I guess it has something to do with this…

1 Like

Hey I’m glad to see you’re responding in OpenMR today! I’ve been trying for days to submit several videos for the 8KX! Event without any success or response with instructions. I’ve registered every time I’ve gotten an email, but nothing happens after that. When I click on the submit button, a window pops up telling me I have to register. If you could solve this for me before time runs out and all of my hard work is wasted, I’d be most appreciative.

Update: currently it seems the disconnecting/reconnecting issue was not caused by a USB problem. Even after I connected the 8KX’s power USB cable with a smartphone charger I experienced the disconnecting/reconnecting issue.

But there is another thing that could have something to do with the problem. Recently, always when I turned on my Index controllers, SteamVR started automatically. So I didn’t see any reason to launch it additionally via the PiTool (which already was active at that moment). So I just began to play Skyrim VR. Then the disconnecting/reconnecting issue reared its ugly head. The last few days I exclusively launched SteamVR via the PiTool (Button “Start Steam VR”) and since then everything has been working fine. Who knows, maybe that could be the reason…


If you are experiencing the same issue after few attempts, we suggest you to log a ticket at our helpdesk.
Our technician will assist you to diagnose the issue.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.