Pimax 8KX stuck with yellow light - no changes

What’s the fix for the yellow-light-of-death? Pitool stuck with “10934” error

I haven’t used the 8KX in a few week. Tried it today and it’s stuck with a yellow light.


  • Removing Pitool
  • Installing several versions all with restarts
  • Different DP slots on my EVGA 3090 FTW3 Ultra
  • Flashed the M99 engineering firmware

What am I missing? Please dont tell me I have to send this back?

1 Like

Not sure I would suggest filing a ticket. Haven’t seen Yellow.

10934 I think might mean extend mode?

Have you tried pitool 271 and firmware 298?

PimaxVR Support

Main Site
  • Self Help Database
  • Submit a Ticket
PimaxVR Forum Support

This group consists of PimaxVR Staff Specialists for assisting PimaxVR Consumers with resolving Ticket.

Please follow this Procedure before Requesting help.

  1. File a Support :tickets: At
  • PimaxVR
    You should receive a response within x Business days.
  1. If you have not received a response after x Business days or Support personnel is having difficulty understanding your request. Please Direct Message(PM) this group requesting assistance.
  • Please provide the following Information:
    Support Ticket # & Details of issue.

if your support issue is Tech related please explore:

  1. Use Docs in Left menu to explore 2 & 3.
  2. Pi-Guides & Troubleshooting. (#guides )
  3. Community Support - review Solved and post question if needed. (#vrcentral:helpme )

I ended up letting Pimax update to 273, flashing the headset back to a Feb firmware, then letting Pitool autoupdate the fw. It’s back on the broken fw that flashes when selecting 90Hz. So the headset works at 75Hz but not 90. Not sure what changed as it was working before. NV drivers maybe?

The yellow light, let’s say it is “white”, is a feature of the latest firmware that I have also noticed, before when the 8KX was connected but in standby (without Pitool running) it was bright red. What happened to me with the yellow (white) led is that even if I turned Pitool on, it did not turn green in 90hz mode, all because of the cable, the poor quality of the cable and its degradation make it not support 90hz. It was to put the newly arrived fiber optic cable, everything solved.


The same here not happy


The “10934” error could be caused by the GPU, DP Cable, or driver version.

We recommend that you report this problem to our technical support team, who will inspect your setup and provide an appropriate solution.


1 Like

How do I add a ticket?

1 Like

Thanks. I’ll submit one. The weird thing is that the only thing that changes were NV drivers. It must be that


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.