Pimax 8KX/RTX 3090 lag on headset.....while no lag on the screen

Hi all,

I have just upgraded my pc to 5900X / Asus Dark Hero / Asus Strix RTX3090 / 32Gb Corsair CL14

My surprise is, now compared to my previous pc (8700K / Asus Maximus X / RTX 2080Ti), Im getting a big lag in the headset even in the Pimax Vr experience app…latest firmware and Pitools version are installed.

Same Pitools version in my other computer with a 2080Ti has not this lag issue…

You can notice the lag very easily while moving your hands (leap motion) or moving your body sideways or front/backwards.
Such lag does not exist in the screen monitor, so you can see a smooth movement in the screen while the lag its huge in the headset.

Any ideas? Anyone with a RTX 3090 getting the same issue?

Thanks in advance

1 Like

Ah, hi there. One Flaw is automated overclocking crap from Asus. I cannot recommend to use ArmoryCrate, it was a mess, need to deactivate in BIOS because it screwed Windows a little bit with each boot. I have a Zotac and the FireStorm tool is crap as well.
The Asus AI overclocker is the same, only in rare cases with exact the Memory and fitting CPU it seems to work for some users. For me, it did not, had similar effects, crashed immediately. Even with manual tweaking, You need to be careful or You face just unstable, jitters,loose tracking, breaks and freezes. May be the reason for Your issues, too?. For me, little tweaking only, but a stable system.


I have the original Alienware Area 51 R2 with a 3090 and I play Skyrim VR with 386 mods and it’s working great. When I was using the 2080 super it couldn’t handle it I I was lagging and doing all kinds of crazy stuff

Interesting, the only changing variable is the CPU or Videocard.

Can you try swapping the 3090 with the 2080Ti to see if the issue is still there?

if it is then you know its not the video card drivers

if it is the CPU then like @3D_FAN mentions it could be crap cpu software.

I recently upgraded too and now am on a 5800X and 2080Ti and have no such issues. But I never installed any overclocking software.

Huh? He basically replaced his whole PC (CPU, motherboard and GPU and probably memory too)…

Hi all and thanks for your replies!

I unistalled the Asus software ArmoryCrate and same bad results.

I have realised when starting the Vr Experience app, the first 2-3 seconds while its loading the floating menus, there is no lag at all while moving the hands, as soon as the menus are loaded…then the huge lag comes in…

Its a whole new PC. Next I will install the 3090 in the “old” computer and lets see.

I have tried with my HP Reverb 2, and the performance in the high demansing XPlane 11 (PP required), its outstanding…Im quite impressed to be honest, but using Pimax with this lag issue its a no-go for me for the time being…

I will update with next test results.


Quick update: I have to delay the installation of the 3090 in the other computer as I have to change the power supply and cables too…

Next its change the Bios of the mobo to default (now the Cpu its OC), if that does not work, a clean installation of Windows will be next step, and I will install only the Nvidia drivers and Pimax software.

I DO confirm that for a couple of seconds just after starting the Pimax Vr Experience software and BEFORE the floating menus are loaded, there is no lag at all, and as soon as the menus are loaded, the lag appears, being like if the HMD would be running at very low refresh rate (maybe 30 hz instead of 75hz…) as well as inconsistent tracking of the hands while moving them at a regular speed moving sideways…

1 Like


Clean windows and just Nvidia and Pitools: deselecting the option to see the mouse in Vr Experience and the windowed-screen mirrored in the monitor has fixed the lag and tracking issue so far. I will install the rest of programs and Ill update again.

Help: when trying to change the FOV using the Vr Experience has no effect, as when I click on “Save” on the left menu, it does not have any effect, being the only way to change the FOV, brightness, contrast or any other option in the left menu, is using the desktop Pitools program…any ideas? (I reinstalled twice the pitools and Vr Experience with same results).

Thanks in advance

1 Like

Doesn’t it change even if You restart Pimax Experience (it can be done from within PE)?

Not sure if it’s still the case but there was a bug (?) a while back (before PE even existed) that prevented You from going from small FOV and up to normal or large but it worked when doing it the other way round (large->normal->small) as long as You started SteamVR in large FOV.

Not sure if it’s the same thing with PE as I usually only use “normal” FOV… :wink:

1 Like

I’m grouping all of that as part of the CPU . :upside_down_face:

I’ve been out of VR for a bit but just tested with a very comparable setup to yours, 5950x, Dark Hero, Strix 3090 OC, and 64gb cl 16 g.skill ram.

I’m not experiencing any noticeable lag, but I’ve reset bios to optimized system defaults + docp (xmp) for other reasons so that might be something to try if you haven’t already.

Good luck.

1 Like

So, deselecting the Window mode in Vr Experience fixed the problem of the lag.

Regarding the left menu on VR Exp. for changing the FOV, contrast… was working after I installed at least one game. I restarted the Pitools and now I can change FOV as well as other options.

Performance in XP11 is no so good as expected (I guess due to PP required), in the other hand, with my new HP Reverb G2 new computer runs solid 45fps even while using Zibo :slight_smile:

So…I will have to keep the 8kx for non-PP games until Pimax gets more games compatible without using PP…its a pity…

Thanks all for your comments!

1 Like

Not normal. Something is still messed up with your drivers and such, or perhaps with lighthouse tracking.

Sounds like you and @Bluewings are hitting this known bug


try installing the fixed drivers and disabling monitoring tools


Thanks for advice.
Updated both PiTool and Firmware smoothly. Re-installed PE 0.84
Have no VRmonitoring tools running, now only AI suite III, which seem to do its job.
No real overclocking. CURRENTLY no issues with 8KX.
The little jitter remains as before, perceivable if you concentrate, but not bothering me.
I had no issues until now to start SteamVR any more. I do not know, if in applications, where I activated all eye candy, where the PIMAX 8KX is meant for, frame drops are related to a driver bug, or poor programmed app or just because of limited frame rate (due to DP1.4 limitations instead missing DP2.1)?
Will wait for regular update, no urgent need for this Nvidia patch from my side.

One thingi is, if You put of the headset, it goes into sleep mode, then You need to restart SteamHome, because it´s something stalled or partially frozen. Maybe a PIMAX Pitool bug or a SteamVRHome Bug, don´t know.

For me, PE always starts with white/empty steam app content from scratch, this is a bug, I had from the beginning. If You activate one of the white entries, all stuff reappears and remains then.

Another bothering issue is screensaver/screen lock, it may kick in if You do not open a VR app and timer starts screensaver, it changes audio and You need to restart SteamVR or PE to fix it. If You start via SteamVR, no issue. So You can “heal” it but inconvenient and annoying.

But, overall, cool stuff.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.