Pimax 8KX "Not Tracked”

Hi all,
My 8KX was working fine, I then decided to follow the instruction at this link to improve visuals:


I ran the program that was specified:

EDIT: You might want to try running @BNP script:

How To Make Your Pimax Image/Picture/Screen Clear/Crisp (Increase Clarity)
I have a program over here that will sets the steamvr.vrsettings in the correct file automatically maxRecommendedResolution = 16384; GPUSpeed’s = 2000; gpuSpeedRenderTargetScale = 1.5m; allowSupersampleFiltering = false; supersampleScale = 1; direct link: https://github.com/craftyinsomniac/WFOVFix/releases/download/v0.1/WFOVFix.exe

After running this and getting the following output:

Found the configuration file at C:\Program Files (x86)\Steam\config\steamVr.Vrsettings

The following values has been updated or added to the configuration file.

“GpuSpeed.GpuSpeed0” = 2000
“GpuSpeed.GpuSpeed1” = 2000
“GpuSpeed.GpuSpeed2” = 2000
“GpuSpeed.GpuSpeed3” = 2000
“GpuSpeed.GpuSpeed4” = 2000
“GpuSpeed.GpuSpeed5” = 2000
“GpuSpeed.GpuSpeed6” = 2000
“GpuSpeed.GpuSpeed7” = 2000
“GpuSpeed.GpuSpeed8” = 2000
“GpuSpeed.GpuSpeed9” = 2000

“GpuSpeed.gpuSpeedHorsepower” = 2000
“GpuSpeed.gpuSpeedRenderTargetScale” = 1.5

“steamvr.maxRecommendedResolution” = 16384
“steamvr.supersampleScale” = 1
“steamvr.allowSupersampleFiltering” = False

Would you like to save the changes? (y/n)

Done. Press any key to exit.

Now no matter what I do I cannot get the “Not Tracked” message to go away.

I have tried everything:
Re-Installed PiTools
Restarted HMD
Restarted Service
Re-booted PC many times
Powered of and on the Base Stations
Powered of and on the HMD.

I have opened a Support Ticket yesterday and I’m currently awaiting a response from Pimax.

Has anyone here experienced similar issues?, Can anyone here assist?

GPU Driver Version: 456.55
Pitool Version: V1.0.2.084
Firmware: V2.1.255.292

System Configuration:

CPU Specification Intel(R) Core™ i5-6600K CPU @ 3.50GHz

Mainboard Model Z170MX-Gaming 5

Manufacturer (ID) G.Skill
Memory Type DDR4
Memory Size 32 GBytes
Specification DDR4-3200
XMP #1 16.0-18-18-38-56-n.a @ 1600 MHz (1.350 Volts)


Drive 0
Type Fixed
Name WDC WDS100T2B0A-00SM50
Capacity 931.5 GB
Volume c:, 930.0 GBytes (56.0 percent available)

Drive 1
Type Fixed
Name ADATA SU800
Capacity 953.9 GB
Volume d:, 953.9 GBytes (3.1 percent available)


Display adapter 0
Name NVIDIA GeForce RTX 2080 Ti
Board Manufacturer NVIDIA Corporation


Windows Version Microsoft Windows 10 (10.0) Professional 64-bit (Build 18363)

I’m sorry you’re having issues with your tracking. My program does litteraly nothing but update those values in the steamvr.vrsettings file though so I seriously doubt that has anything to do with your tracking issues.

If you think it will help you can always just delete your “C:\Program Files (x86)\Steam\config\steamVr.Vrsettings” file and steamvr will make a new one with the default values.

Good luck.

1 Like

I get this tracking issue all the time, the only way to fix is is unplugging both usb cables, the. Plugging them back in but switching the port of the usb 3 cable to a new usb 3 port.


I am also get no tracking and the lighthouse icon keeps flashing in pitool until i hold the headset and put it behind one of the lighthouse it will tracking immediately also i should put my lighthouses one in channel b and the other on channel c

im not sure but also can be related to usb bandwidth related issues.

did you try in pitool to switch temporary to 9 aof tracking & back? try to set upscale mode & switch back

  • to do “Pimax dance” as others proposed above (google for it). And change usb ports.

“Pimax dance” lol my VR shuffle happens almost every time I want to show someone something. Its definitely not for everyone!

1 Like

I have no X, have 5k+, 8k & 5kXR, never did a single dance though, I have 2 x base stations v1 & 2 x valve branded base stations v2 (green lights) all those HMDs work ok on those stations, once I start pitool it itself start track even if HMD is put on a surface in static place. I just recall some other ppl had this tracking problem & “Pimax dance” helped, so might be related.

I had very bad usb bandwidth problem in the past with my CV1 as I had 4 & then 8 IR tracking stations (2 rift were connected in 2 simultaneously run OS on the same PC). So I bought separate pci express usb cards + debugged usb a lot, i believe it can be realated somehow, so having usb problems free PC hardware can help with tracking

1 Like

Hi @kinitex,

Thanks so much for the assist, I unplugged both usb’s and re-plugged them and the tracking started working again.

I didn’t even change ports, I just put them back where I had them before.

I have original Vive and 5K+, it seems this 8KX is more finicky than the others, I actually kept losing tracking again and decided to move my V1 Base Stations a bit to see if I could improve tracking.

Something that happens every time I go to tighten/loosen the HMD or adjust the IPD, the headset will do that weird warp and go blank, once I take my hands away it comes back to life. I’m pretty sure the tracking thing is doing that.

This is a little bit frustrating as this has not happened with any of my other headset, with the base stations where they were (Diagonally facing each other).

But, Thanks again. I really thought this thing was toast.

1 Like

Hi @BNP ,

Yes, it of course turns out it was just a coincidence that the HMD started experiencing this issue right after I ran your program.

The crazy thing is I didn’t have any of these problems when I first connected and played with the 8KX, I was in and out of Half Life and wanted to see if I could improve the visuals a bit.

I can tell from moving my head around and reading text that there is more clarity in this HMD, but I’m having lots of trouble getting it dialed in.

I purchased prescription lenses for the 8KX, Adjusted the IPD as much as I could, but there has to be more as the image is sometimes very clear depending on position and viewing angle.

1 Like

IIRC most/all of the sensors on the Pimax headsets are placed at the corners. This means that the majority are at/near the sides of the headset and get covered up when you put your hands at the sides of the headsets (hence the loss of tracking).

Thanks for the info, this 8KX seems so fussy about these things.

i also need to do this sometimes… its annoying

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.