Pimax 8kx not connecting via 4090 dp connection

so i previously had my 4090 working on my old build i9 9900k , just upgraded to a ryzen 9 7900x with a rog strix x670e MB , got everything installed ready to try the new build but the 8kx wont connect to the 4090 , usb dose fine cause im able to load up a different firmware , ive tried everything in the span of 5 hours from nvdia drivers to bios to pitools and firmware but i cant get anything to work , any ideas

Strange i hope you get it too work…And if you do, i realy like to hear what you gain in performance with the proccesor upgrade

so as a last resort I tried the Pimax Client v1.6.0.18 to see if it would connect , and it did butt it wont recognize any base stations , so I dont have room setup and its locked at 90hz with no other options , so it could connect with client no stations but not in any pitool , pimax this is frustrating please fix it

Hello why did you go for the ryzen and not the i9 13900k?

good question , knowing the ryzen 9 x3d chips are gonna be out next year i figured stick with amd the 7800x3d should be alot better for gaming then the 13900k once it comes out, but i have heard intel has better vr support not sure if theres alot of truth to that , but here I am

2 Likes

Hello,

It might related to the firmware, port and drivers.

I would suggest file a ticket with our tech specialist, and allows them to perform a thorough troubleshooting on your setup.

1 Like

thanks ive been emailing with pimax about this issue , I decided to try a on screen game to see how the new build would go once i started the game it initialized VK software or drivers it caught my eye played the game DOOM eternal then went to sleep , today i just tried the 8kx to see what would happen then it connected to dp port firts time with pitool , not sure why the only thing i did different was install a doom and maybe with the VK initialized it worked , but still dont have base stations working they get detected if i turn on my controllers but wont work , why dose pimax have to be so buggy