Pimax 8K X DP Disconnected error

I received my 8K X several weeks ago, but only just finished the PC build itself. I have submitted a support ticket (#23807), but realize it’s CNY today. Hopefully my support rep is enjoying some holiday and not worrying about my problems. I’m past the 14 days (not sure why exactly that’s significant, but it seems to be), though it only came out of the box three days ago.

I immediately replaced the cable from the original 2xUSB cable with the new 1xUSB cable. I installed PiTool v274 and plugged in the HMD. USB connected, but no DP. I tried a few things, but then remembered Kaspersky has Webcam Protection on, so I turned that off. Then it connected, so I assumed at the time that fixed the issue. It remained connected and I was able to complete the setup and put the HMD on to look around at the planet scene.

Then I installed SteamVR, but I was stuck in that loop where SteamVR would crash and you have to unblock the two modules (Pimax and Controllers). Then restart, only to have it crash and quit. It was tracking in PiTool, but nothing working in SteamVR. I forget what happened in the interim, but then I noticed it was no longer working in PiTool, either. USB is working, but DP shows disconnected. I get the 10600, 106XX, and 109XX (10936) codes and the Diagnose tool says to plug in DP/HDMI.

I tried all three of the DP ports on my 3080ti, all of which are otherwise known to be working fine, but that made no difference. I also tried different USB ports (3.2 on the motherboard and 3.0 on a PCI card with SATA power). So I reinstalled PiTool 274 but made sure I had Kaspersky AV paused (installer run as admin, FWIW). No change. Next I tried PiTool 270. No change. I tried the original 2xUSB cable. No change. I went back to the 1xUSB cable, no change. Tried PiTool 274 again, no change.

I will try another PC and see if it happens to work there, as well as a few other suggestions (thanks to u/FaySmash over at r/Pimax_Official).

Any solutions or other ideas how to troubleshoot this?


Welcome to the OpenMR!

Can you post your system specs?

Are you running Windows 11 as there have been reports of issues overall.

A recent update posted in Pimax Official; they have released pitool 275.

1 Like

Indeed I am using Windows 11

Thank you, I will check out version 275!


Your welcome. It might be Windows 11 that is the culprit. If you can you may want to install Windows 10. Especially if the other pc you try is working with W10.

1 Like

I have had this same problem since PiTool 270 (approx). Run SteamVR and re-enable the Pimax headset and EXIT; do NOT restart. Reinstall PiTool. Start a game.

If there are no disconnects (it works like it should), always reinstall PiTool prior to running a VR app or game, if you’ve rebooted your system or switched the headset off. If you forget, go back to step one and re-enable the headset in SteamVR.

It’s a bit of a pain, but I’ve been doing this for months. I skip the reinstall whenever I switch to a new PiTool version, with the hope that the bug is fixed, but it’s still broken with PiTool 274.


When I replaced the DP cable with an optical cable, I had to install a USB hub with a power supply due to lack of USB bus power.


I have been using a 5k super for months without and problem so I know how a pimax headset works. Then I ordered a 8kx. My pc is strong enoug for a 8kx I am sure. Intel i10700, 48GB DDR4, GF 3080 vga, 750W PS. All USB ports are 3.1, 3.2. DP port is 1.4. So my pc is not a problem.

When I firstly connected 8kx to my pc, pitool worked well but there was not upscaling mode and 3 color options of front light. There was not 4 options of FOV only 2 options. Normal and small. Where is large?

I thought it was an older FW so I downloaded the latest 299 from pimax.com. Updated fw with DFU.exe and everything seemed good. Restarted hdm and pitool. Pitool did not see the hdm anymore. It said usb and dp did not connect. Hdm led changed to permanent white.

Then I read lot of guides how to change fw in DFU mode. I did every single steps but hdm still dead. There is only one version that works but it is too old and everytime wnen I put this version on hdm and start pitool, automaticly start a firmware update and put a wrong fw back on it. I tried it without internet connection but pitool started the update a wrong fw in the same way. So at this moment I can switch on and off my hdm, status led and main switch are operational but I can not connect it to pitool because a damn auto firmware process is starting unstoppably. No answer no option just starting and the end of process the freezed hdm with permanent white led is the result.

All fws result permanent white or red status led, only this one seems good: 8KX_RELEASE_290-V4.0_For_P2N3.0.dfu

I have 25 years in IT profession so I do not think this is the way how a 1200 euro headset should work. :frowning:
I made a ticket but due to the chinese new year no1 reply. I am really really disappointed about this so all good advices are appreciated.


Welcome to the OpenMR!

I have bumped your user level and fixed a system error that flagged your account.


Twice, with a couple of months between,I have had my 8KX stop working and rebooting my system as soon as I plugged in the USB cable! On both occasions the fix was to reinstall the NVIDIA drivers. Did a clean install and everything worked fine after that. Might be worth a try if you have not tried it yet:)


Thank you for the advice. And yes, I have tried to clean reinstall more driver versions.
It is obviously hdm error and not depend on nvidia drivers. My notebook has a poor intel onboard vga and exactly same result if I connect hdm on it.

1 Like

I uninstalled PiTool 274 and SteamVR. Then I installed PiTool 275 and clean-installed the latest nVidia drivers. Reinstalled SteamVR.

I have tried the USB connected to a powered 3.0 Hub, a powered 3.0 PCI card, an unpowered USB 3 to C Hub, and the motherboard 3.2. The only one that isn’t recognized in PiTool is the powered 3.0 Hub. Everything else at least shows connected in PiTool. DP is no longer ever connecting. The error that shows on the Status screen is 10934.

If this is a Windows 10 vs 11 thing, my only real option is to just wait for Pimax to sort that out. I’ve put too much time and effort into tweaking Windows 11 to go back. That would be very disappointing, since work picks up in mid March and I really don’t have time to use my computer again until November. Needless to say, I’m hoping for a quicker resolution than that, but it is what it is. I’d just have to go back to the Rift S for now and let the 8KX potentially go an entire year without ever getting to use it. C’est la vie.

EDIT: Is there any way to confirm that the USB cable is providing enough power? Since I can’t get a DP connection, does the fact that I am not seeing a 10500 error indicate that it’s getting sufficient power? Or is that really only verifiable when you’re using the HMD in VR and not getting drops or crashes? I’m just wondering if I should puchase a powered USB 3.2 to C Hub or something. Especially if there are known hubs that are working for people.

Not sure if it will work. Try Windows Compatibility Wizard on pitool and SteamVR set to w10.

W11 imho is not worth updating too until there are more adoption with drivers and such.

1 Like

Pimax Support got in touch with me today and suggested I disable the integrated GPU on my motherboard. Sure enough, that did the trick. That never would have crossed my mind, but PiTool now sees the HMD every time.

I still had trouble in SteamVR, but eventually I got the crash-unblock-crash loop to stop. I think it was from launching SteamVR from PiTool rather than from within Steam. Does anyone know if that could be relevant?

But I’m up and running for the moment. Tracking in PiTool was fine, but very laggy in SteamVR. Maybe I need to do some more setup in SteamVR or something. I’ll look into that tomorrow.

Thanks for all of the help here!


Hey Guys,

I am here to inform the interested forum members about my 8kx. It is back online. The solution was not the new vga, reinstall windows, reinstall nvidia driver, disable mainboard vga. The solution is a special firmware version thas was sent by Pimax support. I have never seen this version around the Pimax user’s tales.

It is a special V2.1.255.2001.
File name is: P2_DEBUG_8KX_N7_0_M299_t20211203180915_rc879f9b_90only.dfu

So my 8kx can work only with this firmware. I have no option to change an earlier version or so. I am not sure what happens in the future, when pitool wants to auto update its firmware.

Bad thing is I do not have upscale option, and no options for 3 color of front stripe led. Other bad thing is my first impression not too good. Picture quality just hardly better than 5k super. Maybe I can improve it with tons of parameter setup so it is not a final opinion.

Thank you all of you guys for your kind help and advices!


The missing options is quite alarming. Is it still only 90hz native refresh? Has the FoV options now give you all 4 options(potato, small, Normal and Wide)?

The degrade in visual quality is also disconcerting.

1 Like


The visual quality is a subjective thing. I was hope the quality of HP Reverb 2. But it is obviously worse and a bit better than 5k super I guess.


2001 appears to be new firmware currently under development for the 8KX. It seems to be unreleased and only appears pre-installed on some new 8KX purchases for reasons unknown. Perhaps a new internal revision of the 8KX hardware requires this new firmware (which would explain why all older versions of the firmware do not work on your unit) or perhaps the inclusion of this firmware on some newly shipped 8KX’s was a mistake. In either case, it seems that support has offered you a development build of the firmware because they believed it would fix whatever underlying technical problem you were having, and it seems to have worked.

I suspect that you’ll actually be okay on newer firmware releases in the future because presumably whatever you got in this development build that fixed your problem is what’s coming in those future official releases.

That the firmware is titled as “90only” suggests that there may be a different fork which is not 90Hz only as you have suggested in a previous post.

Perhaps Pimax is going 90Hz only for newer customers (such as seems to be indicated by their website advertising updates) but are splitting off firmware for older customers which retains previously advertised capabilities for them (lower refresh rates, upscaling mode, etc) so as to avoid taking those away. In such a case, the previous firmware fork would likely be maintained as bug fixes only. While the new 90Hz only firmware is where all new features and development goes.

I think that trollTraktor has no prior experience with the 8KX, so his comment is not relative to the older firmware. More likely he just needs to get his 8KX dialed in properly.


The 90hz only in the firmware could be like the many flavors they had for 299 while in development as there was one for desktop and one for laptop.

Either way not a good idea to ship new 8kXs with experimental firmware pre-installed. These units should have been not shipped until a proper stabke firmware was ready. No wonder new owners are having bad out of box experience.


I am pretty sure my headset came with a different firmware like this because pitool immediately auto updated it on the first connection. Now pitool does not want to install any other version on it. So it was a simple pimax mistake to sent me with a wrong fw. version. Interesting when Pimax says on 8kx’s item page: Pimax’s Revolutionary Upscaling Technology however upscaling is not supported anymore on new headsets.


Indeed not good to advertise features that are unavailable. They made the same mistake at launch advertising the 120hz upscale mode that took months to implement and ended up only being 114hz.

1 Like