Pimax 8k problem no game display just grey screens and luminosity blinking

Hello guys

While I’m still waiting for my 5k+ (Pimax support sent me a 8k while I asked for a 5k+ even though they aknowledged for a 5k+ via email) I have a big problem with the 8k

I used it for less than 10 hours since I received it (not at home due to work) and today I wanted to test brainwarp ! :slight_smile:

So I started my computer and first I noticed I have a windows information message indicating I have a problem with a usb peripheral lacking power, something like not enough power, but when I click on the message no more informations from windows. But everything seems to work fine.
But being suspicious, I decided to check if everything was fine before upgrading pitool and firmware update not to damage anything.

Currently, I’m still with pitool 0.91 and the previous old firmware.
I decided to give it a try and launch beat saber for a quick game to be sure everything is ok. So I run pitool and check my settings, everything seems OK, just headset tracking being a little upset, Pitool saying pimax 8k is loosing tracking almost every second but anyway I run Steam VR and see it make an upgrade to version 1.2.10.

So I decide to reboot the computer and run beat saber to check everything is working correctly before upgrading pitool and firmware.
Computer reboots without problem and I try to launch beatsaber

But now I have 2 big problems:

  • Screens luminosity is modulating as hell, even sometimes the Pimax logo (with the dark blue sky and stars) is desappearing. I checked the cables, pushed on the cable connection on the headset, tried other usb port, unplugged power supply, changed DisplayPort, nothing changes. Like this:
    Pimax screen luminosity problem - YouTube

  • when I try to run a game from pitool or try to run steam vr home, it doesn’t work at all. I just have grey screens with rarely blinking images of the game/steamvr home. If I activate mirror screen in steamVr, I have exactly the same thing as on my pimax screens, a grey blinking image as you can see:
    Pimax Grey and flickering screen - YouTube

I don’t know what to do now, is it a known problem ? Is there a problem with the last steamVR version ??

Please help ! :cry: :sob: :sob: :sob:

I tried to move the ipd wheel, even this doesn’t work correctly:
Pimax 8k problem - YouTube


Have you tried to disconnect as many USB devices as possible? It could be that there’s not enough power to one or more USB ports/buses. I would also check the Pimax power supply or try another one.


I gonna give it a try thank you.

I was checking it deeper and I discovered my angles are cracking too… :sob:
Backer #496

thank you for your answer @asonkin65
It seems like one of my other usb peripheral is dying on me, I unplugged everything except the pimax, and it looks like it is working again perfectly.
My daughter has to use the computer for his homeworks so I’ll explore this problem later when I can access this computer :slight_smile:

But I’m a little bit happier, I thought my pimax was dying :slight_smile: but maybe it’s still kicking after all!

Thank you again ! :slight_smile:

1 Like

@CyrilJ You’re welcome! It may not be a problem with USB peripheral, or a problem at all. It depends on your mainboard and USB ports configuration, you probably connected too many USB devices (like external hard drives that takes power from USB) to the same USB bus/controller. There maybe few buses/controllers on you mainboard and they normally have limited power supply from mainboard. You can try to use powered USB hub or move the USB devices to other ports.

1 Like

I made some tests, it was my Bluetooth USB dongle that died.
Removed it and everything is ok now !
I even updated my pimax with brainwarp, I’ll try to make some tests this week with my 2080Ti :slight_smile: