Pimax 8K+ Failed FW Update and will not boot


My Pimax 8K+ was working fine. I used Pitool to update Firmware. The update failed and says “Contact Support” and now will not boot. Just flashes Red/Green on the LED.

I searched the topics and found a Piplay flashing tool from 2018. Will this still work in 2020 or is there another way to restore?

Thank you!

dfu mode for flashing is a 3 color code
pitools have a flashing programm
C:\Program Files\Pimax\Runtime\dfu.exe

you usually stop pitool service and when already in dfu mode (3 color blinking) then you can start flashing the firmware (check device manager, there should be the hmd as deive in dfu mode, if its a unknown device then the driver for dfu mode is missing)

If the headset doesn’t react anymore at all you can try to set it to DFU mode manually. I also ran into this situation once with my 8kX and this helped. This video describes how to do this. (Instead of plugging in the power cable one has to plug in the USB cable that powers the device for newer Pimax headsets after putting the finger on both volume buttons and on, as described)

Thank you. Tried this and didn’t work. Says “Device Not Found”. Anything other suggestions?

You can try my method here. I had red, green, blue lights, but I was able to finally get it working using USB ports on a different computer.


1 Like

i solved this problem by deleting my pitool folder and reinstalling

IIRC another user reported that none of tips they found could get it update properly on their original PC but that they were able to fix it by swapping the headset over to another PC.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.